Results 1 to 5 of 5

Thread: Restore to a new(different) server

  1. #1
    Join Date
    May 2006
    Posts
    9
    Rep Power
    9

    Default Restore to a new(different) server

    What are the exact steps to take to restore Zimbra Network Edition to a completely different box. We are trying to come up with a disaster recovery plan should the orginal Zimbra server completely fry. We are running on OS X 10.4.6.

    Steps:
    1. Install OS
    2. Install Zimbra

    This is where it gets fuzzy. Do we run /opt/zimbra/libexec/zmsetup.pl at this point and put all the info in like it was the old server?

    I have and when I do a restore using zmrestore -s server.domain.com -a all -br, the address book is not complete, the COS is wrong and the Zimbra Admin Interface complains no such server.

    Should we use zmrestoreldap and zmrestoreoffline?

    The Zimbra Admin Guide seems a little fuzzy about restores.

    I need the EXACT steps to carryout to resotre to a completely different box.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Took this information from a recent question of the same topc in our support system:

    Here is some more detailed information for you...I'm running through this procedure using 3.1.3, so you'll probably want to upgrade your current box before making the move.

    1. Upgrade current box to 3.1.3
    2. Set up second box in parallel...mine has its own DNS server so it thinks its authoritative for itself. The new box has the same hostname as the old box, though a different IP address. When installing Zimbra, make sure you set up the same admin account. It's also nice to use the same spam and notspam accounts, just to keep the transition smooth. After the installation is complete, the new box will have the admin account and two spam accounts looking identical to the first box.
    3. Back up the first box. zmbackup -f -a all
    4. Tar up the backup directory. DO NOT JUST GET THE SESSION. There are some shared blobs that are used for multiple backups, and you don't want to miss those. It's easiest to tar up the whole deal and FTP or SCP it over to the new box.
    5. Take down the first box. Untar the backup tarfile on the second box into the /opt/zimbra/backup directory. You want this to look the same as the backup directory on the first box.
    6. Run 'zmrestoreldap' to restore the directory. This needs to be run with the Zimbra services down. This will load the distribution lists and account info.
    7. 'zmrestore -a all -c -rf' What this is doing is restoring all accounts, including their entries in directory services, skipping any errors (like the admin and spam accounts), and only restoring from the full backup. This prevents the new box from trying to run any redo logs that it has sitting around.
    8. 'zmrestore -sys' This will restore any local system configuration changes that were present on the old box. You could probably also do this by adding -sys to the zmrestore in step 7, but I didn't want to complicate things.

    When this is all done, the new box should be ready to go up in place of the old one. You can change its IP address over and switch it back to using standard DNS, and move the old box fully offline.

    This worked okay for me in testing, but obviously you'll want to run it through and check out the accounts before bringing the old box totally offline.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Oct 2006
    Posts
    12
    Rep Power
    9

    Default Different Hostname

    How would you handle a restore to a machine with not only a different IP, but a different hostname as well? Same steps as above, but with modifying the:

    /opt/zimbra/backup/ldap/$SESSION-NUMBER/ldap.bak


    file so that the Zimbra server's LDAP CN is changed?? (Along with with Admin user).

  4. #4
    Join Date
    Jul 2006
    Location
    KL, Malaysia
    Posts
    123
    Rep Power
    9

    Default

    how about same migration of multiple zimbra servers with external ldap (zimbra ldap) combined into one all-in-one server.

    can use the same step?

  5. #5
    Join Date
    Jul 2006
    Location
    KL, Malaysia
    Posts
    123
    Rep Power
    9

    Default

    just to enlighten us forumers!

    just migrated my multiserver installation to a new single server setup via zimbra NE 4.0.4 from 32bit to 64bit. the new server retains the ip and hostname of the old MX.

    here's what i did :

    1. create a nfs share on the new server. mounted at the main old server
    2. zmbackup -f -a all -t /mnt/shared-nfs/backup
    3. tar -cvf amavis.tar /opt/zimbra/amavisd-new-2.4.1/
    4. tar -cvf dspam.tar /opt/zimbra/dspam-3.6.2/
    5. mv *.tar /mnt/shared-nfs
    6. by right, now all the backups is ready at the new server
    7. install new zimbra, setup domains, virtual domains, install license
    8. logon to admin & rename admin account to something else
    9. tomcat stop
    10. zmconvertctl start
    11. zmrestoreoffline -a all -rf -sys -t /the/shared/dir/backup
    12. zmcontrol start
    13. verify accounts are ok.. documents.. calendars.. etc..
    14. zmprov gacf | grep -i spamis & remove unnecessary spam learning acc
    15. zmcontrol stop
    16. mv original amavis/dspam to something else
    17. untar the old amavis/dspam
    18. zmcontrol start/status


    basically thats all.. new setup running fine using the ever great dspam/bayes db! no point of migrating and leave behind ur hardwork of learing spams/hams behind right?
    Last edited by scalper; 12-05-2006 at 11:16 AM.

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 11:27 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  4. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  5. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 10:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •