Results 1 to 9 of 9

Thread: postfix issue

  1. #1
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default postfix issue

    After I restart the server and the pc when I send an email I got this "error":
    Jun 22 21:42:50 linux postfix/smtpd[12744]: initializing the server-side TLS engine
    Jun 22 21:42:54 linux postfix/smtpd[12744]: connect from unknown[201.215.213.14]
    Jun 22 21:42:55 linux postfix/trivial-rewrite[12747]: warning: do not list domain subox.zapto.org in BOTH mydestination and virtual_mailbox_domains
    Jun 22 21:42:55 linux postfix/smtpd[12744]: 23E46556B6: client=unknown[201.215.213.14]

    Before the restarting the client was ok
    what cold be the reason of this???
    P.S. Im still able to recive and send mails

  2. #2
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    are you concerned about the trivial-rewrite warning?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    yes indeed
    and about its not recognize my server in this line
    Jun 22 21:42:54 linux postfix/smtpd[12744]: connect from unknown[201.215.213.14]

  4. #4
    Join Date
    Jun 2006
    Posts
    28
    Rep Power
    9

    Default

    When I add a new line in "main.cf"
    Code:
    mydestination =
    The error
    Code:
    postfix/trivial-rewrite[12386]: warning: do not list domain myhost.com in BOTH mydestination and virtual_mailbox_domains
    won't appear.

    If I add
    Code:
    mydestination = $myhostname
    The error will appear in the log.

    What's happened in the behavior?

    I noticed the main.cf.default. Some default setting will load form this files. If you want to use the custom setting, you should add the setting in the main.cf. Then reload the postfix, it will work.
    Last edited by victorLeong; 06-23-2006 at 02:38 AM.

  5. #5
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    re: don't list in both virtual_mailbox_domains and mydestination - that's a bug in our install. Since Zimbra uses the virtual_* address lookup mechanisms (for the record, but not related to this topic: we do not use virtual transport backend), if your server hostname matches your mail domain, then our install should be setting mydestination to be just "localhost, localhost.localdomain". If you could please file a bugzilla on that (it's not that I am lazy to file it myself - kevinh and I insist that you guys file it because it carries more weight...).

    Re: host unknown, looks like you might have enabled reject_unknown_client: check the admin UI, or check postconf smtpd_recipient_restrictions (nb: in a Zimbra install main.cf is periodically updated from data in LDAP, specially smtpd_recipient_restrictions - so best is to edit from admin UI and restart postfix.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #6
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    I do not have the option reject_unknown_client enable
    the unknown client is my own server where is installed zimbra!!
    about the other to options i didn find out where there are

  7. #7
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    I forgot to mention another issue after upgrading to 3.1.3 that everytime I restar postfix change the owner
    After the upgrade I cannot tail the /var/log/zimbra.log is there a way to solve this??
    Last edited by kowell; 06-23-2006 at 02:35 PM. Reason: another problem

  8. #8
    Join Date
    Jun 2006
    Posts
    28
    Rep Power
    9

    Default

    Quote Originally Posted by anand
    re: don't list in both virtual_mailbox_domains and mydestination - that's a bug in our install. Since Zimbra uses the virtual_* address lookup mechanisms (for the record, but not related to this topic: we do not use virtual transport backend), if your server hostname matches your mail domain, then our install should be setting mydestination to be just "localhost, localhost.localdomain". If you could please file a bugzilla on that (it's not that I am lazy to file it myself - kevinh and I insist that you guys file it because it carries more weight...).

    Re: host unknown, looks like you might have enabled reject_unknown_client: check the admin UI, or check postconf smtpd_recipient_restrictions (nb: in a Zimbra install main.cf is periodically updated from data in LDAP, specially smtpd_recipient_restrictions - so best is to edit from admin UI and restart postfix.
    mydestination have three arguments in the main.cf.default
    Code:
    mydestination = $myhostname, localhost.$mydomain, localhost
    remove $myhostname to fix the bug, right?
    Last edited by victorLeong; 06-25-2006 at 03:31 AM.

  9. #9
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    After doing some manuals configurations i dont have more alerts from postfix or unknown clients
    first of all from the admin gui I change the web mail MTA hostname from my domain to localhost and in the main.conf I added mydestination = localhost, "my pc name"
    for example localhost.localdomain for redhat or linux.site for SuSE
    After that even my email delivery and reception has speed up

Similar Threads

  1. Replies: 3
    Last Post: 11-03-2007, 10:55 PM
  2. Zimbra-cluster and Mailman issue
    By briansrapier in forum Administrators
    Replies: 2
    Last Post: 08-01-2007, 05:35 AM
  3. Zimbra 3.1 Postfix Issue
    By csyperski in forum Installation
    Replies: 2
    Last Post: 05-23-2006, 06:35 AM
  4. unable to restart zimbra after reboot
    By droefs in forum Administrators
    Replies: 28
    Last Post: 04-16-2006, 02:33 PM
  5. Intermittent issue (issue# 5852) ?
    By nick20 in forum Installation
    Replies: 1
    Last Post: 02-08-2006, 01:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •