Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Zimbra and Glpi ldap integration

  1. #1
    Join Date
    Nov 2009
    Posts
    1
    Rep Power
    6

    Default Zimbra and Glpi ldap integration

    Hello all,

    Is it possible to make Glpi user authentication from Zimbra's user database?

    I don't want to create users in Glpi database. I have already running Zimbra in my network. All Zimbra users can log in to Glpi that all I want.

    Thanks.

  2. #2
    Join Date
    Nov 2009
    Posts
    1
    Rep Power
    5

    Default

    G'day all

    well I had the same task today and i was able to finish it thanks to the glpi documentation here: GLPI-Wiki/wiki/doku.php?id=en:ldap

    just remember to install any missing library and keep in mind that the Zimbra's LDAP is just a normal LDAP, read and follow the instruction and you'll be able to do it too

    cheers

  3. #3
    Join Date
    Feb 2010
    Posts
    14
    Rep Power
    5

    Default

    I read the instructions but I can not make it work.
    What am I supposed to type into the Login Field? This is just for AD right?

    Connecting to the LDAP with Thunderbird or the java LDAP Editor\Browser would require the same settings and they work fine....

    Thanks for any suggestions!

    Josef

  4. #4
    Join Date
    Oct 2009
    Location
    Ukraine
    Posts
    79
    Rep Power
    6

    Default

    Quote Originally Posted by Josef View Post
    What am I supposed to type into the Login Field? This is just for AD right?
    I use GLPI with Active Directory and provide user logon name (samaccountname) in GLPI "Login field".
    samaccountname not exist in Zimbra LDAP, so try use "uid".
    And change GLPI LDAP Authentication "Connection filter" from default "(&(objectClass=user)(objectCategory=person)(!(use rAccountControl:1.2.840.113556.1.4.803:=2)))" to some like:
    (&(objectClass=zimbraAccount)(zimbraAccountStatus= active))

    Good luck!

  5. #5
    Join Date
    Feb 2010
    Posts
    14
    Rep Power
    5

    Default

    Thanks ChaSer, but unfortunately "uid" did not solve my problem.

    I know that I just can connect to the LDAP using protocol version 3, does GLPI support that? (Or can I force it to use LDAPv3?)

    Thanks again!

  6. #6
    Join Date
    Feb 2010
    Posts
    14
    Rep Power
    5

    Default

    I figured it out. It's a bug.

    If the password contains the symbol ">" it gets stored wrong in the mySQL DB.

    May I ask one more question please?

    When I search for users, none are found. When I search for groups, all the users are found.

    What am I doing wrong? Thanks again!

  7. #7
    Join Date
    Oct 2009
    Location
    Ukraine
    Posts
    79
    Rep Power
    6

    Default

    Configuration of GLPI 0.72.3 thats works for me with Zimbra's 6.0.5 LDAP. Just tested :
    Basedn: <leave empty>
    rootdn (for non anonymous binds): uid=zimbra,cn=admins,cn=zimbra
    Pass (for non-anonymous binds): <password>

  8. #8
    Join Date
    Oct 2009
    Location
    Ukraine
    Posts
    79
    Rep Power
    6

    Default

    Quote Originally Posted by Josef View Post
    When I search for users, none are found. When I search for groups, all the users are found.
    Are You search in GLPI (in which menu) or somewhere else ?

  9. #9
    Join Date
    Oct 2010
    Posts
    7
    Rep Power
    5

    Default Zimbra and Glpi ldap integration

    Hello all,

    Is it possible to make Glpi user authentication from Zimbra's user database?

    I don't want to create users in Glpi database. I have already running Zimbra in my network. All Zimbra users can log in to Glpi that all I want.

    My Configuration is -

    Name : Last update : 12-12-2011 14:13
    Default server : Active :
    Server : Port (default=389) :
    Connection filter &(objectClass=zimbraAccount)(zimbraAccountStatu s= active))
    Basedn :
    rootdn (for non anonymous binds) : uid=user,ou=people,dc=rcorp,dc=in
    Pass (for non-anonymous binds) :***** Login Field :uid
    Comments :
    Test of connection to LDAP directory
    Test successful (Main server : Linux_User)

    Surname :cn First name :givenname
    Comments : Email :mail
    Phone : Phone 2 :
    Mobile phone : telephonenumber Title :
    Category (class) : Select Language referredlanguage
    Administrative number :

    Able to successful authenticate above user but when i want to import the user its not shows any user.

    its show - No users to be imported

    Please guide me.

    Thanks.

    Jugeshwar

  10. #10
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    8

    Default

    We use GLPI also and it uses the Zimbra LDAP so it is possible.

    Our basedn is ou=people, dc=domain,dc=domain,dc=domain (domain is hidden)
    login field is uid

    dj

Similar Threads

  1. zimbra & utf8
    By dmore73 in forum Administrators
    Replies: 3
    Last Post: 07-05-2007, 12:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •