Results 1 to 6 of 6

Thread: [SOLVED] Unable to change share-permissions after logout/in

Hybrid View

  1. #1
    Join Date
    Mar 2009
    Location
    Oslo, Norway
    Posts
    47
    Rep Power
    6

    Default [SOLVED] Unable to change share-permissions after logout/in

    Hello,

    If I create a share, I can see, in /Preferences/Shares, that I made a share with for instance john@localdomain.com. If I logout from Zimbra and then back in again, it no longer says john@localdomain.com, but just a long string of characters.

    This makes it impossible for me to change the share-permissions, because Zimbra don't identify that string as a valid user in Zimbra.

    Please view the attached image for a better understanding of my problem:


    Are anyone else experimenting this?

  2. #2
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    wierd. thats probably the zimbraId of the person you've shared it with. Each user on your system has a zimbraId attribute it uses a lot internally. So something is going screwy with your uid <-> zimbraid mapping. I see you're from norway, are you using any sort of localization?

  3. #3
    Join Date
    Mar 2009
    Location
    Oslo, Norway
    Posts
    47
    Rep Power
    6

    Default

    Quote Originally Posted by bdial View Post
    wierd. thats probably the zimbraId of the person you've shared it with. Each user on your system has a zimbraId attribute it uses a lot internally. So something is going screwy with your uid <-> zimbraid mapping. I see you're from norway, are you using any sort of localization?
    Thanks for answering!

    Yes, I'm using the Norwegian locale, but the same thing happens if I set the default language to English (US). (And actually use the English interface.)

    Do you know how I can troubleshoot this further?

  4. #4
    Join Date
    Oct 2009
    Location
    Oslo, Norway
    Posts
    33
    Rep Power
    6

    Default

    Quote Originally Posted by bdial View Post
    wierd. thats probably the zimbraId of the person you've shared it with. Each user on your system has a zimbraId attribute it uses a lot internally. So something is going screwy with your uid <-> zimbraid mapping. I see you're from norway, are you using any sort of localization?
    I see the same thing here, using the Norwegian localization.

    Also, if I select the folder to share from the same page (Preferences/Sharing), the necessary permissions etc for the person I'm sharing with are established. But after logging back in (before or after the other account has accepted the sharing request) I see no folders in my list of shared folders at all. (The newly shared folder should have been the only one.)

    Yours, Thomas B

  5. #5
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    719
    Rep Power
    9

    Default

    Fix for Bug 41841 - Preferences | Sharing: folders shared by me show grantee ZID rather than name is to be included in 6.0.4.

    For now, you should be able to manage share permissions as in 5.0: Navigate to Briefcase; right-click on the Skjemaer folder; and choose Properties.

    If that doesn't work either, file a new bug.

  6. #6
    Join Date
    Mar 2009
    Location
    Oslo, Norway
    Posts
    47
    Rep Power
    6

    Default

    Mr. Graves, thank you very much!

    I have searched Bugzilla for this bug, but it never occured to me to search for ZID, only ZimbraID...

    Again, thank you!

    (I mark this thread "SOLVED", as there exists workarounds.)

Similar Threads

  1. Replies: 17
    Last Post: 08-30-2010, 12:59 PM
  2. Replies: 9
    Last Post: 10-25-2009, 09:20 AM
  3. UNAUTHORIZED ACCESS Totally fouled up install
    By Lostin60s in forum Installation Help
    Replies: 0
    Last Post: 08-28-2009, 11:17 PM
  4. Replies: 1
    Last Post: 02-11-2008, 07:47 PM
  5. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 07:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •