Results 1 to 10 of 20

Thread: zmtrainsa doesnt appear to work

Hybrid View

  1. #1
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default zmtrainsa doesnt appear to work

    I have move or declare many mails as junk but i still recive mail from those directions into mine inbox what can I do to resolve this or run the trainsa manuale for all inboxes, I have read the wike and the manual but for isnt clear what to do to run the zmtransa for all the accounts in the server.

    I know that I can configure a cron job for doing this bur Im not sure how to do it

    any suggestions??

  2. #2
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    After searching and searching and more searching I figure out that when I make the install or the upgrad the install setup doesnt create the corrects spam/ham accounts, there were created with worngs domains thats why I my sapm trainer doesnt appear to work

    Any ideas of cuold be worng with this of making worng spam/ham accounts??

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    The spam/ham accounts will be created in the domain that you originally installed zimbra, has it changed since that initial install?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    thats was the problem I didnt change the domain and never where created this accounts correctly eaither from the initial install. I didnt worry about spam till today.
    I just created to accounts for spam/ham using
    zmprov ca the account pass
    and modified with this to comands:
    zmprov mcf zimbraSpamIsSpamAccount "the account"
    zmprov mcf zimbraSpamIsNotSpamAccount "the account"

    when I run zmtrainsa the log is:
    [] INFO: Total messages processed: 0
    [] INFO: Total messages processed: 0
    upgrading to DB_File, please be patient: /opt/zimbra/amavisd/.spamassassin/old_bayes_seen
    DB_File: copied 451 entries
    upgrading to DB_File, please be patient: /opt/zimbra/amavisd/.spamassassin/old_bayes_toks
    DB_File: copied 25730 entries
    import successful, original files saved with "old" prefix
    archive-iterator: readdir found no mail in '/tmp/spam.6227' directory
    Learned from 0 message(s) (0 message(s) examined).
    archive-iterator: readdir found no mail in '/tmp/ham.6227' directory
    Learned from 0 message(s) (0 message(s) examined).
    dspam_clean starting
    PROCESSING USER: zimbra
    Processing sigs; age: 14
    Processing probabilities; age: 0
    Processing unused; any: 90 quota: 30 nospam: 15 onehit: 15
    zimbra@linux:~> zmtrainsa
    [] INFO: Total messages processed: 0
    [] INFO: Total messages processed: 0
    upgrading to DB_File, please be patient: /opt/zimbra/amavisd/.spamassassin/old_bayes_seen
    DB_File: copied 451 entries
    upgrading to DB_File, please be patient: /opt/zimbra/amavisd/.spamassassin/old_bayes_toks
    DB_File: copied 25730 entries
    import successful, original files saved with "old" prefix
    archive-iterator: readdir found no mail in '/tmp/spam.7657' directory
    Learned from 0 message(s) (0 message(s) examined).
    archive-iterator: readdir found no mail in '/tmp/ham.7657' directory
    Learned from 0 message(s) (0 message(s) examined).
    bayes: synced databases from journal in 0 seconds: 53 unique entries (53 total entries)
    dspam_clean starting
    PROCESSING USER: zimbra
    Processing sigs; age: 14
    Processing probabilities; age: 0
    Processing unused; any: 90 quota: 30 nospam: 15 onehit: 15

    but it seems not to be learning some mail that I have recive and use the spam buttton to send it to the junk folder

    have I make something worong when I created this acoounts??
    Last edited by kowell; 06-25-2006 at 10:35 PM.

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Are you seeing many spam messages in your inboxes? What are your train/kill settings for spam in the admin gui?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    is there a way to run zmtrainsa to all the acounts server and not just the "zimbra" user??
    I dont every pass of my clients to do it manually and honestly is litle bit tedeous to do it that way


    my train/kill es 66/25

  7. #7
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    when I log into the sapm account it says tha a specific email was declared as spam by may account bt when the email is send it appears in the inbox folder and not into the junk folder

    i make a mistake the train/kill is 25/66

Similar Threads

  1. understanding zmtrainsa
    By bowergo in forum Administrators
    Replies: 0
    Last Post: 06-18-2007, 11:25 AM
  2. spamassassin not learn, zmtrainsa ignores junked mail
    By lukefilewalker in forum Administrators
    Replies: 0
    Last Post: 11-20-2006, 08:36 AM
  3. Replies: 42
    Last Post: 08-11-2006, 09:50 AM
  4. HELP- Making Zimbra work. after installation
    By hifriend1 in forum Installation
    Replies: 7
    Last Post: 04-05-2006, 06:43 AM
  5. Rewrote zmtrainsa for DSPAM
    By unilogic in forum Developers
    Replies: 18
    Last Post: 01-12-2006, 05:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •