Results 1 to 8 of 8

Thread: [SOLVED] Zimbra Sending Mail with Incorrect Header

  1. #1
    Join Date
    Sep 2008
    Posts
    9
    Rep Power
    7

    Default [SOLVED] Zimbra Sending Mail with Incorrect Header

    My mail is bouncing back from some clients with the following (identifying information struck out):

    <abcd@efgh.org>: host
    mxi5p.efgh.org[xxx.xxx.xxx.xxx] said: 554 5.7.1
    <unknown[xxx.xxx.xxx.58]>: Client host rejected:
    rDNS/DNS_validation_failed._Please_setup_matching_DNS_a nd_rDNS_records:_http://www.efgh.org/about/help/rdns_failure
    xabd-4 (in reply to RCPT TO command)

    The problem is that my server's IP address is not xxx.xxx.xxx.58.

    It's xxx.xxx.xxx.61

    My hosts file reflects this, and both forward and reverse DNS checks show the correct IP, and hostname.

    The server used to be at .58, but was moved a while back.

    I haven't been able to find any way to correct this, and it is a major pain in the butt.

    Thanks!

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Well, without some confirmation from you that your external (and internal) DNS records are correct it's difficult to contradict the error you're receiving. I'm guessing that the error is probably correct and your DNS is not set correctly with a reverse DNS etc.... as per the error message.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2008
    Posts
    9
    Rep Power
    7

    Default Confirmation?

    What do you mean by that?

    I stated in the original thread that I had already checked the DNS, both forward and reverse. Forward resolves to the correct IP address, and reverse returns the fqdn of the server.

    I just ran a DNSReport [www.dnsstuff.com] again... Everything is checking out.


    Internal DNS was checked as well....



    Below are the headers of an email sent from my server to a yahoo.com address -- as you can see, the server is reporting an incorrect IP address.
    ---------------------------------------------------------------------------
    X-Apparently-To: id_removed@yahoo.com via 98.137.27.199; Tue, 08 Dec 2009 08:42:04 -0800
    Return-Path: <me@domain.com>
    X-YahooFilteredBulk: xxx.xxx.xxx.58
    X-YMailISG: bMK3n7MWLDusBvbyW9dPHZH1IIarPn_rDWgbGNlWtSscd0f_02 UC4n2pKxSw6KSA_.tTh7aB8YjWkq6rHE_Th7lKByuu9iY_Sv9Y ZGXJxqpKiQJaoSH.XUiGdNhe51DJDExdffSe65DYWcGZAYDZY1 9g3YsjlSag6gUpBadnM8gqusS7LXVl0WGZ9_yELBTx7ll88gBf m6U7N.k75SSonUlb60.E597445Kgbuu_qQLTgXPzHG7rxkKWE. o4t61sjl9NisOqdQTMGZDTgRDqcThI_xn.kD58Ri6ukFc105Bw B8VwnUnTRKSMo9gPGFPbQVnMrgn.iMzr2n0oaTSbyL8NteDI67 4WUMBDUSU-
    X-Originating-IP: [xxx.xxx.xxx.58]
    Authentication-Results: mta1017.mail.re4.yahoo.com from=mydomain.com; domainkeys=neutral (no sig); from=mydomain.com; dkim=neutral (no sig)
    Received: from 127.0.0.1 (EHLO (correct-zimbra-fqdn) (xxx.xxx.xxx.58) by mta1017.mail.re4.yahoo.com with SMTP; Tue, 08 Dec 2009 08:42:04 -0800
    Received: from localhost (localhost.localdomain [127.0.0.1]) by correct-zimbra-fqdn (Postfix) with ESMTP id 8708823021C for <id_removed@yahoo.com>; Tue, 8 Dec 2009 11:41:59 -0500 (EST)
    X-Virus-Scanned: amavisd-new at
    X-Spam-Flag: NO
    X-Spam-Score: -4.236
    X-Spam-Level:
    X-Spam-Status: No, score=-4.236 tagged_above=-10 required=4 tests=[ALL_TRUSTED=-1.8, AWL=0.162, BAYES_00=-2.599, HTML_MESSAGE=0.001]
    Received: from correct-zimbra-fqdn ([127.0.0.1]) by localhost (correct-zimbra-fqdn [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id BIypdftHPNyZ for <id_removed@yahoo.com>; Tue, 8 Dec 2009 11:41:58 -0500 (EST)
    Received: from correct-zimbra-fqdn (correct-zimbra-fqdn [xxx.xxx.xxx.61]) by correct-zimbra-fqdn (Postfix) with ESMTP id C0F5923021B for <id_removed@yahoo.com>; Tue, 8 Dec 2009 11:41:58 -0500 (EST)
    Date: Tue, 8 Dec 2009 11:41:58 -0500 (EST)
    From: "Me" <me@domain.com>
    Add sender to Contacts
    Reply-To: "Me" <me@domain.com>
    To: asim1229 <id_removed@yahoo.com>
    Message-ID: <1566281.241260290518402.JavaMail.root@host.domain .com>
    Subject: Test
    MIME-Version: 1.0
    Content-Type: multipart/alternative; boundary="----=_Part_9_10467510.1260290518401"
    X-Originating-IP: [192.168.81.109]
    X-Mailer: Zimbra 5.0.9_GA_2533.RHEL5 (ZimbraWebClient - FF3.0 (Win)/5.0.9_GA_2533.RHEL5)
    Content-Length: 1610
    Last edited by bfillmore75; 12-08-2009 at 10:07 AM. Reason: Adding supplemental information

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by bfillmore75 View Post
    What do you mean by that?
    What I mean is, you wouldn't believe how many times people say 'x' is true when it isn't. I'm sure you have checked it but I have no confirmation that what you say is valid (i.e. you haven't given any information from your checks) and in those circumstances I have to accept that the receiving mail server is checking your records correctly. If that's not the case and you're 100&#37; convinced that everything at your end is correct then you should contact the admin of the receiving server and ask why he's rejecting your email with that particular error.

    BTW, you've also given no evidence to show that the email is being sent with incorrect headers (as mentioned in the thread title).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    Hi BfillMore , it might be the case that your new DNS record is not yet populated, which seems to be difficult as nowadays DNS changes takes few hrs for replicate. Try reducing your TTL in DNS to something low value.

  6. #6
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    My guess would be from the error you posted that your Zimbra server is behind a NAT/Firewall and that the "main" address that most outgoing connections come from is xxx.xxx.xxx.58. You should review your NAT rules to make sure that outgoing connections from your Zimbra server show as coming from xxx.xxx.xxx.61 and not the main address your NAT usually uses for outgoing addresses.

  7. #7
    Join Date
    Sep 2008
    Posts
    9
    Rep Power
    7

    Red face NAT rules

    Although this server was in a DMZ with a public IP, and there is absolutely no reason for it to have existed. I did a sanity check of the NAT rules, and found that one had been stuck in there.

    It was natting from one public IP to another public IP.

    Bizarre.

    However, removing it DID resolve the problem.

    Thanks for having me check the ridiculous, ArcaneMagus. That was the problem.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    OK, fix your hosts file by removing the 127.0.1.1 line then run the following commands on your Zimbra server and post the output:

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname`  <- use that exact command with backticks not single quotes
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 15
    Last Post: 11-19-2009, 12:16 AM
  2. Replies: 8
    Last Post: 01-20-2009, 01:06 PM
  3. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 12:44 PM
  4. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •