Results 1 to 2 of 2

Thread: [SOLVED] mails sent by undeliverable to gmail yahoo or else

  1. #1
    Join Date
    Dec 2009
    Location
    Rabat, Morocco
    Posts
    5
    Rep Power
    6

    Default [SOLVED] mails sent by undeliverable to gmail yahoo or else

    Hi Tech Folks

    I've had zimbra running as a charm and one day, our ISP made us change the IP numbers.
    I did so on my zimbra server and re-run the config so that /opt/zimbra/config-- and config.#### are fine.

    after having that changed
    zimbra can deliver emails to itself and within the same domain.
    but nothing outside such as gmail or else.

    and we're not blacklisted or something...

    it's really weird

    here's an example from /var/log/messages



    Dec 16 17:36:05 agora zimbramon[19158]: 19158:info: 2009-12-16 17:36:01, STATUS: agora.ras.ma: stats: Running
    Dec 16 17:36:12 agora amavis[14497]: (14497-01) ESMTP::10024 /opt/zimbra/data/amavisd/tmp/amavis-20091216T173611-14497: <kamar001t@agora.ras.ma> -> <khalilamar@gmail.com>,<kamar@ras.ma>,<khalilamar@ sympatico.ca> SIZE
    Dec 16 17:36:12 agora amavis[14497]: (14497-01) Checking: OSM6vkkXVHIp [196.2.85.203] <kamar001t@agora.ras.ma> -> <khalilamar@gmail.com>,<kamar@ras.ma>,<khalilamar@ sympatico.ca>
    Dec 16 17:36:12 agora clamd[14556]: Reading databases from /opt/zimbra/data/clamav/db
    Dec 16 17:36:18 agora amavis[14497]: (14497-01) FWD via SMTP: <kamar001t@agora.ras.ma> -> <khalilamar@gmail.com>,<kamar@ras.ma>,<khalilamar@ sympatico.ca>,BODY=7BIT 250 2.6.0 Ok, id=14497-01, from MTA([127.0.0.1]:1002
    Dec 16 17:36:18 agora amavis[14497]: (14497-01) Passed CLEAN, [196.2.85.203] [196.2.85.203] <kamar001t@agora.ras.ma> -> <khalilamar@gmail.com>,<kamar@ras.ma>,<khalilamar@ sympatico.ca>, Message-ID: <19082482.012609849
    Dec 16 17:36:18 agora amavis[14497]: (14497-01) extra modules loaded: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Net/SSLeay/
    Dec 16 17:36:36 agora clamd[14556]: Database correctly reloaded (845566 signatures)



    reverse lookup is fine (agora.ras.ma. <-> 196.2.85.203)
    hostname is fine ( agora.ras.ma )
    config files inside /opt/zimbra are fine

    version of zimbra is as follows
    Release 5.0.4_GA_2101.RHEL4_20080321155827 CentOS4

    I am not tempted to upgrade now. :X

    any input will be highly appreciated.

    Thanks in advance.

    ---

    Thanks for your help

    the logs above are not complete because I based it on /var/log/messages
    and the status of all the services are green

    I played with postqueue -p and postqueue -f

    changed the MTA to my ISP SMTP, by doing the trick
    Code:
    zmprov ms agora.ras.ma zimbraMtaRelayHost smtp.mtds.com:25
    Code:
    postfix reload ; postqueue -f ; postqueue -p
    and the held emails went through like missiles.

    postfix was holding the emails.
    the reason is still unclear. it wasn't looping to itself, no. but the connexion to hotmail/gmail and else were timing-out. the other server was ignoring my zimbra.

    telneting from zimbra server to smtp of gmail on port 25 gives me a connexion OK. So I assume they're doing the handshake and the HELO.

    is it gmail being restrictive? probably.

    are my dns and reverse-dns wrong ? I don't think so.

    I'd like to return to my original setting where the postfix of zimbra was the actual sender.

    otherwise I will wait until summer and install a fresh server 6.0.x on fedora or centos and get rid of this problem.

    but at least zmprov ms on the Mta did the trick.

    I've checked /var/log/maillog, /var/log/zimbra.log and /var/log/messages

    Do you think I should check somewhere else ?

    Based on the two lines below
    it is saying that using the zimbra smtp, connexion is interrupted by the mail server destination.
    If I switch to my isp smtp, it gets delivered.

    Code:
    zimbra.log:Dec 16 19:01:28 agora postfix/smtp[1033]: E15B43D1889: to=<khalilamar@sympatico.ca>, relay=mxmta.sympatico.ca[67.69.240.23]:25, delay=3405, delays=3359/0.04/45/0, dsn=4.4.2, status=deferred (lost connection with mxmta.sympatico.ca[67.69.240.23] while receiving the initial server greeting)
    zimbra.log:Dec 16 19:10:10 agora postfix/smtp[5680]: 662E43D174E: to=<khalilamar@sympatico.ca>, relay=smtp.mtds.com[196.2.80.6]:25, delay=5632, delays=5631/0.03/0.05/0.37, dsn=2.0.0, status=sent (250 Ok: queued as 70B9073C0AD)
    I think I may know where is the conflict.
    DNS updates don't reach some dns servers. I need to contact my isp (he's my secondary dns) to update the reverse name.

    Code:
    # nslookup 
    > server 8.8.8.8
    Default server: 8.8.8.8
    Address: 8.8.8.8#53
    > set type=MX
    > agora.ras.ma
    Server:		8.8.8.8
    Address:	8.8.8.8#53
    
    Non-authoritative answer:
    agora.ras.ma	mail exchanger = 10 agora.ras.ma.
    
    Authoritative answers can be found from:
    > 196.2.85.203
    Server:		8.8.8.8
    Address:	8.8.8.8#53
    
    Non-authoritative answer:
    203.85.2.196.in-addr.arpa	name = agora.edu.ac.ma.
    
    Authoritative answers can be found from:
    > server 196.2.85.197
    Default server: 196.2.85.197
    Address: 196.2.85.197#53
    > agora.ras.ma
    Server:		196.2.85.197
    Address:	196.2.85.197#53
    
    agora.ras.ma	mail exchanger = 10 agora.ras.ma.
    > 196.2.85.203
    Server:		196.2.85.197
    Address:	196.2.85.197#53
    
    203.85.2.196.in-addr.arpa	name = agora.ras.ma.
    > exit

    at the end it's not zimbra's fault, even if it's an old release
    Last edited by khalilamar; 12-16-2009 at 01:35 PM. Reason: reply not showing up

  2. #2
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Is this a complete set of log events for a failed attempt? All this is showing is that the message passed through the antivirus / antispam check (amavisd). I believe you should also see stuff in the logs where it actually tries to send the message to the remote email server(s).

    Are you sure all your Zimbra services are running? What does the output of 'zmcontrol status' (run as Zimbra user) show?

Similar Threads

  1. zimbra couldn't send mail to gmail or yahoo
    By alfathin in forum Installation
    Replies: 4
    Last Post: 12-08-2009, 03:50 AM
  2. cant send mails to gmail
    By debasmita in forum Administrators
    Replies: 1
    Last Post: 10-21-2009, 05:06 AM
  3. Copy yahoo folders to gmail using Zimbra?
    By herc182 in forum General Questions
    Replies: 3
    Last Post: 01-14-2009, 11:40 PM
  4. Replies: 1
    Last Post: 10-03-2008, 03:30 PM
  5. Not downloading new mails in GMail
    By deepanjan_nag in forum Error Reports
    Replies: 0
    Last Post: 07-31-2008, 09:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •