Results 1 to 6 of 6

Thread: Multi server installation - Problem with remote MTA stats

  1. #1
    Join Date
    Jan 2006
    Posts
    3
    Rep Power
    9

    Default Multi server installation - Problem with remote MTA stats

    We have 2 systems configured. One with all the services installed and a second which is a LDAP replica and backup MX MTA (both services function fine on this server).

    Problem: When trying to view the the Mail Queue stats for the MTA/LDAP replica server (through the WebUI on the primary system) I get the following error message:

    Message: system failure: server b.mail.domain.com has invalid zimbraRemoteManagementPort
    com.zimbra.cs.service.ServiceException: system failure: server b.mail.sonomait.com has invalid zimbraRemoteManagementPort
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:131)
    at com.zimbra.cs.rmgmt.RemoteManager.<init>(RemoteMan ager.java:59)
    at com.zimbra.cs.rmgmt.RemoteManager.getRemoteManager (RemoteManager.java:197)
    at com.zimbra.cs.rmgmt.RemoteMailQueue.startScan(Remo teMailQueue.java:265)
    at com.zimbra.cs.rmgmt.RemoteMailQueue.<init>(RemoteM ailQueue.java:320)
    at com.zimbra.cs.rmgmt.RemoteMailQueue.getRemoteMailQ ueue(RemoteMailQueue.java:81)
    at com.zimbra.cs.service.admin.GetMailQueue.handle(Ge tMailQueue.java:74)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:255)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:163)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:228)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:154)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
    at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:541)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:869)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:667)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:527)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
    at java.lang.Thread.run(Thread.java:595)

    Error code: service.FAILURE
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Receiver


    I have re-run zmsshkeygen and zmupdatesuthkeys on both systems and restarted tomcat on the primary one but still get the error. Any one have ideas on why I can't view the Mail Queue?

  2. #2
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    11

    Default

    what do you get from this:

    zmprov gs b.mail.sonomait.com | grep zimbraRemoteManagement

  3. #3
    Join Date
    Jan 2006
    Posts
    3
    Rep Power
    9

    Default

    I get nothing. There are no zimbraRemoteManagement.* options set at all.

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    It should be set to 22 the default ssh port.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Jan 2006
    Posts
    3
    Rep Power
    9

    Default

    After adding all the missing zimbraRemote settings, I now get:

    Message: system failure: exception during auth {RemoteManager: a.mail.domain.com->zimbra@b.mail.domain.com:22}
    com.zimbra.cs.service.ServiceException: system failure: exception during auth {RemoteManager: a.mail.domain.com->zimbra@b.mail.domain.com:22}
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:131)
    at com.zimbra.cs.rmgmt.RemoteManager.getSession(Remot eManager.java:192)
    at com.zimbra.cs.rmgmt.RemoteManager.execute(RemoteMa nager.java:129)
    at com.zimbra.cs.service.admin.GetMailQueueInfo.handl e(GetMailQueueInfo.java:55)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:255)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:163)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:228)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:154)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
    at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:541)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:869)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:667)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:527)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.io.IOException: There was a problem while talking to b.mail.domain.com:22
    at ch.ethz.ssh2.Connection.connect(Connection.java:64 2)
    at ch.ethz.ssh2.Connection.connect(Connection.java:46 0)
    at com.zimbra.cs.rmgmt.RemoteManager.getSession(Remot eManager.java:183)
    ... 24 more
    Caused by: java.io.IOException: Server uses incompatible protocol, it is not SSH-2 compatible.
    at ch.ethz.ssh2.transport.ClientServerHello.<init>(Cl ientServerHello.java:76)
    at ch.ethz.ssh2.transport.TransportManager.initialize (TransportManager.java:304)
    at ch.ethz.ssh2.Connection.connect(Connection.java:59 1)
    ... 26 more

    Error code: service.FAILURE
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Receiver

  6. #6
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    10

    Default

    Caused by: java.io.IOException: Server uses incompatible protocol, it is not SSH-2 compatible.
    You need to configure your SSH server to use SSHv2.

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 09:57 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  4. Installation Problem - Possibly LDAP
    By geroshea in forum Installation
    Replies: 5
    Last Post: 03-16-2007, 05:47 AM
  5. Zimbra Installation Problem
    By AnilKumarYalla in forum Developers
    Replies: 0
    Last Post: 09-10-2006, 10:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •