We have 2 systems configured. One with all the services installed and a second which is a LDAP replica and backup MX MTA (both services function fine on this server).

Problem: When trying to view the the Mail Queue stats for the MTA/LDAP replica server (through the WebUI on the primary system) I get the following error message:

Message: system failure: server b.mail.domain.com has invalid zimbraRemoteManagementPort
com.zimbra.cs.service.ServiceException: system failure: server b.mail.sonomait.com has invalid zimbraRemoteManagementPort
at com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:131)
at com.zimbra.cs.rmgmt.RemoteManager.<init>(RemoteMan ager.java:59)
at com.zimbra.cs.rmgmt.RemoteManager.getRemoteManager (RemoteManager.java:197)
at com.zimbra.cs.rmgmt.RemoteMailQueue.startScan(Remo teMailQueue.java:265)
at com.zimbra.cs.rmgmt.RemoteMailQueue.<init>(RemoteM ailQueue.java:320)
at com.zimbra.cs.rmgmt.RemoteMailQueue.getRemoteMailQ ueue(RemoteMailQueue.java:81)
at com.zimbra.cs.service.admin.GetMailQueue.handle(Ge tMailQueue.java:74)
at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:255)
at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:163)
at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:228)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:154)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:541)
at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:869)
at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:667)
at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:527)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
at java.lang.Thread.run(Thread.java:595)

Error code: service.FAILURE
Method: ZmCsfeCommand.prototype.invoke
Details:soap:Receiver


I have re-run zmsshkeygen and zmupdatesuthkeys on both systems and restarted tomcat on the primary one but still get the error. Any one have ideas on why I can't view the Mail Queue?