Hi.
I had stats turned off earlier in 6.0.x since it liked to go cpu bound.
I turned it on before upgrading to 6.0.4 recently, and it's still not
quite right.

now rrd seems to be hit or miss...

/opt/zimbra/libexec/zmrrdfetch -c -f zmmtastats

1261161900,0,0.00172667151990648,,1657.6075246035, 0,0.0318217113049919,0.068644337610934,0,0
1261162200,0,0.00172667151990648,,1657.6075246035, 0,0.0318217113049919,0.068644337610934,0,0
1261162500,,,,,,,,,
1261162800,,,,,,,,,
1261163100,,,,,,,,,
1261163400,,,,,,,,,
1261163700,0,0.00167064009926398,,985.131359253286 ,0,0.0417660024815994,0.0885439252609907,0,0
1261164000,0,0.00167064009926398,,985.131359253286 ,0,0.0417660024815994,0.0885439252609907,0,0
1261164300,,,,,,,,,
1261164600,,,,,,,,,
1261164900,,,,,,,,,
1261165200,,,,,,,,,
1261165500,,,,,,,,,
1261165800,,,,,,,,,
1261166100,,,,,,,,,
1261166400,,,,,,,,,
1261166700,0,0.00166907730253432,,257.511922544206 ,0,0.0216980049329462,0.0484032417734954,0,0
1261167000,0,0.00166907730253432,,257.511922544206 ,0,0.0216980049329462,0.0484032417734954,0,0
1261167300,0,0.00166709521377461,,475.107075280919 ,0,0.0347389778437687,0.0744792413288612,0,0
1261167600,0,0.00166709521377461,,475.107075280919 ,0,0.0347389778437687,0.0744792413288612,0,0
1261167900,,,,,,,,,
1261168200,,,,,,,,,
1261168500,,,,,,,,,

zmswatch.out has messages like...

SMTP notification: Dec 18 15:00:03 hub zimbramon[12665]: 12665:err: Disk warning: servername: /dev/sdb1 at 88%
SNMP notification: Dec 18 15:00:03 hub zimbramon[12665]: 12665:err: Disk warning: servername: /dev/sdb1 at 88%
i: Missing type/value for variable
SMTP notification: Dec 18 15:10:03 hub zimbramon[12665]: 12665:err: Disk warning: servername: /dev/sdb1 at 88%
SNMP notification: Dec 18 15:10:03 hub zimbramon[12665]: 12665:err: Disk warning: servername: /dev/sdb1 at 88%
i: Missing type/value for variable

etc.

Odd we get doubles of the disk warn issue, and I think
the Missing type/value is something from a
snmp query, but I'm at a loss as to why that's there.

grep -w MTA /var/log/zimbra-stats.log
looks fine like
Dec 18 15:10:11 xxx zimbramon[14750]: 14750:info: MTA: server: filter_misc,clam_events,mta_delay,mta_volume,filte r_virus,filter_count,mta_count,filter_spam,sendmai l_events:: 0,1,0.896551724137931,154284,0,13,29,0,0
Dec 18 15:20:11 xxx zimbramon[24743]: 24743:info: MTA: server: filter_misc,clam_events,mta_delay,mta_volume,filte r_virus,filter_count,mta_count,filter_spam,sendmai l_events:: 0,1,1.4,287692,0,21,45,0,0

tail /var/log/zimbra-stats.log seems okay looking like...
Dec 18 15:40:23 xxx zimbramon[12676]: 12676:info: zmstat convertd.csv: timestamp, utime, stime, cputime, rchar, wchar, read_bytes, write_bytes, rss, processes, threads:: 12/18/2009 15:40:23, 0, 0, 0, 0, 0, 0, 0, 28040, 7, 7
Dec 18 15:40:24 xxx zimbramon[12678]: 12678:info: zmstat mtaqueue.csv: timestamp, KBytes, requests:: 12/18/2009 15:40:24, 0, 0

#
# zmsoap -z GetLoggerStatsRequest stats/@name=zmmtastats | head -20
# zmsoap -z GetLoggerStatsRequest stats/@name=zmmtastats @limit=1 | head -50
seem to look okay.

(I'm referring to Logger (ZCS 6.0.x and later) - Zimbra :: Wiki
here)

zmloggerctl status; echo $?; ps ax | grep zmlogger
0
14711 ? S 0:16 /usr/bin/perl /opt/zimbra/libexec/zmlogger
14743 ? S 0:00 zmlogger: zmrrdfetch: server
16437 pts/0 R+ 0:00 grep zmlogger


thanks if anyone has ideas on why the rrd is patchy and why I get
i: Missing type/value for variable

thanks,
John