Results 1 to 7 of 7

Thread: [SOLVED] logger mismatch after change servername

  1. #1
    Join Date
    Dec 2009
    Posts
    14
    Rep Power
    5

    Default [SOLVED] logger mismatch after change servername

    Hi all,

    I'm running ZCS6.0.1, because of few mistakes I run a zmsetservername command to change my servername from myhostname to myhost.mydomain.com
    with few complications I finally made that change, but I discover a problem in my server monitoring in my admin console. -- that I have two entries with one say data is stale, but actually I have only one server in zcs.



    I take few read and find this things:

    Code:
    [zimbra@myhost /]$ zmloggerhostmap
    Zimbra Logger Service Hostname Map
    
    ---------------------    ---------------------
    DNS Hostname             Zimbra Hostname
    ---------------------    ---------------------
    myhost                   myhost.mydomain.com
    myhost.mydomain.com      myhost
    so basically I want to map the DNS myhost.mytomain.com to Zimbra myhost.mydomain.com

    I read the logger manual, not discover the command to do that.

    any hint?

    thanks in advance!

    wolvesled
    Attached Images Attached Images
    Last edited by wolvesled; 12-28-2009 at 12:28 AM. Reason: mistake

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by wolvesled View Post
    so basically I want to map the DNS myhost.mytomain.com to Zimbra myhost.mydomain.com
    So what do your DNS records show? Post the output of the following commands (run on the zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname` <- use that exact command with backticks not single quotes
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Dec 2009
    Posts
    14
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    So what do your DNS records show? Post the output of the following commands (run on the zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname` <- use that exact command with backticks not single quotes
    Code:
    [root@myhost /]# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    # Auto-generated hostname. Please do not remove this comment.
    12.34.56.78 myhost.mydomain.com myhost
    Code:
    [root@myhost /]# cat /etc/resolv.conf
    search mydomain.com
    
    nameserver 12.34.56.78
    Code:
    [root@myhost /]# dig mydomain.com mx
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5 <<>> mydomain.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2137
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;mydomain.com.           IN      MX
    
    ;; ANSWER SECTION:
    mydomain.com.    2592000 IN      MX      10 myhost.mydomain.com.
    
    ;; AUTHORITY SECTION:
    mydomain.com.    2592000 IN      NS      mydns.mydomain.com.
    
    ;; ADDITIONAL SECTION:
    myhost.mydomain.com. 2592000 IN    A       12.34.56.78
    mydns.mydomain.com. 2592000 IN     A       12.34.56.78
    
    ;; Query time: 0 msec
    ;; SERVER: 12.34.56.78#53(12.34.56.78)
    ;; WHEN: Fri Dec 25 11:22:43 2009
    ;; MSG SIZE  rcvd: 108
    Code:
    [root@myhost /]# dig mydomain.com any
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5 <<>> mydomain.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61392
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;mydomain.com.           IN      ANY
    
    ;; ANSWER SECTION:
    mydomain.com.    2592000 IN      SOA     mydns.mydomain.com. admin.mydomain.com. 10118 43200 3600 3600000 2592000
    mydomain.com.    2592000 IN      NS      mydns.mydomain.com.
    mydomain.com.    2592000 IN      MX      10 myhost.mydomain.com.
    
    ;; ADDITIONAL SECTION:
    mydns.mydomain.com. 2592000 IN     A       12.34.56.78
    myhost.mydomain.com. 2592000 IN    A       12.34.56.78
    
    ;; Query time: 0 msec
    ;; SERVER: 12.34.56.78#53(12.34.56.78)
    ;; WHEN: Fri Dec 25 11:23:30 2009
    ;; MSG SIZE  rcvd: 150
    Code:
    [root@myhost /]# host `hostname`
    myhost.mydomain.com has address 12.34.56.78
    by the way, the first time I change the server name from myhost to myhost.mydomain.com I did not change it completely (did not update ldap), and when I start the server the monitoring status have two entry with one not working. and then I troubleshoot and successfully change my server name (including update ldap records). there is still two entries with one dead after I restart the zcs server.

    so I guess that mapping is created after I change the server name halfway to FQDN, so some part of the zcs already using the FQDN to create files and mappings but resulted in unable to find the server in ldap record. so there is still a zcs hostname "myhost" somewhere in the logger not updated to myhost.mydomain.com

    or other clue?

    thanks alot!

  4. #4
    Join Date
    Dec 2009
    Posts
    14
    Rep Power
    5

    Default

    and just one thing to clear, my zcs fqdn was already changed successfully with all services up and running. the matter I post this is only because the admin console server monitoring has two entries, one shows all services running, the other looks like a dead body that says data stale, I just want to remove the dead one while the other still functioning well.

    so far now looks like if I solve the mapping of logger to server, and so far far away now looks like I still have two servers as one with old name and mapping to the opposite dns record.

    but I check with zmprov gs myhost returns me no such server. so I'm simply confused where else can have this old host name.

    b.r.

  5. #5
    Join Date
    Dec 2009
    Posts
    14
    Rep Power
    5

    Default

    sorry to bother, I take few searches, but still not find where the zimbra logger stores the server host name, that I can remove it from.

    Any idea would be appreciate!

  6. #6
    Join Date
    Dec 2009
    Posts
    14
    Rep Power
    5

    Default

    I find the correct command to modify the mapping where I missed it:

    "zmloggerhostmap -d" to delete a mapping and "-a" to add one. the problem was I use "zmloggerhostmap --help" for the manual but it only accept "-h" and my system was configured in Spanish that I didn't quite understand to find the expected parameter to modify it. So I was simply thinking zmloggerhostmap is a loopup tool.

    so with the correct command:
    Code:
    zmloggerhostmap -d myhost.mydomain.com myhost
    zmloggerhostmap -a myhost.mydomain.com myhost.mydomain.com
    I got this error:

    Code:
    DBD::SQLite::st execute failed: column dns_hostname is not unique at /opt/zimbra/bin/zmloggerhostmap line 64.
    column dns_hostname is not unique at /opt/zimbra/bin/zmloggerhostmap line 65.
    but in my admin console it looks correct as in picture:



    so the error seems the database not updated, does that matter or I could consider this issue solved?

    sincerely,

    wolvesled
    Attached Images Attached Images

  7. #7
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default Tahnks!

    Quote Originally Posted by wolvesled View Post
    I find the correct command to modify the mapping where I missed it:

    "zmloggerhostmap -d" to delete a mapping and "-a" to add one. the problem was I use "zmloggerhostmap --help" for the manual but it only accept "-h" and my system was configured in Spanish that I didn't quite understand to find the expected parameter to modify it. So I was simply thinking zmloggerhostmap is a loopup tool.

    so with the correct command:
    Code:
    zmloggerhostmap -d myhost.mydomain.com myhost
    zmloggerhostmap -a myhost.mydomain.com myhost.mydomain.com
    I got this error:

    Code:
    DBD::SQLite::st execute failed: column dns_hostname is not unique at /opt/zimbra/bin/zmloggerhostmap line 64.
    column dns_hostname is not unique at /opt/zimbra/bin/zmloggerhostmap line 65.
    but in my admin console it looks correct as in picture:



    so the error seems the database not updated, does that matter or I could consider this issue solved?

    sincerely,

    wolvesled
    Thank you! This solved my problem "zmloggerhostmap -d localhost localhost"

    Regards,
    pup_seba

Similar Threads

  1. "False" Logger Admin Email Alerts After 5.0.15 Upgrade?
    By LMStone in forum Administrators
    Replies: 1
    Last Post: 04-01-2009, 10:15 AM
  2. Logger server installation
    By veronica in forum Installation
    Replies: 2
    Last Post: 06-29-2008, 01:10 PM
  3. Replies: 7
    Last Post: 12-16-2007, 08:43 AM
  4. Tomcat/LDAP Failure on 4.5
    By russgalleywood in forum Installation
    Replies: 10
    Last Post: 01-25-2007, 03:05 AM
  5. Change Servername for Listening
    By linmar in forum Installation
    Replies: 0
    Last Post: 08-27-2006, 07:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •