Results 1 to 3 of 3

Thread: [SOLVED] Changing Operating System

  1. #1
    Join Date
    Jun 2007
    Location
    Porto Alegre, RS, Brazil
    Posts
    96
    Rep Power
    8

    Default [SOLVED] Changing Operating System

    Hello

    We're in the proccess of moving a customer to Zimbra NE. Right now, he's using the FOSS edition, 5.0.13 on OpenSuSE 10.2. So, i followed the guidelines presented here, but there is one strange thing happening and in the end i'm presented with a Perl error that was already mentioned in this forums, but related to RHEL installations.

    The new server is Ubuntu 8.04 LTS. As stated before, i followed the procedures found on that powertip above.

    The strange thing:

    Even though the installer says: ZCS upgrade from 5.0.13 to 5.0.13 will be performed.

    Later, it says:

    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save.. .done
    Operations logged to /tmp/zmsetup.12302009-095247.log
    Starting ldap...done.
    Setting defaults...done.
    Upgrading from 5.0.11_GA_2695 to 5.0.13_GA_2791
    Stopping zimbra services
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql

    5.0.11??????

    And the error itself:

    5 is only avaliable with the XS version at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30, <OUTPUT> line 3.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 991, <OUTPUT> line 3.

    Any help is greatly appreciated.

    Thanks in advance.

  2. #2
    Join Date
    Jun 2007
    Location
    Porto Alegre, RS, Brazil
    Posts
    96
    Rep Power
    8

    Default

    Ok, it looks like someone provided me with an old backup which indeed was version 5.0.11...anyway, i still with the error:

    is only avaliable with the XS version at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 991.

    The only difference from the previous error is that the version is not shown in the beginning of the error...

    Could someone point me to some direction? Even an RTFM with a link is acceptable

  3. #3
    Join Date
    Jun 2007
    Location
    Porto Alegre, RS, Brazil
    Posts
    96
    Rep Power
    8

    Default

    Ok, found it. I must admit it only was a matter of further research.

    This thread solved the problem:

    http://www.zimbra.com/forums/adminis...-platform.html

    Cheers!!

Similar Threads

  1. Clients stopped receiving emails
    By egadinc in forum Administrators
    Replies: 16
    Last Post: 12-14-2009, 02:38 PM
  2. mysql not starting, sort of.
    By lhutton in forum Installation
    Replies: 6
    Last Post: 06-19-2009, 10:45 AM
  3. Replies: 4
    Last Post: 10-08-2008, 06:55 AM
  4. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  5. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •