Results 1 to 7 of 7

Thread: [SOLVED] Add an alias file

Hybrid View

  1. #1
    Join Date
    Jan 2010
    Posts
    4
    Rep Power
    5

    Default [SOLVED] Add an alias file

    Hello,

    I have installed Zimbra Release 6.0.1_GA_1816.DEBIAN5_64 DEBIAN5_64 FOSS edition. I need to add an extra alias file to the postfix configuration. I modified the /opt/zimbra/postfix/conf/main.cf file with this:

    alias_maps = hash:/etc/aliases,hash:/etc/mail/sympa_aliases

    And after that I run the command:

    # /opt/zimbra/postfix/sbin/newaliases

    But, now the mail service is not working because of:

    Jan 4 14:34:43 estafeta1 postfix/smtpd[16471]: fatal: open database /etc/mail/sympa_aliases.db: No such file or directory

    The .db file is not created by the newaliases command. How can I create the .db file?

    Thanks.

  2. #2
    Join Date
    May 2009
    Location
    Bremen, Germany
    Posts
    122
    Rep Power
    6

    Default

    Run
    /opt/zimbra/postfix/sbin/postmap /etc/mail/sympa_aliases
    as root.

  3. #3
    Join Date
    Jan 2010
    Posts
    4
    Rep Power
    5

    Default

    I run this command and I generate the sympa_aliases.db file. But I get warnings. For example, in the sympa_aliases file there is a line with the following text:

    sympa: "| /home/sympa/bin/queue sympa@ivie.es"

    and the previous command gives this warning:

    postmap: warning: /etc/mail/sympa_aliases, line 1: record is in "key: value" format; is this an alias file?

    The problem is when I send a mail to sympa@ivie.es, that is the domain of this server, or sympa@estafeta1.ivie.es, that is the server's name, I receive an automatic response message that says that the user doesn't exist.

    What am I doing wrong?

    Thanks.

  4. #4
    Join Date
    May 2009
    Location
    Bremen, Germany
    Posts
    122
    Rep Power
    6

    Default

    Sorry, you have to use postalias instead of postmap

  5. #5
    Join Date
    Jan 2010
    Posts
    4
    Rep Power
    5

    Default

    Quote Originally Posted by jummo View Post
    Sorry, you have to use postalias instead of postmap
    Ok, this solves the problem of the warning, but it cotinues failing because of it doesn't recognize the user. I get the automatic response message saying that the user doesn't exist.

    Thanks.

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

  7. #7
    Join Date
    Jan 2010
    Posts
    4
    Rep Power
    5

    Default

    Finally, I solved the problem using the advices in this page that it's accesible from the above link.

    Thanks all.

Similar Threads

  1. Error while trying to open an attachment .PPT file
    By pedrocora in forum Administrators
    Replies: 7
    Last Post: 05-11-2009, 05:09 AM
  2. Domain alias with zmprov
    By Klug in forum Administrators
    Replies: 2
    Last Post: 03-25-2009, 07:49 AM
  3. Zimbra + Samba LDAP, cannot add winxp
    By fajarpri in forum Installation
    Replies: 4
    Last Post: 07-08-2007, 11:45 AM
  4. BUILD FAILED error is killing me
    By hanysys in forum Developers
    Replies: 11
    Last Post: 05-11-2007, 06:09 AM
  5. Traslation SVN tree status
    By meikka in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 02-13-2007, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •