I try to upgrade an 6.0.2 installation to 6.04, but it fails with 'Starting mysql...'
The zmsetup.log says:

Tue Jan 5 21:06:18 2010 Verifying /opt/zimbra/conf/my.cnf
Tue Jan 5 21:06:19 2010 Starting mysql...
Tue Jan 5 21:06:19 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
Starting mysqld...done.
Tue Jan 5 21:06:31 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:06:42 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:06:54 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:07:05 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:07:17 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:07:29 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:07:41 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:07:52 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:08:04 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:08:16 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:08:28 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:08:40 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832
Tue Jan 5 21:08:52 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
mysqld_safe already running with pid 8832

It appears that the installer is unable to detect that it has started mysql.
Anyone knows how to proceed ?