Results 1 to 5 of 5

Thread: Reindexing not Running

  1. #1
    Join Date
    Apr 2009
    Calgary, Alberta
    Rep Power

    Default Reindexing not Running


    I suspect I'm missing something very basic here so someone cuff me in the head please.

    Version Zimbra 6.0.1
    When I open the admin console and try to reindex a mailbox, it doesn't work. I see "0 messages indexed, 0 messages remaining, 0 messages failed" then get a message stating "Reindexing is not running". The green bar jumps right to the end to show process is completed. It doesn't matter which mailbox I am trying to reindex.

    I have not tried to do this by command line yet, and will do so when I next get access to the server.

    OK, there definitely appears to be something amiss. I have run the reindexing by command line and it still fails. When Reindexing is done through the admin console, the logs show me the following:

    2010-01-12 07:07:56,459 INFO [btpool0-16] [;mid=1;ip=XX.xx.xx.xx;ua=Zimb raWebClient - FF2.0 (Win);] soap - ReIndexRequest
    2010-01-12 07:07:56,459 INFO [btpool0-16] [;mid=1;ip=xx.xx.xx.xx;ua=Zimb raWebClient - FF2.0 (Win);] misc - delegated access: doc=ReIndex, authenticated, target

    The above lines show up several times, but no indexing happens.

    When I run the reindexing through the command line, I see the following in the logs:

    2010-01-12 07:06:49,371 INFO [btpool0-17] [;mid=1;ip=xx.xx.xx.xx;ua=Zimb raWebClient - FF2.0 (Win);] soap - ReIndexRequest
    2010-01-12 07:06:49,373 INFO [btpool0-17] [;mid=1;ip=xx.xx.xx.xx;ua=Zimb raWebClient - FF2.0 (Win);] misc - delegated access: doc=ReIndex, authenticated, target
    2010-01-12 07:06:49,374 INFO [btpool0-17] [;mid=1;ip=xx.xx.xx.xx;ua=Zimb raWebClient - FF2.0 (Win);] SoapEngine - handler exception
    com.zimbra.common.service.ServiceException: mbox cffd2c43-f792-4d53-98be-73b10a485845 is not currently running action ReIndex
    Code:service.NOT_IN_PROGRESS Arg: (mboxId, IID, "cffd2c43-f792-4d53-98be-73b10a485845") Arg: (action, STR, "ReIndex")
    at com.zimbra.common.service.ServiceException.NOT_IN_ PROGRESS(
    at com.zimbra.cs.service.admin.ReIndex.handle(ReIndex .java:109)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:272)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:156)
    at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:291)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:212)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:129)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:747)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(

    Any hints?
    Sir Bob
    Last edited by Sir Bob; 01-12-2010 at 06:25 AM.

  2. #2
    Join Date
    Sep 2008
    Rep Power


    I'm getting the same experience in the GUI and very similar behavior at the CLI. Looking at the logs, it appears that it is doing something (not sure if its the reindexing), but the GUI remains static and the errors start off the process, in the logs followed by *hundreds of thousands* of lines like this:

    2010-04-15 13:42:49,046 INFO [btpool0-191://{}/service/admin/soap/ReIndexRequest] [name={};mid=198;ip={};ua=ZimbraWebClient - FF3.0 (Win);] misc - delegated access: doc=ReIndex, authenticated account={}, target account={}
    2010-04-15 13:42:49,069 INFO [btpool0-191://{}/service/admin/soap/ReIndexRequest] [name={};mid=198;ip={};ua=ZimbraWebClient - FF3.0 (Win);] soap - ReIndexRequest
    2010-04-15 13:42:49,069 INFO [btpool0-191://{}/service/admin/soap/ReIndexRequest] [name={};mid=198;ip={};ua=ZimbraWebClient - FF3.0 (Win);] misc - delegated access: doc=ReIndex, authenticated account={}, target account={}
    2010-04-15 13:42:49,104 INFO [btpool0-191://{}/service/admin/soap/ReIndexRequest] [name={};mid=198;ip={};ua=ZimbraWebClient - FF3.0 (Win);] soap - ReIndexRequest
    continue ~ad nauseam~

    So, either that's the mailbox being reindexed and my problem is on the GUI side; or I've got a reindexing issue on the fundamental level. Any ideas?

  3. #3
    Join Date
    Sep 2008
    Rep Power


    2010-04-15 14:06:42,357 INFO [ReIndex-1] [name={};mid=161;] mailbox - Deferred Indexing: submitted 64167 items in 1715399ms (37.41/sec). (0 items failed to index). IndexDeferredCount now at 684 NumNotSubmitted= 432
    2010-04-15 14:06:42,383 INFO [ReIndex-1] [name={};mid=161;] mailbox - Re-Indexing: Mailbox 161 COMPLETED in 1715402ms

    Just got this. Looks like it's completing, just not updating the GUI.

  4. #4
    Join Date
    Apr 2009
    Calgary, Alberta
    Rep Power


    Hi Emiro,

    In my case, I was on version 6.0.1 of Zimbra. This was one of several problems I saw in the admin console. An upgrade t 6.0.5 cured all problems and things work as advertized. Not sure if you are in the same boat or not......

    Sir Bob

  5. #5
    Join Date
    Apr 2008
    New Paltz, NY
    Rep Power


    With both 6.0.5 and 6.0.6 I've never seen any progress for reindexing in the Admin UI (as you've reported). Using the command line of:
    zmprov rim status

    DOES show me that accounts are being reindexed for a while (time depends on the size of the account - a few moments for virtually empty accounts though) and eventually shows as being completed.

    It never says HOW MANY messages are completed/failed/etc but it does appear to work for us.
    Paul Chauvet
    State University of New York at New Paltz

Similar Threads

  1. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  2. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 08:22 AM
  3. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 07:18 PM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts