Results 1 to 4 of 4

Thread: [SOLVED] Enable replication on master issue

  1. #1
    Join Date
    Mar 2009
    Posts
    16
    Rep Power
    6

    Exclamation [SOLVED] Enable replication on master issue

    Hi guys...
    Yesterday I was trying to setup replication on ZCS 6.0.4 in our test env,
    but for some strange reasons i got some strange errors....
    Maybe someone can point me into the right direction to fix it...

    So.. while running /opt/zimbra/libexec/zmldapenablereplica i got this...

    /opt/zimbra/libexec/zmldapenablereplica
    Enabling sync provider on master...FAILED
    ERROR: Unable to add accesslog database to zimbra.domain.com - exiting
    ldap_initialize( ldapi:///??base ) ldap_add: Other (e.g., implementation specific) error (80) additional info: no structuralObjectClass operational attribute

    and when I run the same command the second time I got this...
    Enabling sync provider on master...FAILED
    ERROR: Unable to add accesslog database to zimbra.domain.com - exiting
    ldap_add: No such object (32) adding new entry "olcDatabase={2}hdb,cn=config"


    Any ideas what might be wrong ?
    Last edited by winampus; 01-14-2010 at 01:44 AM.

  2. #2
    Join Date
    Mar 2009
    Posts
    16
    Rep Power
    6

    Default

    Maybe someone can point some ideas about manually enabling the replication ? Or suggest some debugging ideas ?

    Thanks in advance...

    Best regards,
    Alex R.

  3. #3
    Join Date
    Mar 2009
    Posts
    16
    Rep Power
    6

    Default

    After fessing around I got some more details...
    I have tried to do some of the things manually based on the how to promote an ZCS ldap Replica to Master and got following error when I was adding following :
    Code:
    dn: olcDatabase={2}hdb,cn=config
    changetype: add
    objectClass: olcDatabaseConfig
    objectClass: olcHdbConfig
    olcDatabase: {2}hdb
    olcDbDirectory: /opt/zimbra/data/ldap/accesslog/db
    olcSuffix: cn=accesslog
    olcAccess: {0}to dn.subtree="cn=accesslog" by dn.exact="uid=zimbra,cn=admins,cn=zimbra" read by dn.exact="cn=config" read by dn.exact="uid=zmreplica,cn=admins,cn=zimbra" read
    olcLastMod: TRUE
    olcMaxDerefDepth: 15
    olcReadOnly: FALSE
    olcRootDN: cn=config
    olcSizeLimit: unlimited
    olcTimeLimit: unlimited
    olcMonitoring: TRUE
    olcDbCacheSize: 10000
    olcDbCheckpoint: 64 5
    olcDbNoSync: FALSE
    olcDbDirtyRead: FALSE
    olcDbIDLcacheSize: 10000
    olcDbIndex: entryCSN eq
    olcDbIndex: objectClass eq
    olcDbIndex: reqEnd eq
    olcDbIndex: reqResult eq
    olcDbIndex: reqStart eq
    olcDbLinearIndex: FALSE
    olcDbMode: 0600
    olcDbSearchStack: 16
    olcDbShmKey: 0
    olcDbCacheFree: 1
    olcDbDNcacheSize: 0
    And the error in zimbra log was :
    Code:
    Jan 14 23:18:57 zimbra1 slapd[7403]: slap_queue_csn: queing 0x42a833d0 20100114211857.104500Z#000000#000#000000 
    Jan 14 23:18:57 zimbra slapd[7403]: No structuralObjectClass for entry (olcDatabase={3}hdb,cn=config) 
    Jan 14 23:18:57 zimbra slapd[7403]: slap_graduate_commit_csn: removing 0x13c49540 20100114211857.104500Z#000000#000#000000
    The strange part is that in there is nothing pointing to olcDatabase={3}hdb,cn=config in the add code...

    Can someone advise me how to get a zimbra default olcDatabase={3}hdb,cn=config created ?

    I know it sounds like a dummy, which obviously I am since i can't manage to get some simple command la zmldapenablereplica to work.... but i really need some more info about the structure and the content of it...

    I hope some of you might me able to help...

    Best regards,
    Alex R.

  4. #4
    Join Date
    Mar 2009
    Posts
    16
    Rep Power
    6

    Default Solved...

    We... Since I didn't manage to setup the replication using zmldapenablereplica, I have done the work manually and it seems that worked.

    Also I never managed to get the root cause. I've installed a new server, compared the schema on both the existing Master and the New server and everything is identical. On the new one zmldapenablereplica worked without any problem.

    Best regards,
    Alex R.

Similar Threads

  1. LDAP Replication Experiences
    By technikolor in forum Administrators
    Replies: 4
    Last Post: 11-11-2008, 11:52 PM
  2. LDAP Master Replication Issue
    By tmf in forum Administrators
    Replies: 1
    Last Post: 04-12-2008, 09:28 AM
  3. Issue with LDAP replication
    By peter@mxtoolbox.com in forum Administrators
    Replies: 0
    Last Post: 06-08-2007, 02:31 PM
  4. How to disable LDAP replication on the master server
    By jpawlyn in forum Administrators
    Replies: 0
    Last Post: 04-29-2007, 10:03 AM
  5. Intermittent issue (issue# 5852) ?
    By nick20 in forum Installation
    Replies: 1
    Last Post: 02-08-2006, 01:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •