Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: [SOLVED] Moved server - now cannot send mail

  1. #1
    Join Date
    Dec 2007
    Location
    Chiang Mai, Thailand
    Posts
    29
    Rep Power
    7

    Default [SOLVED] Moved server - now cannot send mail

    I followed the instructions at Moving ZCS to Another Server Ľ Zimbra :: Blog
    and moved our zimbra 5.09 from an ubuntu 6.06 server to a new ubuntu 8.04 box.

    Everything seems to be fine - I can login to the web client, receive emails, add calendar entries etc. However the big problem is that I now cannot send emails to external domains (internal works fine).

    From looking through the forums it seems likely that this is a dns problem however I have tried a few things and made no difference. I would be very grateful for some assistance on this.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    What does /var/log/zimbra.log show when you try and send a email ? Have you checked, as the zimbra user, you can perform DNS lookups for a remote domain. If you can perform DNS lookups try telneting to a remote MTA on port 25 to ensure outbound traffic is not being blocked.

  3. #3
    Join Date
    Dec 2007
    Location
    Chiang Mai, Thailand
    Posts
    29
    Rep Power
    7

    Default

    /var/log/zimbra.log says:

    Code:
    Jan 14 05:54:37 IS-10197 postfix/smtpd[17627]: connect from IS-10197.unassigned--
    domain[78.129.167.175]
    Jan 14 05:54:37 IS-10197 postfix/smtpd[17627]: NOQUEUE: reject: RCPT from IS-1011
    97.unassigned-domain[78.129.167.175]: 554 5.7.1 <steve@thinkmonkeys.com>: Relay  
    access denied; from=<steve@mydomain.com> to=<steve@externaldomain.com> proto=ESMTP  
    helo=<hvlmail.com>
    Jan 14 05:54:37 IS-10197 postfix/smtpd[17627]: disconnect from IS-10197.unassignn
    ed-domain[78.129.167.175]
    zimbra user can use dig command to resolve external domains
    I can telnet to port 25 on a remote server

    thanks

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    First of all looks like you do not have rDNS entry for your Zimbra server
    Code:
    IS-10197.unassigned--domain[78.129.167.175]
    Is it sending to the correct server as it would appear steve@externaldomain.com does not reside on the remote server due to the relay error message.

  5. #5
    Join Date
    Dec 2007
    Location
    Chiang Mai, Thailand
    Posts
    29
    Rep Power
    7

    Default

    how do i go about fixing the rDNS problem?
    my domains are hvlmail.com and cmhmail.com and both of those point at this machine's ip 78.129.167.175

    I am unsure from that log entry which server the email is being sent to... I have tried to send to multiple email addresses with different domains and they all fail.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by geoffDeGeoffGeoff View Post
    my domains are hvlmail.com and cmhmail.com and both of those point at this machine's ip 78.129.167.175
    That's not quite correct from my (DNS) point of view, the following is returned:

    Code:
    dig hvlmail.com any
    ;; global options: +cmd                 
    ;; Got answer:                          
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52505
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;hvlmail.com.                   IN      ANY
    
    ;; ANSWER SECTION:
    hvlmail.com.            172766  IN      NS      ns60.1and1.co.uk.
    hvlmail.com.            172766  IN      NS      ns59.1and1.co.uk.
    
    ;; ADDITIONAL SECTION:
    ns60.1and1.co.uk.       86368   IN      A       212.227.123.78
    ns59.1and1.co.uk.       75653   IN      A       195.20.224.84 
    
    ;; Query time: 2 msec
    ;; SERVER: 192.168.1.10#53(192.168.1.10)
    ;; WHEN: Thu Jan 14 15:20:26 2010
    ;; MSG SIZE  rcvd: 110
    
    dig hvlmail.com mx
    
    ; <<>> DiG 9.6.1-P2 <<>> hvlmail.com mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 56793
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;hvlmail.com.                   IN      MX
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.10#53(192.168.1.10)
    ;; WHEN: Thu Jan 14 15:20:33 2010
    ;; MSG SIZE  rcvd: 29
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Agreed Phoenix and no rDNS is available
    Code:
    dig -x 78.129.167.175
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.1 <<>> -x 78.129.167.175
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 7633
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;175.167.129.78.in-addr.arpa.	IN	PTR
    
    ;; AUTHORITY SECTION:
    167.129.78.in-addr.arpa. 10800	IN	SOA	ns2.rapidswitch.com. hostmaster.rapidswitch.com. 2010010301 3600 120 1209600 10800
    
    ;; Query time: 40 msec
    ;; SERVER: 192.168.1.103#53(192.168.1.103)
    ;; WHEN: Thu Jan 14 14:23:39 2010
    ;; MSG SIZE  rcvd: 111
    To resolve the rDNS issue you would need to talk to your ISP and get them to set it up for you.

  8. #8
    Join Date
    Dec 2007
    Location
    Chiang Mai, Thailand
    Posts
    29
    Rep Power
    7

    Default

    ok, I don't reckon the dns has propogated yet as
    dig hvlmail.com any on that server any gives:
    Code:
    ; <<>> DiG 9.4.2-P2.1 <<>> hvlmail.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43220
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 2, ADDITIONAL: 7
    
    ;; QUESTION SECTION:
    ;hvlmail.com.			IN	ANY
    
    ;; ANSWER SECTION:
    hvlmail.com.		86400	IN	SOA	ns59.1and1.co.uk. hostmaster.1and1.co.uk. 2010011401 28800 7200 604800 86400
    hvlmail.com.		86400	IN	MX	10 hvlmail.com.
    hvlmail.com.		86400	IN	MX	20 mx01.1and1.co.uk.
    hvlmail.com.		47970	IN	A	78.129.167.175
    hvlmail.com.		86400	IN	NS	ns60.1and1.co.uk.
    hvlmail.com.		86400	IN	NS	ns59.1and1.co.uk.
    
    ;; AUTHORITY SECTION:
    hvlmail.com.		86400	IN	NS	ns59.1and1.co.uk.
    hvlmail.com.		86400	IN	NS	ns60.1and1.co.uk.
    
    ;; ADDITIONAL SECTION:
    hvlmail.com.		47970	IN	A	78.129.167.175
    mx01.1and1.co.uk.	457	IN	A	212.227.15.150
    mx01.1and1.co.uk.	457	IN	A	212.227.15.169
    mx01.1and1.co.uk.	457	IN	A	212.227.15.186
    mx01.1and1.co.uk.	457	IN	A	212.227.15.134
    ns59.1and1.co.uk.	79002	IN	A	195.20.224.84
    ns60.1and1.co.uk.	79002	IN	A	212.227.123.78
    
    ;; Query time: 186 msec
    ;; SERVER: 87.117.198.200#53(87.117.198.200)
    ;; WHEN: Thu Jan 14 14:33:27 2010
    ;; MSG SIZE  rcvd: 318
    however the dig -x 78.129.167.175 gives the same result as uxbod posted. I will contact my isp about this. we use 2 domains so presumably both should be set up to return on an rDNS lookup?

  9. #9
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    No The rDNS entry for your ZCS server should point to the FQDN. I see from your dig
    Code:
    hvlmail.com.		86400	IN	MX	10 hvlmail.com.
    that you point it just at the domain name. You should really have it pointing to mail.hvlmail.com and any others domains using your ZCS server should point to the same one.

    Please post the following so we can check your setup
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes
    su - zimbra
    zmhostname

  10. #10
    Join Date
    Dec 2007
    Location
    Chiang Mai, Thailand
    Posts
    29
    Rep Power
    7

    Default

    Code:
    root@IS-10197:~# cat /etc/hosts
    127.0.0.1	localhost.localdomain	localhost
    78.129.167.175	IS-10197.unassigned-domain	IS-10197
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    Code:
    root@IS-10197:~# cat /etc/resolv.conf
    search unassigned-domain
    nameserver 87.117.198.200
    nameserver 87.117.237.100
    nameserver 87.117.196.200
    Code:
    root@IS-10197:~# dig hvlmail.com any
    
    ; <<>> DiG 9.4.2-P2.1 <<>> hvlmail.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28869
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 2, ADDITIONAL: 6
    
    ;; QUESTION SECTION:
    ;hvlmail.com.			IN	ANY
    
    ;; ANSWER SECTION:
    hvlmail.com.		52922	IN	A	78.129.167.175
    hvlmail.com.		47244	IN	MX	10 hvlmail.com.
    hvlmail.com.		47244	IN	MX	20 mx01.1and1.co.uk.
    hvlmail.com.		53247	IN	NS	ns59.1and1.co.uk.
    hvlmail.com.		53247	IN	NS	ns60.1and1.co.uk.
    
    ;; AUTHORITY SECTION:
    hvlmail.com.		53247	IN	NS	ns60.1and1.co.uk.
    hvlmail.com.		53247	IN	NS	ns59.1and1.co.uk.
    
    ;; ADDITIONAL SECTION:
    mx01.1and1.co.uk.	5759	IN	A	212.227.15.186
    mx01.1and1.co.uk.	5759	IN	A	212.227.15.134
    mx01.1and1.co.uk.	5759	IN	A	212.227.15.150
    mx01.1and1.co.uk.	5759	IN	A	212.227.15.169
    ns59.1and1.co.uk.	84421	IN	A	195.20.224.84
    ns60.1and1.co.uk.	84421	IN	A	212.227.123.78
    
    ;; Query time: 1 msec
    ;; SERVER: 87.117.198.200#53(87.117.198.200)
    ;; WHEN: Thu Jan 14 14:45:42 2010
    ;; MSG SIZE  rcvd: 255
    Code:
    root@IS-10197:~# dig hvlmail.com mx
    
    ; <<>> DiG 9.4.2-P2.1 <<>> hvlmail.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64858
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 7
    
    ;; QUESTION SECTION:
    ;hvlmail.com.			IN	MX
    
    ;; ANSWER SECTION:
    hvlmail.com.		85623	IN	MX	20 mx01.1and1.co.uk.
    hvlmail.com.		85623	IN	MX	10 hvlmail.com.
    
    ;; AUTHORITY SECTION:
    hvlmail.com.		85623	IN	NS	ns59.1and1.co.uk.
    hvlmail.com.		85623	IN	NS	ns60.1and1.co.uk.
    
    ;; ADDITIONAL SECTION:
    hvlmail.com.		47193	IN	A	78.129.167.175
    mx01.1and1.co.uk.	6881	IN	A	212.227.15.134
    mx01.1and1.co.uk.	6881	IN	A	212.227.15.150
    mx01.1and1.co.uk.	6881	IN	A	212.227.15.169
    mx01.1and1.co.uk.	6881	IN	A	212.227.15.186
    ns59.1and1.co.uk.	78225	IN	A	195.20.224.84
    ns60.1and1.co.uk.	78225	IN	A	212.227.123.78
    
    ;; Query time: 1 msec
    ;; SERVER: 87.117.198.200#53(87.117.198.200)
    ;; WHEN: Thu Jan 14 14:46:24 2010
    ;; MSG SIZE  rcvd: 227
    Code:
    root@IS-10197:~# host `hostname`
    Host IS-10197 not found: 3(NXDOMAIN)
    Code:
    zimbra@IS-10197:/root$ zmhostname
    hvlmail.com

Similar Threads

  1. zmmailboxdctl is not running !!!!!!
    By olibite in forum Administrators
    Replies: 14
    Last Post: 04-28-2011, 05:50 AM
  2. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  3. Replies: 2
    Last Post: 02-12-2008, 10:55 AM
  4. fatal: Queue report unavailable - mail system is down
    By zzzzsg in forum Administrators
    Replies: 16
    Last Post: 08-24-2006, 02:31 AM
  5. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-03-2006, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •