Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 34

Thread: ClamAV not identifying viruses

  1. #21
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    Quote Originally Posted by uxbod View Post
    Correct; as it is not defined as standard within the Zimbra configuration. Hence filing the RFE.
    So, I delete from begin of config this:
    $warnvirussender = 1;

    And post your
    warnvirussender => 1,
    string in section

    Code:
    $policy_bank{'MYNETS'} = {
      originating                 => 1,
      warnvirussender         => 1,
      allow_disclaimers           => %%binary VAR:zimbraDomainMandatoryMailSignatureEnabled%%,
      log_level                   => 1,
    };
    Have not effect. Alert only for recipient.

  2. #22
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Are you restarting Amavis after making the changes ?

  3. #23
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    Quote Originally Posted by uxbod View Post
    Are you restarting Amavis after making the changes ?
    Yes, off course!

  4. #24
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    It was a simple question, and I am trying to help It may be that it is not being written to the normal config so run
    Code:
    su - zimbra
    zmmtactl stop ; zmmtactl start

  5. #25
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    Quote Originally Posted by uxbod View Post
    It was a simple question, and I am trying to help It may be that it is not being written to the normal config so run
    Code:
    su - zimbra
    zmmtactl stop ; zmmtactl start
    Sorry, my English is not perfect!
    I did mean "of course", "surely"!
    Thanks allot for your help!

    Wait, I just testing test your last instruction...

  6. #26
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    No effect(

  7. #27
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Has the new option been written okay into /opt/zimbra/conf/amavisd.conf ? When you restarted it should have picked it up from the .in (include) file.

  8. #28
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    Yes, *.conf file reloaded from *.conf.in good!

    Also I reading *.conf and comparing within *.conf.in now and find this interesting string:

    *.conf.in:
    $warnvirusrecip = %%binary VAR:zimbraVirusWarnRecipient%%;

    *.conf:
    $warnvirusrecip = 1;

    ===

    So, I put in the *.conf.in also your string:
    $warnvirussender = 1;

    Will be testing...

  9. #29
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Yes, if you make the change to the .conf file it will be over-written as restart; so for the change to be persistent it should be put in the .conf.in file aswell.

  10. #30
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    Again...\
    status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

Similar Threads

  1. Clamav
    By physikal in forum Administrators
    Replies: 10
    Last Post: 05-18-2009, 09:48 AM
  2. [SOLVED] Howto: Update ClamAV
    By unilogic in forum Administrators
    Replies: 9
    Last Post: 12-12-2007, 04:28 AM
  3. [SOLVED] Clamav expiration notification
    By artimus in forum Administrators
    Replies: 8
    Last Post: 11-19-2007, 09:34 AM
  4. help for clamav outdated
    By newvision in forum Administrators
    Replies: 3
    Last Post: 02-16-2007, 08:14 PM
  5. Replies: 2
    Last Post: 03-15-2006, 08:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •