Results 1 to 9 of 9

Thread: [SOLVED] Moving to new server with 6.0.4 - doesn't look good

  1. #1
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    148
    Rep Power
    7

    Default [SOLVED] Moving to new server with 6.0.4 - doesn't look good

    Hello.
    Unfortunately I'm at a spot where I just cannot run Zimbra on it's existing machine. Although I have less than 100 users, the machine is running like a slug. With 3GB RAM and a Core 2 Duo it's just not holding up. I'm in for about a gig of swap!

    Anyway, the new VM is on a quad core xeon and has up to 16GB of RAM available. My problem is I can't figure out how to move to the new machine.

    According to Moving ZCS to New Server - Zimbra :: Wiki and
    CLI zmrestore Network Edition only - Zimbra :: Wiki
    This shouldn't be very painful but I'm running into some scary messages along the way.

    I'm running the install of 6.0.4 onto CentOS 5.x (latest yum updates) and I use the --platform-override and --license /downloads/license.xml

    I go through and configure everything but here's what happens:

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes] Yes
    Save config in file: [/opt/zimbra/config.32506]
    Saving config in /opt/zimbra/config.32506...done.
    The system will be modified - continue? [No] Yes
    Operations logged to /tmp/zmsetup.01252010-233701.log
    Setting local config values...done.
    Setting up CA...done.
    Deploying CA to /opt/zimbra/conf/ca ...done.
    Creating SSL certificate...done.
    Installing mailboxd SSL certificates...done.
    Initializing ldap...done.
    Setting replication password...done.
    Setting Postfix password...done.
    Setting amavis password...done.
    Setting nginx password...done.
    Creating server entry for z1.ourRealDomainName.com...failed.
    Saving CA in ldap ...done.
    Saving SSL Certificate in ldap ...done.
    Setting spell check URL...failed.
    Setting service ports on z1.ourRealDomainName.com...done.
    Adding z1.ourRealDomainName.com to zimbraMailHostPool in default COS...failed. Couldn't find a server entry for z1.ourRealDomainName.com
    Installing webclient skins...
    lavender...failed.
    steel...failed.
    sand...failed.
    hotrod...failed.
    smoke...failed.
    bare...failed.
    bones...failed.
    sky...failed.
    zmail...failed.
    beach...failed.
    lemongrass...failed.
    yahoo...failed.
    goldrush...failed.
    waves...failed.
    Finished installing webclient skins.
    Setting zimbraFeatureIMEnabled=FALSE...failed.
    Setting zimbraFeatureTasksEnabled=TRUE...failed.
    Setting zimbraFeatureBriefcasesEnabled=TRUE...failed.
    Setting zimbraFeatureNotebookEnabled=TRUE...failed.
    Setting convertd URL...failed.
    Setting MTA auth host...failed.
    Setting TimeZone Preference...failed.
    Initializing mta config...done.
    Setting services on z1.ourRealDomainName.com...done.
    Creating domain z1.ourRealDomainName.com...failed.
    Setting default domain name...failed.
    Setting up default domain admin UI components..failed.
    Granting group zimbraDomainAdmins@z1.ourRealDomainName.com domain right +domainAdminConsoleRights on z1.ourRealDomainName.com...failed.
    Granting group zimbraDomainAdmins@z1.ourRealDomainName.com global right +domainAdminZimletRights...failed.
    Setting up global distribution list admin UI components..failed.
    Granting group zimbraDLAdmins@z1.ourRealDomainName.com global right +adminConsoleDLRights...failed.
    Granting group zimbraDLAdmins@z1.ourRealDomainName.com global right +listAccount...failed.
    Creating domain z1.ourRealDomainName.com...failed.
    Creating admin account admin@z1.ourRealDomainName.com...failed.
    Creating root alias...failed.
    Creating postmaster alias...failed.
    Creating user wiki@z1.ourRealDomainName.com...failed.
    Creating user spam.mzkt3we0@z1.ourRealDomainName.com...failed.
    Creating user ham.zduynqeo6p@z1.ourRealDomainName.com...failed.
    Setting spam training accounts...failed.
    Initializing store sql database...done.
    Setting zimbraSmtpHostname for z1.ourRealDomainName.com...failed.
    Configuring SNMP...done.
    Checking for default IM conference room...not present.
    Initializing default IM conference room...failed.
    Setting up syslog.conf...ERROR: service.FAILURE (system failure: unable to get config) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    updateSyslog: Updating /etc/syslog.conf....done.
    done.
    Setting default backup schedule...Done
    Looking for valid license to install...failed to install license.

    *******ERROR

    Failed to install a license - this will prevent your server from functioning properly
    Please contact Zimbra to obtain a license
    Press RETURN to continue
    Starting servers...Unable to determine enabled services from ldap.
    done.
    Installing common zimlets...
    com_zimbra_local...failed. This may impact system functionality.
    com_zimbra_email...failed. This may impact system functionality.
    com_zimbra_ymemoticons...failed. This may impact system functionality.
    com_zimbra_bulkprovision...failed. This may impact system functionality.
    com_zimbra_phone...failed. This may impact system functionality.
    com_zimbra_date...failed. This may impact system functionality.
    com_zimbra_url...failed. This may impact system functionality.
    com_zimbra_adminversioncheck...failed. This may impact system functionality.
    com_zimbra_cert_manager...failed. This may impact system functionality.
    Finished installing common zimlets.
    Installing network zimlets...
    com_zimbra_backuprestore...failed. This may impact system functionality.
    com_zimbra_mobilesync...failed. This may impact system functionality.
    com_zimbra_convertd...failed. This may impact system functionality.
    com_zimbra_hsm...failed. This may impact system functionality.
    com_zimbra_license...failed. This may impact system functionality.
    com_zimbra_delegatedadmin...failed. This may impact system functionality.
    Finished installing network zimlets.
    Initializing Documents...failed to initialize documents...see logfile for details.
    Restarting mailboxd...done.
    Setting up zimbra crontab...done.


    Moving /tmp/zmsetup.01252010-233701.log to /opt/zimbra/log


    Configuration complete - press return to exit
    Is this busted or are all these failed messages to be ignored or what?

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    I am betting prior to applying the configuration the install script complained that you did not have a valid MX. You should check that IPTables and SELinux are not running; plus that you have a valid /etc/hosts and DNS records.

  3. #3
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    148
    Rep Power
    7

    Default

    Thanks for your reply,
    That's a trick though... I have a live server. I have to keep it running until the replacement server is ready. I can't get the replacement server ready until it has the MX records etc. I can't setup those or the live server is no longer live.... Chicken or Egg anyone?

  4. #4
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    You'll have to go for the Split DNS setup. Install a DNS server on the machine and point the domain records to itself. See many posts here...

  5. #5
    Join Date
    Sep 2009
    Location
    Canada
    Posts
    13
    Rep Power
    6

    Default

    If we have two MX records and the first one failed ( new server ) the second MX record ( old server ) should works no ? I think it's how MX is designed.

  6. #6
    Join Date
    Jan 2008
    Posts
    658
    Rep Power
    8

    Default

    You could always setup a DNS view that only responds to requests from that IP so the Zimbra server thinks everything is in place.

  7. #7
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    148
    Rep Power
    7

    Default Split DNS

    The Split DNS approach has worked enough to allow a proper installation. It's too bad you couldn't pass an install command-line variable such as --skip-dns or some such thing. Anyway it's not too hard to use the split DNS.

    Now my concern is installing the backups and seeing if all the custom settings from the live server kick in for the new server. We have some domain aliasing, domain admins and other fun things to watch out for.

  8. #8
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    148
    Rep Power
    7

    Default Cannot run... all sorts of errors...

    I've attached some of the output of the error log. I've used Split DNS to install zimbra on a new machine. I can't seem to get it to run now. I'm getting a pile of errors such as:

    Jan 26 15:32:26 z1 zimbramon[6676]: 6676:info: zmmtaconfig: gacf ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.net.ssl.SSLHandshakeException sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: timestamp check failed)
    Jan 26 15:32:29 z1 zimbramon[6676]: 6676:info: zmmtaconfig: Skipping getAllReverseProxyURLs ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.net.ssl.SSLHandshakeException sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: timestamp check failed
    All I've done is install zimbra to this point. I haven't even logged into the admin, copied over the backups from the live server... etc.
    Attached Files Attached Files

  9. #9
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    148
    Rep Power
    7

    Default Fixed

    I don't know what it is, but I had to wipe the new machine clean before this would work. Anyway it's up and running.

Similar Threads

  1. zmmailboxdctl is not running !!!!!!
    By olibite in forum Administrators
    Replies: 14
    Last Post: 04-28-2011, 05:50 AM
  2. [SOLVED] Moving mailboxes to second mailbox server
    By xtrac in forum Administrators
    Replies: 3
    Last Post: 09-02-2009, 01:45 AM
  3. Replies: 8
    Last Post: 08-07-2008, 05:18 AM
  4. Replies: 10
    Last Post: 11-21-2007, 02:32 AM
  5. Moving to new server on new domain...
    By jeremymaritz in forum Installation
    Replies: 1
    Last Post: 07-16-2007, 02:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •