Results 1 to 3 of 3

Thread: [SOLVED] How to avoid IE warning of mixed http/https content

  1. #1
    Join Date
    Feb 2007
    Location
    Austin, TX
    Posts
    110
    Rep Power
    8

    Default [SOLVED] How to avoid IE warning of mixed http/https content

    Installed a new server (6.0.4) and when you browse to ZCS with IE you get a warning

    Do you want to view only the webpage content that was delivered securely?

    This webpage contains content that will not be delivered using a secure HTTPS connection which would compromise the security of the webpage.
    I have older servers which do not have this problem but I can't figure out what is different from a configuration point of view or what I could do to fix this.

    I have zimbraMailMode set to redirect.

    UPDATE: I'm an idiot. The new version has you configure logos with URLs and I didn't have them set to https://. I'm used to my old version 5 system where I had to manage themes manually by putting files in /jetty.

    UPDATE2: So I've made the changes in the Admin GUI -> Glogbal Settings -> Themes ->to use https references for ImgAppBanner and ImgLoginBanner. I've flushed the cache and it didn't take. I ran zmmailboxdctl restart and it didn't take. I did a full zmcontrol stop/start and I still get the old references and thus the warning.

    I found that the reference is in this CSS file - https://server.domain.com/zimbra/css...v=091020150430

    Peter
    Last edited by peter@mxtoolbox.com; 01-27-2010 at 09:29 AM.
    Peter LeBlond
    Product Development Engineer
    http://www.mxtoolbox.com


  2. #2
    Join Date
    Feb 2007
    Location
    Austin, TX
    Posts
    110
    Rep Power
    8

    Smile

    Finally fixed.

    The default domain for the server had different urls from the default and they were responsible. After I reset them back to default everything was alright.
    Peter LeBlond
    Product Development Engineer
    http://www.mxtoolbox.com


  3. #3
    Join Date
    Feb 2007
    Location
    Austin, TX
    Posts
    110
    Rep Power
    8

    Default

    Somebody PM'd me to ask for more details. I posted tired or something because I had to look this up again to figure out what I meant.

    The solution was to edit the "Application logo banner URL of the themes" and the "Login logo banner URL of the themes" both at the "Global Settings" level and also for the default domain listed under the General Information tab in the Global Settings section. Switching these to https solved the problem.
    Peter LeBlond
    Product Development Engineer
    http://www.mxtoolbox.com


Similar Threads

  1. Replies: 17
    Last Post: 08-30-2010, 12:59 PM
  2. mta to not starting
    By cowanpf in forum Installation
    Replies: 2
    Last Post: 10-05-2009, 05:36 AM
  3. Clamav
    By physikal in forum Administrators
    Replies: 10
    Last Post: 05-18-2009, 10:48 AM
  4. [SOLVED] Error running mailboxd after script backup
    By ttortosa in forum Administrators
    Replies: 5
    Last Post: 10-22-2008, 02:33 AM
  5. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •