Results 1 to 7 of 7

Thread: Renaming disaster

  1. #1
    Join Date
    Mar 2008
    Location
    France
    Posts
    17
    Rep Power
    8

    Unhappy Renaming disaster

    Hi all

    I have renomming my existing domain (about 2000 account) with:

    zmprov -l rd ancien.fr nouveau.fr

    But just at the end, I get this:

    Exception in thread "main" java.util.MissingFormatArgumentException: Format specifier 's'
    at java.util.Formatter.format(Formatter.java:2429)
    at java.util.Formatter.format(Formatter.java:2364)
    at java.lang.String.format(String.java:2558)
    at com.zimbra.cs.account.ldap.RenameDomain.warn(Renam eDomain.java:807)
    at com.zimbra.cs.account.ldap.RenameDomain.warn(Renam eDomain.java:802)
    at com.zimbra.cs.account.ldap.RenameDomain.access$400 (RenameDomain.java:53)
    at com.zimbra.cs.account.ldap.RenameDomain$RenameDoma inVisitor.fixupForeignTarget(RenameDomain.java:732 )
    at com.zimbra.cs.account.ldap.RenameDomain$RenameDoma inVisitor.handleForeignAlias(RenameDomain.java:710 )
    at com.zimbra.cs.account.ldap.RenameDomain$RenameDoma inVisitor.visit(RenameDomain.java:451)
    at com.zimbra.cs.account.ldap.LdapProvisioning.search Objects(LdapProvisioning.java:1054)
    at com.zimbra.cs.account.ldap.LdapProvisioning.search Objects(LdapProvisioning.java:994)
    at com.zimbra.cs.account.ldap.RenameDomain.execute(Re nameDomain.java:116)
    at com.zimbra.cs.account.ldap.LdapProvisioning.rename Domain(LdapProvisioning.java:2052)
    at com.zimbra.cs.account.ProvUtil.doRenameDomain(Prov Util.java:815)
    at com.zimbra.cs.account.ProvUtil.execute(ProvUtil.ja va:634)
    at com.zimbra.cs.account.ProvUtil.main(ProvUtil.java: 2027)
    and nothing works now nouveau.fr is shutdown and I can't activate it
    :

    [zimbra@zimbra ~]$ zmprov -l md nouveau.fr zimbraDomainStatus active
    ERROR: service.INVALID_REQUEST (invalid request: domain vetagro-sup.fr is being renamed, cannot change zimbraDomainStatus)
    I see this too :

    [zimbra@zimbra ~]$ zmprov gd nouveau.fr |grep zimbraDomainRenameInfo:
    zimbraDomainRenameInfo: DEST:ancien.fr

    I know this entry should not be manually modified but is there any tips to delete this line ? Before trying to restore my backup, I would try anithing possible...

    Many many thanks for your help, I'm a little bite desperate now ...

  2. #2
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    14

    Default

    Which ZCS version ?
    Your profile shows 5.0.8

  3. #3
    Join Date
    Mar 2008
    Location
    France
    Posts
    17
    Rep Power
    8

    Default

    It's right 5.0.8. I know it's an old version. Should I update to next release first ?

  4. #4
    Join Date
    Mar 2006
    Posts
    300
    Rep Power
    10

    Default

    Quote Originally Posted by Nic View Post
    It's right 5.0.8. I know it's an old version. Should I update to next release first ?
    Shouldn't be necessary. Look at this thread.

    http://www.zimbra.com/forums/install...er-domain.html

  5. #5
    Join Date
    Mar 2008
    Location
    France
    Posts
    17
    Rep Power
    8

    Default

    b) If your on v5B3 or greater there's the command zmprov -l renameDomain {domain|id} {newDomain}
    This what I have done


    I have correctly restore backup last night so if I should ugrade, I'm ready to do this next week.

  6. #6
    Join Date
    Mar 2006
    Posts
    300
    Rep Power
    10

    Default

    Did you shutdown the mail services first?
    Also, you really should have any DNS changes already in place before you run the rename.

  7. #7
    Join Date
    Mar 2008
    Location
    France
    Posts
    17
    Rep Power
    8

    Default

    First, thank you for the reply tgx. I really need some help ...

    Did you shutdown the mail services first?
    No, I have done zmprov -l rd with ancien.fr running... (perhaps error come from this ?)
    I have try with zmcontrol stop before renaming domain but it doesn't work ... so Zimbra should be started

    However perhaps I have made a big mistake running zmprov rd on active domain and domain ancien.fr should be set in "maintenance mode" before renaming it to nouveau.fr ?

    Also, you really should have any DNS changes already in place before you run the rename.
    Hum ... perhaps another problem...
    nouveau.fr have a correct domain DNS record but not MX one

    I will try to make an offline test server populating with my last production backup...

Similar Threads

  1. Help recovering from disaster
    By acidbits in forum Administrators
    Replies: 3
    Last Post: 10-07-2009, 02:57 PM
  2. Question about redo logs and disaster recovery
    By dlochart in forum Administrators
    Replies: 10
    Last Post: 08-12-2008, 03:40 AM
  3. Disaster Recovery
    By rmvg in forum Administrators
    Replies: 4
    Last Post: 06-15-2008, 07:22 PM
  4. Zimbra NE: Disaster Recovery blues
    By generic31 in forum Administrators
    Replies: 7
    Last Post: 07-25-2007, 12:33 AM
  5. Disaster Recovery on a Multi Server Configuration
    By dlochart in forum Administrators
    Replies: 2
    Last Post: 04-14-2007, 05:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •