Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Zimbra not responding

  1. #1
    Join Date
    Apr 2006
    Posts
    48
    Rep Power
    9

    Default Zimbra not responding

    Not sure if this is the right place for this post. But recently I have to do a zmcontrol stop/start to get the mail server to respond. When I do a zmcontrol status everything looks fine. In the logs. I see a line

    Caused by: java.io.EOFException: SSL peer shut down incorrectly.

    It is in the log file quite a bit but I don't know if this is the cause of the issue. I can post the log file if you want let me know. Thanks

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    I suppose the question would be why is your SSL shutting down.

    Do you have anymore from the log? and a stacktrace might be useful.

  3. #3
    Join Date
    Apr 2006
    Posts
    48
    Rep Power
    9

    Default

    Let me know if this help any. I afraid I don't know what you mean by stacktrace

    javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRec ord(SSLSocketImpl.java:739)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.perform InitialHandshake(SSLSocketImpl.java:1025)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.writeRe cord(SSLSocketImpl.java:619)
    at com.sun.net.ssl.internal.ssl.AppOutputStream.write (AppOutputStream.java:59)
    at java.io.BufferedOutputStream.flushBuffer(BufferedO utputStream.java:65)
    at java.io.BufferedOutputStream.flush(BufferedOutputS tream.java:123)
    at com.zimbra.cs.pop3.Pop3Handler.sendLine(Pop3Handle r.java:387)
    at com.zimbra.cs.pop3.Pop3Handler.sendResponse(Pop3Ha ndler.java:376)
    at com.zimbra.cs.pop3.Pop3Handler.sendOK(Pop3Handler. java:359)
    at com.zimbra.cs.pop3.Pop3Handler.setupConnection(Pop 3Handler.java:116)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:196)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.io.EOFException: SSL peer shut down incorrectly
    at com.sun.net.ssl.internal.ssl.InputRecord.read(Inpu tRecord.java:321)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRec ord(SSLSocketImpl.java:720)
    ... 12 more
    2006-07-17 09:32:33,707 INFO [Pop3Server-260] [] ProtocolHandler - Handler exiting normally
    2006-07-17 09:32:34,182 INFO [Pop3Server-5] [] pop - connected
    2006-07-17 09:32:34,183 INFO [Pop3Server-5] [ip=192.168.7.1;] pop - -ERR only valid after entering TLS mode (USER administrator)
    2006-07-17 09:32:34,183 INFO [Pop3Server-5] [ip=192.168.7.1;] pop - quit from client
    2006-07-17 09:32:34,183 INFO [Pop3Server-5] [] ProtocolHandler - Handler exiting normally
    2006-07-17 09:32:34,184 INFO [Pop3Server-6] [] pop - connected
    2006-07-17 09:32:34,185 INFO [Pop3Server-6] [ip=192.168.7.1;] pop - -ERR only valid after entering TLS mode (USER administrator)
    2006-07-17 09:32:34,185 INFO [Pop3Server-6] [ip=192.168.7.1;] pop - quit from client

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Seems some clients are getting SSL/TLS errors when using POP. When you say the mail server is not responding can you get to the web client or is it entirely hung?

    If this happens again please try this:

    kill -QUIT <tomcat pid>

    This should dump the threads into /opt/zimbra/tomcat/log/catalina.out. Attach a zip file of that log here. We may be able to find out *where* the problem is from that stack trace.

    Also in general you should just need to run "tomcat restart" for this to clear. The full zmcontrol works but will just take longer.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Apr 2006
    Posts
    48
    Rep Power
    9

    Default

    When this happens you can still access the web client you just can't pull any new emails into outlook or thunderbird. I will run the command you posted next time it happens. Thanks for the advice. I will post next time I get the problem

  6. #6
    Join Date
    Apr 2006
    Posts
    48
    Rep Power
    9

    Default

    Ok it finally did it again, I admit it has been awhile I used the kill command. It did print out a catalina.out file do you want me to post here. Also we have zimbra running under jboss and tomcat. let me know it this helps at all.

  7. #7
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by jwilson
    Ok it finally did it again, I admit it has been awhile I used the kill command. It did print out a catalina.out file do you want me to post here. Also we have zimbra running under jboss and tomcat. let me know it this helps at all.
    It would be better to file a bug and attach a zip file with the log details.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #8
    Join Date
    Sep 2006
    Posts
    7
    Rep Power
    9

    Default wt is the bug ID

    hello;

    i found in my log the same exception. it is the first time it happens. but actually i didn't restart the server. i found it happned once in my log.

    so, plz if u know the bug id enclosing this problem, can u give me this information?

    thx in advance.

  9. #9
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default Once = no problem

    I believe that this can actually happen in the wild when a remote SSL client disconnects very early in the handshake. If it only happened once on your site, it's likely to be a client issue abd I wouldn't get overly worried about it.

    If it's happening a lot, that's a different story.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  10. #10
    Join Date
    Sep 2006
    Posts
    7
    Rep Power
    9

    Unhappy It happened again

    hello;

    I found the same exception again in my log file.
    it happened 24 times today!!!
    Attached Files Attached Files

Similar Threads

  1. Replies: 26
    Last Post: 04-19-2011, 09:24 AM
  2. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  3. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM
  4. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 06:18 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •