Results 1 to 9 of 9

Thread: Disable disk warning for one mount point

  1. #1
    Join Date
    Feb 2010
    Posts
    4
    Rep Power
    5

    Default Disable disk warning for one mount point

    I have not found on the forum how to disable the alerts for disk one mount point in particular which is full of 100% which make me receive alerts every 10 minutes

  2. #2
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

  3. #3
    Join Date
    Feb 2010
    Posts
    4
    Rep Power
    5

    Default

    Thank you but I don't see solution formy problem, I have already read this thread.

    My disk (not USB) is full and will remain so. I need to exclude it from the check

  4. #4
    Join Date
    Apr 2010
    Location
    Mexico City, México
    Posts
    10
    Rep Power
    5

    Default bump?

    same issue here, any help would be great, thanks

  5. #5
    Join Date
    Feb 2010
    Posts
    4
    Rep Power
    5

    Thumbs down

    I set the treshold at 120% so I am no longer receiving email

  6. #6
    Join Date
    Apr 2010
    Location
    Mexico City, México
    Posts
    10
    Rep Power
    5

    Default how?

    Where can I change that?

  7. #7
    Join Date
    Feb 2010
    Posts
    4
    Rep Power
    5

    Default

    my $DISK_CRIT_THRESHOLD = getLocalConfig("zmdisklog_critical_threshold") || 120;
    my $DISK_WARN_THRESHOLD = getLocalConfig("zmdisklog_warn_threshold") || 110;
    in /opt/zimbra/libexec/zmstat-df

  8. #8
    Join Date
    Nov 2008
    Location
    Denver, CO
    Posts
    221
    Rep Power
    7

    Default

    Or, you can just use the zmlocalconfig variables:

    Code:
    zmlocalconfig -e zmdisklog_warn_threshold=95
    zmlocalconfig -e zmdisklog_critical_threshold=99
    zmstatctl stop
    zmstatctl start
    Of course, this just sets the thresholds for all disks. If you want to just disable monitoring for a partition, you can set a custom variable:
    Code:
    zmlocalconfig -e zmdisklog_ignore_disks="sdc1"
    I just use the useful part of the mount point, no need for "/dev/", etc.

    To ignore more than one partition, separate them by a pipe:
    Code:
    zmlocalconfig -e zmdisklog_ignore_disks="sda1|sdc1"
    Then, to use the new variable, you modify zmstat-df. Comment out the my $DF line,
    Code:
    #my $DF = '/bin/df -k';
    and substitute:
    Code:
    my $IGNORE_DISKS = getLocalConfig("zmdisklog_ignore_disks");
    my $DF = "/bin/df -k | /bin/egrep -v \"$IGNORE_DISKS\"";
    Then, stop/start stats:
    Code:
    zmstatctl stop
    zmstatctl start
    If you don't want to bother with the variable, you can just be explicit in zmstat-df:
    Code:
    my $DF = '/bin/df -k | /bin/egrep -v sdc1';

  9. #9
    Join Date
    Sep 2007
    Location
    Aoteroa
    Posts
    128
    Rep Power
    8

    Default

    Hey, just a note to say this patch is no longer required.

    Instead use something like
    Code:
    zmlocalconfig -e zmstat_df_excludes="/mount/point:/mount/point2"

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 09:57 AM
  2. Replies: 17
    Last Post: 08-30-2010, 12:59 PM
  3. Clamav
    By physikal in forum Administrators
    Replies: 10
    Last Post: 05-18-2009, 10:48 AM
  4. [SOLVED] Error running mailboxd after script backup
    By ttortosa in forum Administrators
    Replies: 5
    Last Post: 10-22-2008, 02:33 AM
  5. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •