Results 1 to 2 of 2

Thread: GetMsgRequest system failure: MessagingException

Hybrid View

  1. #1
    Join Date
    Jan 2010
    Cochrane, Alberta
    Rep Power

    Default GetMsgRequest system failure: MessagingException

    I'm using ZD Beta2 and I can see this email no problem on webmail but when I click on it to view in ZD2 I get this error:

    method: GetMsgRequest
    msg: system failure: MessagingException while creating MimeMessage for item 33794
    code: service.FAILURE
    detail: soap:Receiver
    trace: com.zimbra.common.service.ServiceException: system failure: MessagingException while creating MimeMessage for item 33794 ExceptionId:btpool0-332:1266504767281:67df16f3073bcadf Code:service.FAILURE at com.zimbra.common.service.ServiceException.FAILURE ( at com.zimbra.cs.mailbox.MessageCache.getMimeMessage( at com.zimbra.cs.mailbox.Message.getMimeMessage(Messa at com.zimbra.cs.mailbox.Message.getMimeMessage(Messa at com.zimbra.cs.service.mail.ToXML.encodeMessageAsMP ( at com.zimbra.cs.service.mail.GetMsg.handle(GetMsg.ja va:102) at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:273) at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:157) at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:291) at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:212) at javax.servlet.http.HttpServlet.service(HttpServlet .java:727) at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra at javax.servlet.http.HttpServlet.service(HttpServlet .java:820) at org.mortbay.jetty.servlet.ServletHolder.handle(Ser at org.mortbay.jetty.servlet.ServletHandler.handle(Se at at org.mortbay.jetty.servlet.SessionHandler.handle(Se at org.mortbay.jetty.handler.ContextHandler.handle(Co at org.mortbay.jetty.webapp.WebAppContext.handle(WebA at org.mortbay.jetty.handler.ContextHandlerCollection .handle( at org.mortbay.jetty.handler.HandlerCollection.handle ( at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle( at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha at org.mortbay.jetty.Server.handle( at org.mortbay.jetty.HttpConnection.handleRequest(Htt at org.mortbay.jetty.HttpConnection$ ntent( at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:755) at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa at org.mortbay.jetty.HttpConnection.handle(HttpConnec at at org.mortbay.thread.BoundedThreadPool$ n( Caused by: javax.mail.MessagingException: Error in input stream; nested exception is: renaming destination file C:\Documents and Settings\glenn\Local Settings\Application Data\Zimbra\Zimbra Desktop\data\tmp\uncompressed\135CcaRRMPdnRtwMsgmJTjnoc4I= already exists at javax.mail.internet.InternetHeaders.load(InternetH at javax.mail.internet.InternetHeaders.(InternetHeade at javax.mail.internet.MimeMessage.createInternetHead ers( at javax.mail.internet.MimeMessage.parse(MimeMessage. java:328) at javax.mail.internet.MimeMessage.( 205) at com.zimbra.cs.mime.Mime$FixedMimeMessage.(Mime.jav a:89) at com.zimbra.cs.mailbox.MessageCache.getMimeMessage( ... 31 more Caused by: renaming destination file C:\Documents and Settings\glenn\Local Settings\Application Data\Zimbra\Zimbra Desktop\data\tmp\uncompressed\135CcaRRMPdnRtwMsgmJ Tjnoc4I= already exists at com.zimbra.common.util.FileUtil.rename(FileUtil.ja va:502) at at ile( at at at com.sun.mail.util.LineInputStream.readLine(LineInp at javax.mail.internet.InternetHeaders.load(InternetH ... 37 more

    Body: {
    GetMsgRequest: {
    _jsns: "urn:zimbraMail",
    m: {
    html: 1,
    id: "48289e7b-8bea-4eb2-88b8-0de03cba313d:33794",
    max: 100000,
    read: 1
    Header: {
    context: {
    _jsns: "urn:zimbra",
    account: {
    _content: "",
    by: "name"
    authToken: "(removed)",
    notify: {
    seq: 701
    session: {
    _content: 195,
    id: 195
    userAgent: {
    name: "ZimbraWebClient - PRISM (Win)",
    version: "0.0"

    Anyone have any idea what's going on?



    I fixed it by deleting the files in the C:\Documents and Settings\glenn\Local Settings\Application Data\Zimbra\Zimbra Desktop\data\tmp\uncompressed

    Why would this happen?
    Last edited by sagelike; 02-18-2010 at 07:01 AM. Reason: Fixed it

  2. #2
    Join Date
    Mar 2010
    Rep Power


    I had the same problem and this worked for me too. Thanks for posting the solution.

    on vista I have deleted the files from :
    C:\Users\MY_USER\AppData\Local\Zimbra\Zimbra Desktop\data\tmp\uncompressed

Similar Threads

  1. Installation zimbra Initializing ldap...failed. (28416)
    By farrukh.nadeem in forum Installation
    Replies: 10
    Last Post: 08-14-2009, 06:52 AM
  2. mysql not starting, sort of.
    By lhutton in forum Installation
    Replies: 6
    Last Post: 06-19-2009, 10:45 AM
  3. Replies: 4
    Last Post: 08-04-2008, 06:17 PM
  4. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  5. system failure: getDirectContext
    By avisser in forum Installation
    Replies: 3
    Last Post: 10-12-2005, 05:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts