Results 1 to 8 of 8

Thread: :( Postfix header_checks doesn't work

  1. #1
    Join Date
    Apr 2009
    Location
    France
    Posts
    9
    Rep Power
    6

    Unhappy :( Postfix header_checks doesn't work

    Hi all,
    I recently finished the upgrade to the V6. Now here is the issue I have :
    the header_checks.in does not work. After the reload of postfix, I see my new lines into the header_checks file :

    Here is what I add :
    Code:
    /^Sender:.*/ IGNORE
    /^Received: from localhost.*/ IGNORE
    /^Received: from .+\..+\.webmail .+(by society\.com .+) / REPLACE Received: $1
    /^Received:.*\[127\.0\.0\.1/ IGNORE
    /^Return-Path:.*/ IGNORE
    /^X-Originating-IP.*/ IGNORE
    /^X-Mailer.*/ IGNORE
    #/^X-Virus-Scanned:.*/ IGNORE
    and well there is just one entry which works :

    before :

    Code:
    Received: 	from webmail.society.com (webmail.society.com ) by mx.google.com with ESMTP
    Received: 	from localhost (localhost.localdomain [127.0.0.1]) by webmail.society.com (Postfix) with ESMTP id 
    Received: 	from webmail.society.com ([127.0.0.1]) by localhost (webmail.society.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id PE8yvmtRoyYo; Mon, 22 Feb 2010 17:26:32 +0100 (CET)
    Received: 	from webmail.society.com (localhost.localdomain [127.0.0.1]) by webmail.society.com (Postfix) with ESMTP id

    After :

    Code:
    Received: 	from webmail.society.com (webmail.society.com ) by mx.google.com with ESMTP
    Received: 	from localhost (localhost.localdomain [127.0.0.1]) by webmail.society.com (Postfix) with ESMTP id 
    Received: 	from webmail.society.com ([127.0.0.1]) by localhost (webmail.popgom.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id PE8yvmtRoyYo; Mon, 22 Feb 2010 17:26:32 +0100 (CET)
    So just the last line is gone, I disabled through the gui the option which allows the header_cheks to work
    Well plus the line "X-Originating-IP."
    but I still see 'localhost', X-Virus-Scanned (I commented the line, but I didn't work, that's why

    And the most-annoying thing, the
    Code:
    /^Sender:.*/ IGNORE
    doesn't work, that means the "send on behalf of" is not disabled
    I run accross hundred pages here, and I don't think I missed a step (enable headers_checks -> PCRE ok, so I wrote the rules -> reload of postfix)

    thanks for your help,
    Razique
    Last edited by Razique; 02-22-2010 at 12:07 PM.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    Any error messages in /var/log/zimbra.log ? you could try a
    Code:
    su - zimbra
    zmmtactl stop ; zmmtactl start

  3. #3
    Join Date
    Apr 2009
    Location
    France
    Posts
    9
    Rep Power
    6

    Default

    Hi uxbod, thanks
    Well everything runs smoothly in the logs
    After the restart via zmmtactl, headers now don't show the person who send the email, that's a good point. But now I still see :
    Code:
    Received: 	from 127.0.0.1  (EHLO webmail.society.com) (94.23.194.148) by mta1068.mail.sp2.yahoo.com with SMTP; Mon, 22 Feb 2010 11:12:51 -0800
    	Received: 	from localhost (localhost.localdomain [127.0.0.1]) by webmail.society.com (Postfix) with ESMTP id 9425511E4003 for <xxxxxxxxx@yahoo.fr>; Mon, 22 Feb 2010 20:12:02 +0100 (CET)
    	Received: 	from webmail.society.com ([127.0.0.1]) by localhost (webmail.popgom.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ubDAAroQ7eBb; Mon, 22 Feb 2010 20:12:01 +0100 (CET)
    and the "send on behalf of" it still enabled :/

    any clue ?
    thanks !

  4. #4
    Join Date
    Feb 2009
    Location
    Lecco, Italy
    Posts
    554
    Rep Power
    7

    Default

    hi.
    did you ever solve this?

    I edited conf/postfix_header_checs.in, added the "Sender" line, checked that conf/postfix_header_checs was correctly valued after mta restart, but yet when I send mail the Sender line is still present!
    YetOpen S.r.l. ~ Your open source partner
    Lecco (LC) - ITALY
    http://www.yetopen.it

  5. #5
    Join Date
    Dec 2010
    Location
    São Paulo/Brasil
    Posts
    4
    Rep Power
    5

    Default

    Try this:

    zmprov mcf zimbraMtaBlockedExtensionWarnRecipient FALSE (default: TRUE)

    then restart mta:

    zmmtactl restart

  6. #6
    Join Date
    Feb 2009
    Location
    Lecco, Italy
    Posts
    554
    Rep Power
    7

    Default

    Quote Originally Posted by fernando.cainelli View Post
    zmprov mcf zimbraMtaBlockedExtensionWarnRecipient FALSE (default: TRUE)
    indeed this is the fix, I found it as well some time ago
    thanks for posting!
    YetOpen S.r.l. ~ Your open source partner
    Lecco (LC) - ITALY
    http://www.yetopen.it

  7. #7
    Join Date
    Dec 2010
    Location
    São Paulo/Brasil
    Posts
    4
    Rep Power
    5

    Default

    I thought so.


  8. #8
    Join Date
    May 2009
    Posts
    59
    Rep Power
    6

    Default

    For the benefit of others. This is apparently a known problem and Zimbra's response is to live with it... a bug report was opened and then closed

    http://www.zimbra.com/forums/adminis...h-persona.html
    http://www.zimbra.com/forums/adminis...t-working.html
    Bug 52942 &ndash; enable use of Postfix header_checks in conjunction with Amavis banned attachment warnings

Similar Threads

  1. [SOLVED] Zimbra + postfix + mailman
    By sjsobol in forum Administrators
    Replies: 13
    Last Post: 01-13-2011, 09:34 PM
  2. [SOLVED] Postfix permissions
    By gallimore in forum Administrators
    Replies: 4
    Last Post: 08-10-2009, 06:22 AM
  3. [SOLVED] Internal Distribution List
    By vtx624 in forum Administrators
    Replies: 4
    Last Post: 05-18-2009, 12:53 PM
  4. [SOLVED] Distribution list
    By chandu in forum Administrators
    Replies: 16
    Last Post: 04-02-2009, 06:17 AM
  5. Replies: 2
    Last Post: 06-07-2007, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •