Results 1 to 8 of 8

Thread: :( Postfix header_checks doesn't work

Threaded View

  1. #1
    Join Date
    Apr 2009
    Location
    France
    Posts
    9
    Rep Power
    6

    Unhappy :( Postfix header_checks doesn't work

    Hi all,
    I recently finished the upgrade to the V6. Now here is the issue I have :
    the header_checks.in does not work. After the reload of postfix, I see my new lines into the header_checks file :

    Here is what I add :
    Code:
    /^Sender:.*/ IGNORE
    /^Received: from localhost.*/ IGNORE
    /^Received: from .+\..+\.webmail .+(by society\.com .+) / REPLACE Received: $1
    /^Received:.*\[127\.0\.0\.1/ IGNORE
    /^Return-Path:.*/ IGNORE
    /^X-Originating-IP.*/ IGNORE
    /^X-Mailer.*/ IGNORE
    #/^X-Virus-Scanned:.*/ IGNORE
    and well there is just one entry which works :

    before :

    Code:
    Received: 	from webmail.society.com (webmail.society.com ) by mx.google.com with ESMTP
    Received: 	from localhost (localhost.localdomain [127.0.0.1]) by webmail.society.com (Postfix) with ESMTP id 
    Received: 	from webmail.society.com ([127.0.0.1]) by localhost (webmail.society.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id PE8yvmtRoyYo; Mon, 22 Feb 2010 17:26:32 +0100 (CET)
    Received: 	from webmail.society.com (localhost.localdomain [127.0.0.1]) by webmail.society.com (Postfix) with ESMTP id

    After :

    Code:
    Received: 	from webmail.society.com (webmail.society.com ) by mx.google.com with ESMTP
    Received: 	from localhost (localhost.localdomain [127.0.0.1]) by webmail.society.com (Postfix) with ESMTP id 
    Received: 	from webmail.society.com ([127.0.0.1]) by localhost (webmail.popgom.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id PE8yvmtRoyYo; Mon, 22 Feb 2010 17:26:32 +0100 (CET)
    So just the last line is gone, I disabled through the gui the option which allows the header_cheks to work
    Well plus the line "X-Originating-IP."
    but I still see 'localhost', X-Virus-Scanned (I commented the line, but I didn't work, that's why

    And the most-annoying thing, the
    Code:
    /^Sender:.*/ IGNORE
    doesn't work, that means the "send on behalf of" is not disabled
    I run accross hundred pages here, and I don't think I missed a step (enable headers_checks -> PCRE ok, so I wrote the rules -> reload of postfix)

    thanks for your help,
    Razique
    Last edited by Razique; 02-22-2010 at 11:07 AM.

Similar Threads

  1. [SOLVED] Zimbra + postfix + mailman
    By sjsobol in forum Administrators
    Replies: 13
    Last Post: 01-13-2011, 08:34 PM
  2. [SOLVED] Postfix permissions
    By gallimore in forum Administrators
    Replies: 4
    Last Post: 08-10-2009, 05:22 AM
  3. [SOLVED] Internal Distribution List
    By vtx624 in forum Administrators
    Replies: 4
    Last Post: 05-18-2009, 11:53 AM
  4. [SOLVED] Distribution list
    By chandu in forum Administrators
    Replies: 16
    Last Post: 04-02-2009, 05:17 AM
  5. Replies: 2
    Last Post: 06-07-2007, 03:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •