Results 1 to 10 of 13

Thread: [SOLVED] Could not send message: mail.SEND_FAILURE...Invalid Addresses

Threaded View

  1. #1
    Join Date
    Dec 2007
    Location
    Stockton, CA
    Posts
    164
    Rep Power
    8

    Default [SOLVED] Could not send message: mail.SEND_FAILURE...Invalid Addresses

    Hey Everyone,

    We just upgraded from ZCS 5.0.18 to 6.0.5 last Thursday. Ever since then, some users periodically encounter problems sending mail to outside addresses. I cannot figure out a pattern on why this is happening. It happens when creating a new message and when replying. Users receive an error message indicating invalid addresses...but (especially when clicking reply) as far as I can tell there aren't any invalid addresses.

    Here is an example:

    Example 1:

    Code:
    Could not send message: mail.SEND_FAILURE
    method:	SendMsgRequest
    msg:	SMTP server reported: Invalid Addresses
    code:	mail.SEND_FAILURE
    detail:	soap:Sender
    trace:	btpool0-4370://mail.ourserver.org/service/soap/SendMsgRequest:1266885067376:058a757e7e76eb96
    request:	
    
    Body: {
      SendMsgRequest: {
        _jsns: "urn:zimbraMail",
        m: {
          e: [
            0: {
              a: "recipient@theirserver.org",
              p: "Suzanne Recipient",
              t: "t"
             },
            1: {
              a: "sender@ourserver.org",
              p: "Jim Sender",
              t: "f"
             }
           ],
          idnt: "357bc018-9664-4e3f-841d-ab8fabfa9a4d",
          irt: {
            _content: "<17018994.5290.1266884930686.JavaMail.root@cottontail>"
           },
          mp: [
            0: {
              content: {
                _content:
    
     Content removed for privacy...I don't think it's important anyway.
    
    "
               },
              ct: "text/plain"
             }
           ],
          su: {
            _content: "Re: Subject"
           }
         },
        suid: 1266885066892
       }
     },
    Header: {
      context: {
        _jsns: "urn:zimbra",
        account: {
          _content: "sender@ourserver.org",
          by: "name"
         },
        authToken: "(removed)",
        notify: {
          seq: 27
         },
        session: {
          _content: 18777,
          id: 18777
         },
        userAgent: {
          name: "ZimbraWebClient - FF3.0 (Mac)",
          version: "6.0.5_GA_2213.DEBIAN4.0"
         }
       }
     }
    We've NEVER had this problem before, and it's happening with e-mail addresses that people have successfully been e-mailing for a long while. In some cases, if a user tries multiple times (closes e-mail, deletes draft, re-replies or re-creates e-mail), they're successful...but most of the time they are not.

    I worked with a user having this problem and couldn't find any logical reason why it was happening. Nothing stuck out as a possible reason why Zimbra was having trouble. Most of the time it wouldn't work, sometimes it would. The user who was encountering this problem could send/recieve e-mail from many other outside e-mail addresses just fine.

    The weirdest thing is that, in some cases, a user will have trouble replying to a message sent to them by the affected address, but they can compose a new message and there is a 50/50 change it'll work. Vice versa as well.

    I should mention that the upgrade also involved moving to LVM and expanding storage for Zimbra, so I had to copy Zimbra from one partition to another. I used "cp --archive" could this be an issue? Is there a way to verify all ownerships and permissions are correct?

    Where do I start to troubleshoot this?! Any help would be GREATLY appreciated!
    Last edited by thunder04; 02-22-2010 at 06:42 PM.

Similar Threads

  1. Replies: 0
    Last Post: 08-23-2009, 04:10 PM
  2. Replies: 2
    Last Post: 06-18-2008, 07:54 AM
  3. Send Message as Distribution List
    By akirsch in forum Administrators
    Replies: 3
    Last Post: 01-18-2007, 11:45 AM
  4. Send error on Firefox/FC3
    By rodrigoccurvo in forum Users
    Replies: 12
    Last Post: 10-22-2005, 12:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •