I'm using Zimbra OS (Release 5.0.10_GA_2638.RHEL5_20081003052615 CentOS5 FOSS edition)

I have succesfully setup smtp authentication and enable TLS authentication only.
However, if I setup a Outlook Express not to use SMTP authentication, I can still send mails through the MTA.
It appears authentication only works when I set the option.
This overrides the point of authentication, don't you think?

Let's say a user disables the authentication option, then they'd be able to send mail anonymously.

I have even removed the subnet from the mtatrustednetworks list but no show.

How do I FORCE all smtp traffic to be authenticated?