Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: ZCS Backup Report: FAIL, (No such file or directory)

  1. #11
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    You should run a disk check (fsck) on the machine.

  2. #12
    Join Date
    Sep 2007
    Posts
    24
    Rep Power
    8

    Default

    I ran this yesterday
    /opt/zimbra/libexec/zmfixperms --verbose --extended

    and that completed fine as far as I could see. Backup ran last night and was successful which is weird.

    The thing is, the permissions havent changed for months and months, so god knows..

    I will monitor over the next few days and report back.

    iway, why run fsck though, to find out what?

  3. #13
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    To find out if you have file system errors on disk.

  4. #14
    Join Date
    Sep 2007
    Posts
    24
    Rep Power
    8

    Default

    Ok, bit of a report back.

    Since running that command: /opt/zimbra/libexec/zmfixperms --verbose --extended

    the last 3 backups have successful..

    im a bit confused now because its either 1) fixed itself, 2) that command fixed it, but then, if changing permissions fixed it, nothing permission wise had changed for months...

    I'm happy the issue seems to be resolved, but concerned if it happens again.

  5. #15
    Join Date
    Nov 2007
    Location
    Santa Barbara, CA.
    Posts
    109
    Rep Power
    7

    Thumbs up

    Wow great explanation bdial - even though I'm not having these errors on our cluster, I think this post has incredible value. Great Job!

    --
    Jesster


    Quote Originally Posted by bdial View Post
    You need to first understand the basics of how zimbra's mailboxes are stored.

    Actual messages are stored in /opt/zimbra/store organized by mailboxid under the 0 directory (0 for people with only one message store). These are the raw emails often referred to as the blobs.

    Information about each blob is stored in a sql database for eahc mailbox. It stores information like size, subject, date sent and date received, and snippets. basically everything you see in your preview pane in zimbra is stored as metadata for hte message in the sql database. so what zmblobchk does is compares what is in the database for a message versus what is on the disk. so these errors mean



    the size of the e-mail in the database is different than what is on the disk



    theres is an entry for an e-mail in the database, but there is no corresponding blob on the mail store. basically you would see this e-mail in your preview pane but when you clicked on it you would get an error b ecause zimbra wouldn't be able to find teh e-mail to display to you



    There is a blob on the disk that has no metadata entry in the database. E-mails like this wouldn't even show up in the web interface

    Usually this kind of thing may happen when you have a disk failure and some data gets lost or something. like the first zmblobchk you had reported



    But I don't see that in the second zmblobchk you posted. Now its unlikely that file would suddenly re-appear.

    I would be hesitant to try to manually fix some of this stuff by editing the database or removing blobs because of the inconsistant nature of it. This might be a good time to talk to support

    Some good reading on teh subjects:

    Ajcody-Notes-No-Such-Blob - Zimbra :: Wiki
    Account mailbox database structure - Zimbra :: Wiki

  6. #16
    Join Date
    Sep 2007
    Posts
    24
    Rep Power
    8

    Default

    Even more confused now:

    Backup on Fri: Success

    Backup on Sat: Failed

    Backup on Sun: Success

    Logs below:

    FRI

    Label: full-20100305.213654.756
    Type: full
    Status: completed
    Started: Fri, 2010/03/05 21:36:54.756 GMT
    Ended: Sat, 2010/03/06 01:55:21.896 GMT
    Redo log sequence range: 17441 .. 17441
    Number of accounts: 28

    SAT

    Label: full-20100306.213649.563
    Type: full
    Status: completed (with errors)
    Started: Sat, 2010/03/06 21:36:49.563 GMT
    Ended: Sun, 2010/03/07 01:56:01.729 GMT
    Redo log sequence range: 17443 .. 17443
    Number of accounts: 28
    Number of errors: 1


    ERRORS

    anewdifferentaccountthatsneverfailed...urdoma in.com: /opt/zimbra/store/0/31/msg/38/156571-199681.msg (No such file or directory)
    java.io.FileNotFoundException: /opt/zimbra/store/0/31/msg/38/156571-199681.msg (No such file or directory)
    at java.io.FileInputStream.open(Native Method)
    at java.io.FileInputStream.<init>(FileInputStream.jav a:106)
    at com.zimbra.common.util.FileUtil.copyOIO(FileUtil.j ava:188)
    at com.zimbra.common.util.FileUtil.copyOIO(FileUtil.j ava:181)
    at com.zimbra.common.io.AsyncFileCopier$WorkerThread. copy(AsyncFileCopier.java:149)
    at com.zimbra.common.io.AsyncFileCopier$WorkerThread. run(AsyncFileCopier.java:116)



    SUN

    Label: full-20100307.213421.987
    Type: full
    Status: completed
    Started: Sun, 2010/03/07 21:34:21.987 GMT
    Ended: Mon, 2010/03/08 01:53:05.032 GMT
    Redo log sequence range: 17443 .. 17443
    Number of accounts: 28


    I could understand if it failed every single day, but to be succesful one day, fail the next, and be fine the day after, im a bit confused.

    That command wont fix things im sure as nothing has changed and it failed again. Is there anything I can be checking for exactly.

    I want to try and fix this myself if possible, or find as much info as I can before I goto support.

    Thanks for the help

  7. #17
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    Well, once again, we had similar errors before. A file system check resolved the issue.
    You should try it!

Similar Threads

  1. Mail is being queued, not delivered!
    By icepick94 in forum Administrators
    Replies: 12
    Last Post: 01-22-2009, 06:03 AM
  2. ZCS, Windows Active directory and Multiple-servers
    By tuhintt in forum Installation
    Replies: 0
    Last Post: 12-19-2008, 08:30 AM
  3. error on zmldapinit
    By DenisBY in forum Installation
    Replies: 5
    Last Post: 07-30-2008, 11:50 AM
  4. initializing ldap fail Fedora core 7
    By tita in forum Installation
    Replies: 11
    Last Post: 12-09-2007, 11:06 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •