Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: 3 testing: LDAP: 389 Failed when restore zimbra

  1. #1
    Join Date
    Jun 2006
    Posts
    28
    Rep Power
    9

    Default 3 testing: LDAP: 389 Failed when restore zimbra

    I have searched the fourms, but can not find the best solution.

    My Machine
    Operating System: Fedora Core 4
    Zimbra Version: 3.1.2 for FC4

    I have two machines, and the settings are the same.
    A PC: for testing
    B PC: for using

    Two backup files
    A files: Backup from A PC.
    B files: Backup from B PC.

    My first testing on A PC:
    1. Uninstall the zimbra
    2. Install a clean zimbra
    3. Stop zimbra and kill all related process and reboot
    4. Check the process and kill(include slapd)
    5. Remove the /opt/zimbra
    6. Copy the backup zimbra folder(A files) to /opt
    7. Run the install script "./install.sh"
    8. When restore the zimbra, the error appears.
    Code:
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    Operations logged to /tmp/zmsetup.log.9702
    Setting defaults...Setting defaults from existing config...Done
    Checking for port conflicts
    Starting ldap...Done
    Setting defaults from ldap...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    Done
    Checking ldap on localhost:389...FAILED ( ldap_bind: Invalid credentials (49) )
    Checking ldap on localhost:389...FAILED ( ldap_bind: Invalid credentials (49) )
    
    Main menu
    
       1) Hostname:                                mydomain                   
       2) Ldap master host:                        mydomain                   
       3) Ldap port:                               389                           
       4) Ldap password:                           set                           
       5) zimbra-ldap:                             Enabled                       
       6) zimbra-store:                            Enabled                       
            +Create Admin User:                    no                            
            +SMTP host:                            mydomain                   
    ******* +Web server HTTP port:                 UNSET                         
    ******* +Web server HTTPS port:                UNSET                         
            +Web server mode:                      mixed                         
            +Enable POP/IMAP proxy:                no                            
            +IMAP server port:                     143                           
            +IMAP server SSL port:                 993                           
            +POP server port:                      110                           
            +POP server SSL port:                  995                           
            +Use spell check server:               yes                           
            +Spell server URL:                     http://mydomain:7780/aspell.php
    
       7) zimbra-mta:                              Enabled                       
       8) zimbra-snmp:                             Enabled                       
       9) zimbra-logger:                           Enabled                       
      10) zimbra-spell:                            Enabled                       
       r) Start servers after configuration        yes                           
       s) Save config to file                                                    
       x) Expand menu                                                            
       q) Quit                                    
    
    Address unconfigured (**) items or correct ldap configuration  (? - help)
    zmsetup.log
    Code:
    Started slapd: pid 10101
    slapd already running: pid 10101
    ldap_bind: Invalid credentials (49)
    ldap_bind: Invalid credentials (49)
    ldap_bind: Invalid credentials (49)
    ls: /opt/zimbra/lib/conf/*ldif: No such file or directory
    After that, I pressed "Ctrl+C" to stop the installation. Then I run the install script again.
    Code:
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    Operations logged to /tmp/zmsetup.log.18008
    Setting defaults...Setting defaults from existing config...Done
    Checking for port conflicts
    Starting ldap...Done
    Setting defaults from ldap...Done
    Checking ldap on localhost:389...Success
    Checking ldap on localhost:389...Success
    Saving config in /opt/zimbra/config.18008...Done
    Operations logged to /tmp/zmsetup.log.18008
    Setting local config values...Done
    Creating SSL certificate...Done
    Starting ldap...Done
    Saving CA in ldap...Done
    Installing SSL certificate...Done
    Creating server entry for mydomain...Done
    Setting spell check URL...Done
    Setting service ports on mydomain...Done
    Adding mydomain to zimbraMailHostPool in default COS...Done
    Installing zimlets... com_zimbra_ymaps... com_zimbra_xslt... com_zimbra_url... com_zimbra_amzn... com_zimbra_wikipedia... com_zimbra_tracking... com_zimbra_phone... Done
    Setting MTA auth host...Done
    Initializing mta config...Done
    Configuring SNMP...Done
    Setting services on mydomain...Done
    Setting up zimbra crontab...Done
    
    You have the option of notifying Zimbra of your installation.
    This helps us to track the uptake of the Zimbra Collaboration Suite.
    The only information that will be transmitted is:
            The VERSION of zcs installed (3.1.2_GA_445_FC4)
            The ADMIN EMAIL ADDRESS created (admin@mydomain)
    
    Notify Zimbra of your installation? [Yes] N
    Notification skipped
    Starting servers...
    Done.
    
    
    Operations logged to /tmp/zmsetup.log.18008
    
    
    Configuration complete - press return to exit
    The installation is successfully. (Checking ldap on localhost:389...Success)However, when I check the zimbra status, the other error appears.
    Code:
    [zimbra@mail zcs_3.1.2]$ zmcontrol status
    Host mydomain
            antispam                Running
            antivirus               Stopped
                    zmclamdctl is not running
            ldap                    Running
            logger                  Stopped
                    logmysql.server is not running
                    zmlogswatchctl is not running
            mailbox                 Stopped
                    mysql.server is not running
                    tomcat is not running
            mta                     Running
            snmp                    Running
            spell                   Running
    Some posts in fourms said that the slapd.conf have problems. However, I test on other way.

    My second testing on A PC:
    1. Uninstall the zimbra
    2. Install a clean zimbra
    3. Stop zimbra and kill all related process and reboot
    4. Check the process and kill(include slapd)
    5. Remove the /opt/zimbra
    6. Copy the backup zimbra folder(B files) to /opt
    7. Run the install script "./install.sh"
    8. No errors and installation is successfully.

    No errors on this testing. I don't really understand what problem on it.

    My third testing on A PC:
    1. Uninstall the zimbra
    2. Install a clean zimbra
    3. Stop zimbra and kill all related process and reboot
    4. Check the process and kill(include slapd)
    5. Run the install script "./install.sh"
    6. Error appears!
    Code:
    Checking for port conflicts
    Starting ldap...Done
    Setting defaults from ldap...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    Done
    Checking ldap on localhost:389...FAILED ( ldap_bind: Invalid credentials (49) )
    Checking ldap on localhost:389...FAILED ( ldap_bind: Invalid credentials (49) )
    
    Main menu
    
       1) Hostname:                                mydomain                   
       2) Ldap master host:                        mydomain                   
       3) Ldap port:                               389                           
       4) Ldap password:                           set                           
       5) zimbra-ldap:                             Enabled                       
       6) zimbra-store:                            Enabled                       
            +Create Admin User:                    no                            
            +SMTP host:                            mydomain                   
    ******* +Web server HTTP port:                 UNSET                         
    ******* +Web server HTTPS port:                UNSET                         
            +Web server mode:                      mixed                         
            +Enable POP/IMAP proxy:                no                            
            +IMAP server port:                     143                           
            +IMAP server SSL port:                 993                           
            +POP server port:                      110                           
            +POP server SSL port:                  995                           
            +Use spell check server:               yes                           
            +Spell server URL:                     http://mydomain:7780/aspell.php
    
       7) zimbra-mta:                              Enabled                       
       8) zimbra-snmp:                             Enabled                       
       9) zimbra-logger:                           Enabled                       
      10) zimbra-spell:                            Enabled                       
       r) Start servers after configuration        yes                           
       s) Save config to file                                                    
       x) Expand menu                                                            
       q) Quit                                    
    
    Address unconfigured (**) items or correct ldap configuration  (? - help)
    New Version 3.1.4 have the same result.

    Anyone have idea on those of problems?
    Last edited by victorLeong; 07-25-2006 at 09:50 PM.

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    I've had the exact same problem. Odds are, your LDAP Password is either an old version, or it didn't update it right.

    Your problem is with : the save config file.

    Try this, when you get the options menu, set the LDAP password to what you remember it to be.

  3. #3
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Quote Originally Posted by wannabetenor
    I've had the exact same problem. Odds are, your LDAP Password is either an old version, or it didn't update it right.

    Your problem is with : the save config file.

    Try this, when you get the options menu, set the LDAP password to what you remember it to be.
    And rest the HTTP port to what ever you want and the ssl is likely 443

  4. #4
    Join Date
    Jun 2006
    Posts
    28
    Rep Power
    9

    Default

    Quote Originally Posted by wannabetenor
    I've had the exact same problem. Odds are, your LDAP Password is either an old version, or it didn't update it right.

    Your problem is with : the save config file.

    Try this, when you get the options menu, set the LDAP password to what you remember it to be.
    I have tried to set the password and set the port of http and https. But it can not continue to install.

    Code:
    Select, or 'r' for previous menu [r] r
    Checking ldap on localhost:389...FAILED ( ldap_bind: Invalid credentials (49) )
    Checking ldap on localhost:389...FAILED ( ldap_bind: Invalid credentials (49) )
    
    Main menu
    
       1) Hostname:                                mydomain                   
       2) Ldap master host:                        mydomain                   
       3) Ldap port:                               389                           
       4) Ldap password:                           set                           
       5) zimbra-ldap:                             Enabled                       
       6) zimbra-store:                            Enabled                       
       7) zimbra-mta:                              Enabled                       
       8) zimbra-snmp:                             Enabled                       
       9) zimbra-logger:                           Enabled                       
      10) zimbra-spell:                            Enabled                       
       r) Start servers after configuration        yes                           
       s) Save config to file                                                    
       x) Expand menu                                                            
       q) Quit                                    
    
    Address unconfigured (**) items or correct ldap configuration  (? - help)
    It said that I need to correct ldap configuration. Otherwise, can not continue to install zimbra. I have tried to change the LDAP port, but the error still appear. What should I do now?

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    You don't want to change the LDAP Port. It should be 389

    Can open another window and run zmlocalconfig -s ?

    And post the results? If you want you can message them to me, cause its going to display stuff you may not want on the board.

  6. #6
    Join Date
    Jun 2006
    Posts
    28
    Rep Power
    9

    Default

    Quote Originally Posted by wannabetenor
    You don't want to change the LDAP Port. It should be 389

    Can open another window and run zmlocalconfig -s ?

    And post the results? If you want you can message them to me, cause its going to display stuff you may not want on the board.
    Config removed.
    Last edited by jholder; 07-25-2006 at 11:27 PM.

  7. #7
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    I'm going to go ahead and remove your config, because I don't think it's good to leave it here.

    Run the following as zimbra user
    zmldappasswd --root newpasss
    zmldappasswd newpass2

    I assume you still have the install open, that's good. Keep it open when you run these. You should be at the menu.

    Then, once you've run those commands, then go to the menu, and set the LDAP Password.

    Just as an FYI: I think that if your LDAP is out of sync, your sql passwords are going to be out of sync too. . .so this is only the beginning.

    jh

  8. #8
    Join Date
    Jun 2006
    Posts
    28
    Rep Power
    9

    Default

    Quote Originally Posted by wannabetenor
    I'm going to go ahead and remove your config, because I don't think it's good to leave it here.

    Run the following as zimbra user
    zmldappasswd --root newpasss
    zmldappasswd newpass2

    I assume you still have the install open, that's good. Keep it open when you run these. You should be at the menu.

    Then, once you've run those commands, then go to the menu, and set the LDAP Password.

    Just as an FYI: I think that if your LDAP is out of sync, your sql passwords are going to be out of sync too. . .so this is only the beginning.

    jh
    It can continue to install now. Thanks you veru much.

    However, when the installation completed. The errors meet again

    Code:
    [zimbra@mail zcs_3.1.2]$ zmcontrol status
    Host mydomain
            antispam                Running
            antivirus               Running
            ldap                    Running
            logger                  Stopped
                    logmysql.server is not running
                    zmlogswatchctl is not running
            mailbox                 Stopped
                    mysql.server is not running
                    tomcat is not running
            mta                     Running
            snmp                    Running
            spell                   Running

  9. #9
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    I was right, your SQL Passwords are out of sync.
    Go to the wiki and look up that section. It has a good tutorial on how to fix that.

    Also, you're going to have some permissions issues as well. Run the zmfixperms script in the libexec dir. Also, you will need to run
    >chown zimbra:zimbra /opt/zimbra/store/*

    Hope this helps.

    john

  10. #10
    Join Date
    Jun 2006
    Posts
    28
    Rep Power
    9

    Default

    Quote Originally Posted by wannabetenor
    I was right, your SQL Passwords are out of sync.
    Go to the wiki and look up that section. It has a good tutorial on how to fix that.

    Also, you're going to have some permissions issues as well. Run the zmfixperms script in the libexec dir. Also, you will need to run
    >chown zimbra:zimbra /opt/zimbra/store/*

    Hope this helps.

    john
    Thanks you so much.

    However, I found the best solution.

    when I used tar command to backup the files and restore, no ldap failed.( I used cp command before, cp command can not copy some files. )
    Last edited by victorLeong; 07-26-2006 at 03:15 AM.

Similar Threads

  1. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  2. Replies: 7
    Last Post: 01-24-2007, 11:03 PM
  3. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 05:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •