Results 1 to 3 of 3

Thread: mysql will not start

  1. #1
    Join Date
    Oct 2008
    Rep Power

    Default mysql will not start

    I've been having a problem with mysql not starting on zimbra 4.5.10, i have followed many posts that have delt with this issue and i believe it is even worse then when i started.

    when i run zmmysqlstatus i get:

    Error while running 'mysql --user=zimbra --password="password" --database=zimbra --batch --skip-column-names'. at /opt/zimbra/bin/zmmysqlstatus line 241

    where "password" is a password that i have set following another post (sry there were so many i got lost)

    when i run "zmlocalconfig -s | grep mysql | grep password" the mysql_root_password is something that i know is wrong but i do not know the right password or even how to change it if i did

    sorry if that is not enough info but i am way over my head here, zimbra just worked with no problems for 2 years so i havent had to do much administration experience with it

  2. #2
    Join Date
    Oct 2008
    Rep Power


    i checked an older backup i had and I found what the mysql root password is supposed to be but I cannot change it back

    To change it in the first place i ran "zmlocalconfig -e zimbra_mysql_password='newpassword'

    When i try to run that again with the proper password i get the following:

    Error: can not edit key zimbra_mysql_password

    i found this post but it did not help

    Any ideas?

    The backup i have is about a week old, would it work if i restored everything but the store and database?? idk, grasping at straws
    Last edited by Kruger81; 03-10-2010 at 10:41 AM.

  3. #3
    Join Date
    Aug 2009
    The Hague -- The Netherlands
    Rep Power


    Instead of changing the mysql password in zimbra ldap, which apparently does not work, you could also try to change the mysql password in mysql to match the one in zimbra ldap.

Similar Threads

  1. Errors installing Outlook Connector
    By Tim G in forum Zimbra Connector for Outlook
    Replies: 57
    Last Post: 05-05-2011, 02:27 PM
  2. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. Mysql does not start on RHEL 64
    By cryptogram in forum Installation
    Replies: 11
    Last Post: 01-18-2007, 01:39 PM
  5. Can't start MySQL to init db - Gentoo
    By fak3r in forum Installation
    Replies: 3
    Last Post: 10-10-2005, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts