Results 1 to 9 of 9

Thread: Can Zimbra Modify email headers (FROM:)?

Hybrid View

  1. #1
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default Can Zimbra Modify email headers (FROM:)?

    Hi

    How can I modify the headers that Zimbra sends? Here is my setup:

    -have a machine that does not have a FQDN so its mailserv.company.local.
    -email comes via individual POP accounts at our ISP

    Problem is, mail headers show mail from mailserv.company.local, but I would like it to be mailserv.ourdomain.com. How can I do this? I have not been able to find answers by searching forum or google.

    Update: I tried domain masquerade as per this post but that doesn't change the from headers:
    http://www.zimbra.com/forums/install...querading.html

    Regards,
    Scott
    Last edited by strafford; 03-17-2010 at 09:26 AM. Reason: clarify subject

  2. #2
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default

    Do I have to rename the machine? If so, do I have to have a real/FQDN or can I use a bogus sub-domain (i.e. if our domain is company.com, can I use mail.company.com even though that is not registered/setup)?

  3. #3
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    What is your domain hosted on server mailserv.company.local or mailserv.company.com ?

  4. #4
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default

    Currently mailserv.company.local is the server and it does not have a domain, just an IP.
    Last edited by strafford; 03-17-2010 at 11:59 AM.

  5. #5
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    So u want to create domain with mailserv.company.com and users in it ? is this wat u are trying to achieve ?

  6. #6
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default

    I can setup a domain no problem. I can add users, etc. My problem is with the email headers. They still say mail.company.local no matter what I try (Canonical name, masquerade, etc.) and are getting rejected by spam filters, etc.

    See below for an example of what the headers would look like if we are using company.com (gmail accepts the mail so I am able to see the headers, but most others don't):

    Return-Path: <scott@company.com>
    Received: from mail.company.local (d72-38-21-199.commercial1.cgocable.net [72.38.21.199])
    by mx.google.com with ESMTP id 2si14534435qwi.51.2010.03.16.14.51.32;
    Tue, 16 Mar 2010 14:51:32 -0700 (PDT)
    Received-SPF: neutral (google.com: 72.38.21.199 is neither permitted nor denied by best guess record for domain of scott@company.com) client-ip=72.38.21.199;
    Authentication-Results: mx.google.com; spf=neutral (google.com: 72.38.21.199 is neither permitted nor denied by best guess record for domain of scott@company.com) smtp.mail=scott@company.com
    Received: from localhost (localhost [127.0.0.1])
    by mail.company.local (Postfix) with ESMTP id 51C9670367
    for <scott.trafford@gmail.com>; Tue, 16 Mar 2010 17:42:35 -0400 (EDT)
    X-Virus-Scanned: amavisd-new at mail.company.local
    Received: from mail.company.local ([127.0.0.1])
    by localhost (mail.company.local [127.0.0.1]) (amavisd-new, port 10024)
    with ESMTP id oDkuAuxVTph3; Tue, 16 Mar 2010 17:42:32 -0400 (EDT)
    Received: from mail.company.local (mail.company.local [192.168.7.108])
    by mail.company.local (Postfix) with ESMTP id E1CFF7027D;
    Tue, 16 Mar 2010 17:42:31 -0400 (EDT)

  7. #7
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    it's probably that your server is identifying itself to remote servers as mail.company.local when it says HELO

    try this

    zmprov mcf zimbraMtaMyHostname mail.company.com

    then restart the zimbra mta (or all of zimbra to be sure)

  8. #8
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default

    Ok, much closer. Still have some instances of mail.company.local. See below.


    Code:
    Received: from mail.company.com ([127.0.0.1])
    	by localhost (mail.company.local [127.0.0.1]) (amavisd-new, port 10024)
    	with ESMTP id ttCLbwr1kdiA; Thu, 18 Mar 2010 10:33:55 -0400 (EDT)
    Received: from mail.company.local (mail.company.local [192.168.7.108])
    	by mail.company.com (Postfix) with ESMTP id EDEEB70328;
    	Thu, 18 Mar 2010 10:33:54 -0400 (EDT)
    Last edited by strafford; 03-18-2010 at 08:52 AM.

  9. #9
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default

    Ok. So the headers look pretty good now after changing the mta hostname (Thanks bdial). But since my machine name is a bogus domain (mail.company.local) I can't send email from user to user (errors in logs about not finding domain even though mail.company.local is in my /etc/hosts file)

    Any ideas?

    Code:
     (Host or domain name not found. Name service error for name=mail.company.local type=A: Host not found)

Similar Threads

  1. [SOLVED] mailboxmanager does not start
    By jrefl5 in forum Administrators
    Replies: 18
    Last Post: 01-30-2012, 11:40 PM
  2. [SOLVED] Moving Zimbra to a new server
    By krolen in forum Administrators
    Replies: 109
    Last Post: 02-05-2009, 11:38 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  4. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 03:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •