Results 1 to 9 of 9

Thread: Error upgrading to 3.2.0_M2_224 from 3.1.3_GA_474 on FC4

Hybrid View

  1. #1
    Join Date
    Nov 2005
    Location
    Norway
    Posts
    11
    Rep Power
    9

    Default Error upgrading to 3.2.0_M2_224 from 3.1.3_GA_474 on FC4

    I get the following errors while running the upgrade:

    -------
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    chown: cannot access `/opt/zimbra/conf/perdition.pem': No such file or directory
    chown: cannot access `/opt/zimbra/conf/perdition.key': No such file or directory
    Operations logged to /tmp/zmsetup.log.4699
    Setting defaults...Setting defaults from existing config...Done
    Upgrading from 3.1.3_GA_474 to 3.2.0_M2_224
    Sun Jul 30 14:39:55 2006: Stopping zimbra services
    Sun Jul 30 14:40:09 2006: Checking mysql status
    Sun Jul 30 14:40:10 2006: Starting mysql
    Sun Jul 30 14:40:11 2006: SELECT value FROM config WHERE name = 'db.version'
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=72zPvbu.Dn02njHuDLU0OYLynEPH._C --database=zimbra --batch --skip-column-names'. at /opt/zimbra/libexec/scripts/Migrate.pm line 134.
    -------

    The upgrade stops after this error.
    Any suggestions to how I can fix this?

    Thanks
    Bjorn-Kare
    (I am not very experienced :-) )

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Try running the upgrade again and see if that works. Don't forget to take a backup of your /opt/zimbra directories before you try the upgrade.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Nov 2005
    Location
    Norway
    Posts
    11
    Rep Power
    9

    Default

    Thanks
    Running the install/upgrade made the upgrade finish.
    I have experienced this error with other upgrades, and a restart of the install/upgrade has solved it earlier also.
    Is it something that I should be "nervous" of?
    I would not like that in a future upgrade I would have at "total" crash because of something not going exactly as planed on earlier version upgrades.

    I do take backup of opt/zimbra before upgrading, it has saved me a couple times :-)

    Now I have problem logging in
    IE6 I get the error: AjxException.INVALID_PARAM
    Firefox 1.5.0.5: INVALID_PDU

    When trying to access on the admin console
    I get no logon page
    IE6: javascript error in line 2825 char460, "No exception caught"
    Firefox: just a blank page

    I have cleared the cache in both IE and Firefox


    in the zimbra.log I see some errors:

    ... ERROR [main] Versions - DB Version Mismatch: ours="25" from DB="21"
    ... FATAL [main] soap - Unable to start servlet
    javax.servlet.UnavailableException: Data version mismatch ......

    ... - Markin servlet AdminServlet unavailable
    ... - Servlet /service threw load() excepion
    javax.servlet.UnavailableException: Data version mismatch ......

    ... [http-443-Processor100] [] [SoapServlet] - Servlet SoapServlet is currantly unavailable
    ... [http-7071-Processor49] [] [AdminServlet] - Servlet AdminServlet is currantly unavailable


    How do I proceed?

    Thanks
    Bjorn-Kare
    (and ofcourse, I posted in the wrong forum :-( )
    Last edited by Flister; 07-30-2006 at 01:51 PM.

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Hi,
    Can you please post your /opt/zimbra/zimbra.log

    That might help.

  5. #5
    Join Date
    Nov 2005
    Location
    Norway
    Posts
    11
    Rep Power
    9

    Default

    Thanks
    Here is the log-file
    I replaced the domain-name with maildomain.com

    I am going to wait a day before rolling back using my backup

    Best regards
    Bjorn-Kare
    Attached Files Attached Files

  6. #6
    Join Date
    Nov 2005
    Location
    Norway
    Posts
    11
    Rep Power
    9

    Default

    OK
    I restored my 3.1.3 backup
    upgraded to 3.1.4 without errors
    made a new backup
    and I have now upgraded to 3.2.M2.224
    The upgrade seems to have been OK
    I can now log in as users, and to the admin console.

    I got one error during the upgrade:
    ----
    Checking 3.1.4_GA

    Mon Jul 31 22:35:36 2006: Updating from 3.1.4_GA
    ldap_bind: Can't contact LDAP server (-1)
    Checking 3.2.0_M1

    Mon Jul 31 22:35:38 2006: Updating from 3.2.0_M1
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    ERROR: wiki.ERROR (error: import) (cause: java.net.ConnectException Connection refused)
    Checking 3.2.0_M2

    Mon Jul 31 22:38:11 2006: Updating from 3.2.0_M2
    Mon Jul 31 22:38:30 2006: Stopping ldap
    Upgrade complete
    ----

    Do I have a problem with the LDAP?
    If I have a problem, can I fix it with a script, or should I roll back again?

    Thanks
    Bjorn-Kare

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •