Results 1 to 9 of 9

Thread: [SOLVED] Amavisd greeting problem

  1. #1
    Join Date
    Jun 2006
    Posts
    209
    Rep Power
    9

    Default [SOLVED] Amavisd greeting problem

    Hi,

    I loose my head with Zimbra, after restart it I got now this message on mail.log:

    ...status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while receiving the initial server greeting)
    A telnet on 127.0.0.1 10024 respond well :

    220 [127.0.0.1] ESMTP amavisd-new service ready
    I have a lot of mail waiting in the queue !

    What's wrong ???

    Sam.
    Release 6.0.7_GA_2473.DEBIAN5 DEBIAN5 FOSS edition.
    On Debian Vserver

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    You are having a few issues Samp Turn up the amavis logging by updating /opt/zimbra/conf/amavisd.conf.in and setting log_level=2 and the perform
    Code:
    su - zimbra
    zmmtactl stop ; zmmtactl start
    Fire a message through and lets take a look at the logs under /var/log/zimbra.log. Also check the freshclam logs under /opt/zimbra/log to ensure that you do not have a corrupt definition.

  3. #3
    Join Date
    Jun 2006
    Posts
    209
    Rep Power
    9

    Default

    So, after several minutes the services work and the queue was flushed...

    Very special.
    Release 6.0.7_GA_2473.DEBIAN5 DEBIAN5 FOSS edition.
    On Debian Vserver

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Are you making changes to the system while live ? You appear to have made a number of posts recently.

  5. #5
    Join Date
    Jun 2006
    Posts
    209
    Rep Power
    9

    Default

    Quote Originally Posted by uxbod View Post
    You are having a few issues Samp Turn up the amavis logging by updating /opt/zimbra/conf/amavisd.conf.in and setting log_level=2 and the perform
    Code:
    su - zimbra
    zmmtactl stop ; zmmtactl start
    Fire a message through and lets take a look at the logs under /var/log/zimbra.log. Also check the freshclam logs under /opt/zimbra/log to ensure that you do not have a corrupt definition.
    Ok I do that modify the amavisd.conf, restart zmmtactl, and check the zimbra log everything seems ok and amavisd work as before... But the main.conf back to smtpd_reject_unlisted_recipient = no AGAIN !

    Thanks again for you help perhaps this night I will sleep more than 3 hours.

    Sam.
    Release 6.0.7_GA_2473.DEBIAN5 DEBIAN5 FOSS edition.
    On Debian Vserver

  6. #6
    Join Date
    Jun 2006
    Posts
    209
    Rep Power
    9

    Default

    Quote Originally Posted by uxbod View Post
    Are you making changes to the system while live ? You appear to have made a number of posts recently.
    I changed the $mynetwork variable in Postfix main.cf from the admin console, add rbl lists from the console too and the smtpd_reject_unlisted_recipient=yes a lot of time !

    The only working solution I found is to modify the main.cf by hand and make a /opt/zimbra/postfix/sbin/postfix reload as root user to just reload the config NOT all postfix setup.

    I can't leave my Zimbra in this stat let me know to force definitevely the smtpd_reject_unlisted_recipient = yes

    Sam.
    Release 6.0.7_GA_2473.DEBIAN5 DEBIAN5 FOSS edition.
    On Debian Vserver

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Samp View Post
    I can't leave my Zimbra in this stat let me know to force definitevely the smtpd_reject_unlisted_recipient = yes
    The correct place to modify that setting is in the file mentioned here: Improving Anti-spam system - Zimbra :: Wiki
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Apr 2010
    Location
    Coimbatore. INDIA
    Posts
    14
    Rep Power
    5

    Default

    Quote Originally Posted by uxbod View Post
    You are having a few issues Samp Turn up the amavis logging by updating /opt/zimbra/conf/amavisd.conf.in and setting log_level=2 and the perform
    Code:
    su - zimbra
    zmmtactl stop ; zmmtactl start
    Fire a message through and lets take a look at the logs under /var/log/zimbra.log. Also check the freshclam logs under /opt/zimbra/log to ensure that you do not have a corrupt definition.
    hi...

    i am also facing the same problem. In that amavisd.conf.in file has log_level=1 and log_level=5 in two places. where we need to modify it. pls guide me.

    thanks in advance
    - Venugopal R

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by venugopalr View Post
    i am also facing the same problem.
    A description of your problem would be better than a 'me too' post.

    Quote Originally Posted by venugopalr View Post
    In that amavisd.conf.in file has log_level=1 and log_level=5 in two places. where we need to modify it.
    There should only be one entry containing "log_level=1", if there's more than that then someone has modified that file.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 05:32 PM
  2. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  3. Backup problem
    By polaco999 in forum Installation
    Replies: 1
    Last Post: 11-26-2007, 12:13 PM
  4. smtp table lookup problem
    By s_c_johnson in forum Installation
    Replies: 5
    Last Post: 09-21-2007, 06:46 AM
  5. [SOLVED] Small problem stopping zimbra
    By jml75 in forum Administrators
    Replies: 13
    Last Post: 07-13-2006, 09:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •