Results 1 to 10 of 14

Thread: [SOLVED] mysql innodb corrupt, innodb_force_recovery 6 won't work

Threaded View

  1. #1
    Join Date
    Dec 2009
    Posts
    14
    Rep Power
    5

    Default [SOLVED] mysql innodb corrupt, innodb_force_recovery 6 won't work

    Hi,

    this morning our ZCS server discovered not work, after few reviewing I discover the problem is mysql unable to start. with some test I and google I realize is a db corrupt but not so much info I can find on how to recover in this unlucky situation, what I've been already tried:

    1. I stop the whole zcs, only su zimbra and test mysql.server start, it won't work
    2. I read the log/mysql_error.log realize the problem is some inconsistency in log and innodb start to recovery but failed at error: "Page directory corruption: supremum not pointed to"
    3. I read the zimbra mysql recovery guide, but even I set innodb_force_recovery = 6 I do not have any luck to start mysql.server start with user zimbra

    my ZCS is version zcs-6.0.0_GA_1802.RHEL5.20090830140212.
    in CentOS in a VM, was running perfect.

    so what I have to do next?
    Last edited by wolvesled; 03-22-2010 at 03:16 AM.

Similar Threads

  1. Corrupt database
    By menno.pieters in forum Administrators
    Replies: 2
    Last Post: 02-02-2009, 05:01 AM
  2. [SOLVED] MySQL not starting
    By Deeeep in forum Administrators
    Replies: 2
    Last Post: 11-30-2008, 12:23 PM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. Replies: 7
    Last Post: 02-27-2008, 04:17 PM
  5. Upgrade 4.5.1 -> 4.5.2 Network Edition on RH Failed
    By CJ.deb in forum Installation
    Replies: 7
    Last Post: 03-01-2007, 06:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •