Results 1 to 7 of 7

Thread: [SOLVED] zmdbintegrityreport reports missing tables

  1. #1
    Join Date
    Feb 2008
    Posts
    22
    Rep Power
    7

    Default [SOLVED] zmdbintegrityreport reports missing tables

    zmdbintegrityreport is giving the attached output. Basically it is complaining that some tables in the mboxgroup2, 3, and 4 databases do not exist. There are directories in /opt/zimbra/db/data named mboxgroup[2,3,4] but the files within have not changed in a very long time (since original installation?).

    I am about to upgrade from 5.1.6 to 5.0.22. Is there anything I can do to correct this error as part of my upgrade process?

    --
    patrick

    ZCS 5.0.16, RHEL5
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Okay; something is not quite right there. Please try the following
    Code:
    su - zimbra
    mysql
    use zimbra;
    select group_id, comment from mailbox where group_id = '2';
    The comment field should show which account is having issues; therefore the account it returns is that still a valid account ? Please do the same for 3 and 4.

  3. #3
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Oops I missed the most important bit!
    Code:
    error    : Corrupt
    Sounds like your database requires a bit of TLC. To start with try the following
    Code:
    su - zimbra
    mysql
    use mboxgroup2;
    repair table appointment;
    check table appointment;
    If that comes back as Okay then let us know and we can then repair all your tables

  4. #4
    Join Date
    Feb 2008
    Posts
    22
    Rep Power
    7

    Default

    Thanks for the quick reply. I am in the middle of full backups right now. I will check it out as soon as I can bring the server back up.

  5. #5
    Join Date
    Feb 2008
    Posts
    22
    Rep Power
    7

    Default

    I can list the tables and it shows appointment being there but repair and check both fail.


    mysql> use mboxgroup2;
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A

    Database changed
    mysql> repair table appointment;
    +------------------------+--------+----------+----------------------------------------------+
    | Table | Op | Msg_type | Msg_text |
    +------------------------+--------+----------+----------------------------------------------+
    | mboxgroup2.appointment | repair | Error | Table 'mboxgroup2.appointment' doesn't exist |
    | mboxgroup2.appointment | repair | error | Corrupt |
    +------------------------+--------+----------+----------------------------------------------+
    2 rows in set (0.00 sec)

    mysql> check table appointment;
    +------------------------+-------+----------+----------------------------------------------+
    | Table | Op | Msg_type | Msg_text |
    +------------------------+-------+----------+----------------------------------------------+
    | mboxgroup2.appointment | check | Error | Table 'mboxgroup2.appointment' doesn't exist |
    | mboxgroup2.appointment | check | error | Corrupt |
    +------------------------+-------+----------+----------------------------------------------+
    2 rows in set (0.00 sec)

    mysql> show tables in mboxgroup2;
    +----------------------+
    | Tables_in_mboxgroup2 |
    +----------------------+
    | appointment |
    | data_source_item |
    | imap_folder |
    | imap_message |
    | mail_item |
    | open_conversation |
    | pop3_message |
    | revision |
    | tombstone |
    +----------------------+
    9 rows in set (0.00 sec)

    mysql>

  6. #6
    Join Date
    Mar 2009
    Posts
    11
    Rep Power
    6

    Default

    Same same, encountering same issue. Any advise yet?

  7. #7
    Join Date
    Feb 2008
    Posts
    22
    Rep Power
    7

    Default

    This issue was resolved with help from Zimbra tech support. Unfortunately since my mail server was down I used gmail for our support conversation and gmail has already expired the conversation. I do remember that the solution was to stop the mysql server and then physically remove the database files for the corrupt tables. Apparently Zimbra will re-create them as necessary.

Similar Threads

  1. [SOLVED] upgrading to latest 4.5 release
    By ak2009 in forum Installation
    Replies: 6
    Last Post: 01-17-2009, 09:08 AM
  2. Help! Upgrade problems from 5.09 to 5.10
    By gtr33m in forum Installation
    Replies: 17
    Last Post: 11-13-2008, 04:20 AM
  3. Zimbra OSS 4.5.11 Re-install
    By newmember in forum Installation
    Replies: 0
    Last Post: 09-09-2008, 11:26 PM
  4. 4.5.11 to 5.06 Migration Suggestion
    By newmember in forum Migration
    Replies: 15
    Last Post: 09-02-2008, 07:59 PM
  5. Traslation SVN tree status
    By meikka in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 02-13-2007, 11:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •