Results 1 to 6 of 6

Thread: Special characters in command line

  1. #1
    Join Date
    Nov 2009
    Posts
    21
    Rep Power
    6

    Default Special characters in command line

    Hi,
    I need to use special characters using zimbra commands
    for example: zmprov ma test@example.com displayName āēŗ
    Is it possible to do that? Because now it displays in unrecognisable characters.

    I use ZCS 6 on ubuntu linux.
    thnx

  2. #2
    Join Date
    Jan 2008
    Location
    Berlin, Germany
    Posts
    203
    Rep Power
    7

    Default

    This issue is caused by LC environment Settings in .bash_profile in /opt/zimbra.

    Code:
    export LANG=C
    will not work as expected since this most likely does not match with your systems settings in /etc/default/locale. If you change this value in /opt/zimbra/.bash_profile to

    export LANG=en_US.ISO-8859-1

    or whatever your System setting is (mostly UTF8 these days), all
    is working fine on the command line too.

    Regards

    Andreas

  3. #3
    Join Date
    Nov 2009
    Posts
    21
    Rep Power
    6

    Default

    I have UTF-8 in /etc/default/locale.
    When i set UTF-8 in /opt/zimbra/.bash_profile then it works fine when i write in console but whe i execute zmprov command then doesn't work special symbols.
    I tryed command: zmprov ma test@example.com sn ēēēāāā.
    After this command in web interface there are not these symbols. But if i change them in web admin site then it works fine.
    Problem is that i have over 100 users to change settings where are special symbols like ēāī.
    I tryed load from file these names but same problem.

  4. #4
    Join Date
    Jan 2008
    Location
    Berlin, Germany
    Posts
    203
    Rep Power
    7

    Default

    you may try to quote the names e.g.

    Code:
    zmprov ma test@example.com displayName 'āēŗ'

  5. #5
    Join Date
    Nov 2009
    Posts
    21
    Rep Power
    6

    Default

    Still nothing.
    I tryed "āēŗ" and 'āēŗ'

    Interesting than from root user i can use special symbol commands. But zimbra commands doesn't work from root user.

  6. #6
    Join Date
    Feb 2014
    Posts
    7
    Rep Power
    1

    Default

    Hi,

    If someone still intrested in a solution, you have to set LC_ALL=en_US.UTF-8 and not only LANG, see Zimbra 8 ? provisioning accounts with non English characters using zmprov | ParanoidPenguin.net

    Best Regards,
    Patrick

Similar Threads

  1. zmprov ca and special characters
    By twickle in forum Administrators
    Replies: 1
    Last Post: 08-26-2014, 06:41 AM
  2. Using Special Characters in Zimbra Mail Filters
    By sena@kei.com in forum Users
    Replies: 2
    Last Post: 08-26-2009, 08:33 AM
  3. Beta 6 RC1 - special characters solved?
    By xander2k in forum Installation
    Replies: 4
    Last Post: 07-29-2009, 04:48 PM
  4. User password with special characters reset themselves?
    By easytouch in forum Administrators
    Replies: 0
    Last Post: 08-16-2007, 07:09 AM
  5. Spellchecker special characters support
    By Abak in forum Developers
    Replies: 3
    Last Post: 03-31-2006, 09:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •