Results 1 to 6 of 6

Thread: zmaccts don't work under root

  1. #1
    Join Date
    Apr 2010
    Posts
    19
    Rep Power
    5

    Default zmaccts don't work under root

    zmaccts don't work under root, it says:
    ldap_start_tls: Connect error (-11)
    additional info: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed (unable to get local issuer certificate)
    ldap_result: Can't contact LDAP server (-1)
    What can I do? zmaccts hasn't any arguments.

  2. #2
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Have you tried running this tool as the zimbra user? Most commands staring with "zm" are designed to run as zimbra, not root.

  3. #3
    Join Date
    Nov 2008
    Posts
    46
    Rep Power
    7

    Default

    Hi Dirk,

    Even i want to run zmaccts from root user and giving same error message. Yes from zimbra user, its working fine. But we need to provide one read only dashboard to users to show mailbox status. and for that we need to run zmaccts command from root....
    is there any way ??

  4. #4
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    What about using su?

    As root:
    Code:
    su - zimbra -c "zmaccts"

  5. #5
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    I was going to suggest
    Code:
    sudo -u zimbra /opt/zimbra/bin/zmaccts
    but that does not work. I tried Klug's suggestion though and that does work, so go with that one

  6. #6
    Join Date
    Nov 2008
    Posts
    46
    Rep Power
    7

    Default

    hey that worked..thanks a lot

Similar Threads

  1. Replies: 658
    Last Post: 04-04-2014, 10:01 AM
  2. Fine tunning on 2 GB RAM with no swap
    By adrian15 in forum Installation
    Replies: 8
    Last Post: 05-29-2010, 02:24 AM
  3. ZCS 6.0.2 Admin Interface Missing Features and/or Broken
    By Guenther983 in forum Installation
    Replies: 7
    Last Post: 02-23-2010, 05:46 PM
  4. [SOLVED] Error Installing Zimbra on RHEL 5
    By harris7139 in forum Installation
    Replies: 10
    Last Post: 09-25-2007, 12:39 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 05:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •