Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: How to disable X-Mailer and X-Virus-Scanned

  1. #11
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by frankman View Post
    Along with removing "X-Mailer" and "X-Virus-Scanned", how do we remove "X-Originating-IP" as well?
    Read the Admin Guide or go to the Admin UI and disable the option.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #12
    Join Date
    Apr 2008
    Posts
    69
    Rep Power
    7

    Default

    Bill, Thanks for the super quick reply! Found how to remove the originating IP in the Admin Guide and UI.

    But can't find unsetting the X-Mailer in the Guide and UI. Running `zmlocalconfig | grep -i mailer` as zimbra doesn't return anything either.

    Did some digging and found that X-Mailer is added to Zimbra emails from version 5.0.5 by default and can be disabled by setting zimbraSmtpSendAddMailer to FALSE in global config. Bug 6237

    What's the command to set it to false?
    Last edited by frankman; 10-23-2011 at 11:42 AM. Reason: Found partial answer to question. Still need a little help.

  3. #13
    Join Date
    Apr 2008
    Posts
    69
    Rep Power
    7

    Default

    ccelis5215, I think in your case, Outlook is adding the X-mailer.

    In my case, the Zimbra webmail client in the browser is adding the X-Mailer. I need the command syntax for setting zimbraSmtpSendAddMailer to false, so the X-Mailer header doesn't get added. What is that syntax?

  4. #14
    Join Date
    Jun 2011
    Location
    Caracas Venezuela
    Posts
    476
    Rep Power
    4

    Default

    Exactly, i delete my post after read the phoenix response, going to take a break and then continue searching.

    Thanks all!

  5. #15
    Join Date
    Jun 2011
    Location
    Caracas Venezuela
    Posts
    476
    Rep Power
    4

    Default

    Zimbra Administrator's Guide

    10 Managing ZCS Configuration > Global MTA Settings

    Messages
    Set the Maximum messages size for a message and it’s attachments that can be sent. Note: To set the maximum size of an uploaded file to Briefcase, go to the General Information tab.

    You can enable the X-Originating-IP header to messages checkbox. The X-Originating-IP header information specifies the original sending IP of the email message the server is forwarding.

    Just uncheck the mark, save and after that there's no local IP in sent messages!

    Regards.
    Last edited by ccelis5215; 10-23-2011 at 05:03 PM.

  6. #16
    Join Date
    Apr 2008
    Posts
    69
    Rep Power
    7

    Default

    That eliminates the X-Originating-IP header, but the X-Mailer header is still there.

  7. #17
    Join Date
    Jun 2011
    Location
    Caracas Venezuela
    Posts
    476
    Rep Power
    4

    Default

    barth and uxbod posted modifications in amavisd how-to in this thread.

    uxbod mentioned about X-Mailer.....

  8. #18
    Join Date
    Jun 2011
    Location
    Caracas Venezuela
    Posts
    476
    Rep Power
    4

    Default

    To disable X-Mailer.

    Run as Zimbra user:

    zmprov mcf zimbraSmtpSendAddMailer "FALSE";


  9. #19
    Join Date
    Apr 2008
    Posts
    69
    Rep Power
    7

    Default

    Thanks you! That worked.

Similar Threads

  1. Replies: 29
    Last Post: 10-08-2009, 03:07 PM
  2. [SOLVED] help please zmamavisdctl is not running
    By cornbread in forum Administrators
    Replies: 4
    Last Post: 11-21-2007, 12:13 PM
  3. [SOLVED] Unable to receive email 4.5.6:
    By cornbread in forum Installation
    Replies: 8
    Last Post: 09-29-2007, 12:51 PM
  4. Migration from postfix mailer to zimbra
    By ash in forum Administrators
    Replies: 2
    Last Post: 03-06-2007, 12:54 AM
  5. Can't send or receive mails from Zimbra
    By ppurama in forum Administrators
    Replies: 4
    Last Post: 11-14-2005, 10:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •