Results 1 to 3 of 3

Thread: [SOLVED] Help! I broke it.

  1. #1
    Join Date
    Apr 2010
    Posts
    2
    Rep Power
    5

    Default [SOLVED] Help! I broke it.

    running: zcs open source edition 6.06 on Debian 4.

    Hi. Today I was trying to add a transport table as described on: Transport Table for external servers - Zimbra :: Wiki
    When I ran zmlocalconfig|grep... I noticed that the existing value used ${zimbra_home} instead of /opt/zimbra. I decided to be fancy and tried to do the same but when I checked the result it had been replaced by nothing. (presumably by my shell) So, I escaped the $ and { } with backslashes, and got this:
    Exception in thread "main" java.lang.ExceptionInInitializerError
    at com.zimbra.common.localconfig.Main.main(Main.java: 106)
    Caused by: java.lang.RuntimeException: com.zimbra.common.localconfig.ConfigException: recursive expansion of key 'zimbra_home': postfix_transport_maps zimbra_home

    NOW, any attempt to run zmlocalconfig returns that or something similar. Mail seems to still be running but I'm unable to reconfigure that value back to something sane. HELP! What can I do?

    Thanks.

  2. #2
    Join Date
    Apr 2010
    Posts
    2
    Rep Power
    5

    Default

    Fixed. Discovered that the configuration is simply in an XML file in /opt/zimbra/conf/localconfig.xml. (here I was expecting something gawdawful like the windows registry) Edited it by hand, and it is all good again. Which makes me wonder... why would anyone use the clumsy "zmlocalconfig" command? Editing a text file just seems so much simpler.

  3. #3
    Join Date
    Dec 2010
    Location
    Besancon
    Posts
    1
    Rep Power
    5

    Default

    Thank you very much for the explaination, i was scary because i thought i was the only one to do that before i google my probleme.
    Thank you again, you saved me lot of time.

Similar Threads

  1. upgrade broke server :Unable to connect to the MTA
    By esb123 in forum Administrators
    Replies: 14
    Last Post: 05-02-2012, 01:20 PM
  2. GoDaddy SSL broke my keystore
    By ryandball in forum Administrators
    Replies: 12
    Last Post: 06-17-2008, 08:52 AM
  3. I broke it? ;D (5.0RC1)
    By jadestorm in forum Users
    Replies: 3
    Last Post: 10-12-2007, 07:20 AM
  4. I broke IMAP authentication
    By sjobeck in forum Administrators
    Replies: 2
    Last Post: 09-14-2007, 03:40 AM
  5. Upgrade to 3.0.1_GA_160 broke
    By jwilso2 in forum Installation
    Replies: 2
    Last Post: 02-24-2006, 09:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •