Results 1 to 5 of 5

Thread: [SOLVED] 5.0.2 32-bit -> 6.0.6 64-bit - zmmailboxdctl is not running - I've tried

Threaded View

  1. #1
    Join Date
    May 2010
    Location
    NY, USA
    Posts
    7
    Rep Power
    5

    Default [SOLVED] 5.0.2 32-bit -> 6.0.6 64-bit - zmmailboxdctl is not running - I've tried

    EDIT: I've gotten further since this was posted. You can probably just skip down to post #2 for the current situation. Thanks!

    Hi All,

    I've been banging my head against this one for about 4 hours now, and figured I'd ask for help.

    My goal is to migrate a 5.0.2 32-bit ZCS Open Source Edition instance to 6.0.6 64-bit. I have been largely successful to this point (I believe), and the actual upgrade process went smoothly.

    I've read countless threads on this issue, and can't seem to find the one that solves the problem for me. So many threads both on zimbra.com and other places that I can't cite them all here.

    The problem is that the ZCS services start without error, but:

    zimbra@zimbra01 [~]# zmcontrol status
    Host zimbra01.mail02.codecrunchers.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    zmmailboxdctl is not running.
    mta Running
    snmp Running
    spell Running
    stats Running
    I was getting this error in logs/zmmailboxd.out when it was trying to bind the port for IMAP SSL:

    java.net.SocketException: Unbound server sockets not implemented
    I read that's usually associated with a commercial SSL cert, however I am not attempting to use one. I'm good with just self-signed for this machine.

    I tried following the directions here ..

    Recreating a Self-Signed SSL Certificate in ZCS 4.5 & 5.0 - Zimbra :: Wiki

    .. using the 5.0+ commands.

    I would always get the error Keystore was tampered with, or password was incorrect, however now I'm getting additional exceptions after messing with the certs:

    zimbra@zimbra01 [~/log]# zmlocalconfig -s -m nokey mailboxd_keystore_password
    T1JWHAMGG6
    zimbra@zimbra01 [~/log]# keytool -delete -alias jetty -keystore /opt/zimbra/mailboxd/etc/keystore -storepass T1JWHAMGG6
    CompilerOracle: exclude com/zimbra/cs/session/SessionMap.putAndPrune
    CompilerOracle: exclude com/zimbra/cs/mailbox/MailItem.delete
    CompilerOracle: exclude org/apache/xerces/impl/XMLDocumentFragmentScannerImpl$FragmentContentDisp atcher.dispatch
    keytool error: java.io.IOException: Keystore was tampered with, or password was incorrect
    I believe my solution overall is to just re-deploy a new self-signed cert, but if the keystore is fubar'd then I feel a bit stuck.

    I can't find much on this subject specific to 6.0.*, so I've been following 5.0.* directions for the most part.

    Can someone give me a nudge in the right direction, please?
    Last edited by ScottRose; 05-06-2010 at 09:46 AM.

Similar Threads

  1. [SOLVED] mailboxmanager does not start
    By jrefl5 in forum Administrators
    Replies: 18
    Last Post: 01-30-2012, 11:40 PM
  2. Replies: 5
    Last Post: 01-14-2010, 01:34 PM
  3. zmmailboxdctl is not running
    By smaring in forum Administrators
    Replies: 7
    Last Post: 10-23-2009, 04:38 AM
  4. [SOLVED] Outlook no longer updating
    By jeremy.pratt in forum Zimbra Connector for BlackBerry
    Replies: 10
    Last Post: 05-30-2008, 04:22 PM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •