Results 1 to 2 of 2

Thread: [SOLVED] mailbox indexing convertd failure

  1. #1
    Join Date
    Jan 2008
    Ashland, Oregon
    Rep Power

    Default [SOLVED] mailbox indexing convertd failure

    Release 6.0.5_GA_2213.RHEL5_20100202211341 FC6 NETWORK edition.
    Did an update some months back from a 5.x version.

    Got a report from a user today saying that searches on their mailbox did not work properly, so tried reindexing mailbox:

    [zimbra@zimbra log]$ zmprov rim user@mydomain start
    status: started
    [zimbra@zimbra log]$ zmprov rim user@mydomain status
    status: running
    progress: numSucceeded=0, numFailed=0, numRemaining=0
    [zimbra@zimbra log]$ zmprov rim user@mydomain status
    ERROR: service.NOT_IN_PROGRESS (mbox 1b0ff884-60d6-47e3-b8e8-89a3707be6a6 is not currently running action ReIndex)


    looking through mailbox.log gets this:
    com.zimbra.cs.mime.MimeHandlerException: extraction failed
    at com.zimbra.cs.mime.handler.ConverterHandler.getCon tentImpl(
    at com.zimbra.cs.mime.MimeHandler.getContent(MimeHand
    at com.zimbra.cs.mime.ParsedMessage.analyzePart(Parse
    at com.zimbra.cs.mime.ParsedMessage.analyzeNonBodyPar ts(
    at com.zimbra.cs.mime.ParsedMessage.analyzeFully(Pars
    at com.zimbra.cs.mailbox.Message.generateIndexData(Me
    at com.zimbra.cs.mailbox.IndexHelper.indexItemList(In
    at com.zimbra.cs.mailbox.IndexHelper.indexDeferredIte msInternal(
    at com.zimbra.cs.mailbox.IndexHelper.indexDeferredIte ms(
    at com.zimbra.cs.mailbox.IndexHelper.access$500(Index
    at com.zimbra.cs.mailbox.IndexHelper$ReIndexTask.reIn dex(
    at com.zimbra.cs.mailbox.IndexHelper$
    at com.zimbra.common.util.ThreadPool$
    at java.util.concurrent.ThreadPoolExecutor$ Task(
    at java.util.concurrent.ThreadPoolExecutor$ (
    Caused by: com.zimbra.cs.convert.ConversionException: connect failed
    ... 16 more
    Caused by: Connection refused
    at Method)
    at .java:333)
    at ava:182)
    at ava:366)
    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknow n Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
    at java.lang.reflect.Method.invoke(
    at org.apache.commons.httpclient.protocol.ReflectionS ocketFactory.createSocket(ReflectionSocketFactory. java:139)
    at org.apache.commons.httpclient.protocol.DefaultProt ocolSocketFactory.createSocket(DefaultProtocolSock
    at org.apache.commons.httpclient.MultiThreadedHttpCon nectionManager$
    at org.apache.commons.httpclient.HttpMethodDirector.e xecuteWithRetry(
    at org.apache.commons.httpclient.HttpMethodDirector.e xecuteMethod(
    at org.apache.commons.httpclient.HttpClient.executeMe thod(
    at org.apache.commons.httpclient.HttpClient.executeMe thod(
    at com.zimbra.cs.convert.ConverterClient.extract(Conv
    at com.zimbra.cs.mime.handler.ConverterHandler.getCon tentImpl(
    ... 15 more

    So, following other posts regarding upgrades to 6.0.5, I undeployed convertd, and redeployed convertd.

    [zimbra@zimbra log]$ zmconvertctl start
    Starting convertd...failed.

    Reindexing does not work on ANY of my mailboxes.

    ???? /thanks

  2. #2
    Join Date
    Jan 2008
    Ashland, Oregon
    Rep Power


    Resolved... For some reason... was not installed on this system.. and needed to be for convertd.
    yum install compat-libstdc++-33.i386
    allowed convertd to start. Still had to reindex mailbox twice for it to finish sucessfully, but it worked. Web interface for reindex is a fail as does not show any progress, and the command line as well shows no progress. The mailbox.log however shows:
    2010-05-19 08:39:20,081 INFO [ReIndex-1] [name=user@mydomain;mid=66;] mailbox - Re-Indexing: Mailbox 66 COMPLETED in 236762ms


Similar Threads

  1. system failure: fetching folder data for mailbox
    By tanke67 in forum Administrators
    Replies: 6
    Last Post: 08-18-2010, 08:18 AM
  2. Clients stopped receiving emails
    By egadinc in forum Administrators
    Replies: 16
    Last Post: 12-14-2009, 02:38 PM
  3. convertd still active; attachment indexing off
    By brianfinley in forum Administrators
    Replies: 0
    Last Post: 04-17-2009, 09:54 PM
  4. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 05:53 PM
  5. The *ULTIMATE* 451 / convertd problem thread!
    By Leesbian in forum Administrators
    Replies: 13
    Last Post: 10-31-2007, 01:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts