Results 1 to 4 of 4

Thread: Unable to read logger Stats

  1. #1
    Join Date
    May 2010
    Location
    Cape Town; South Africa
    Posts
    102
    Rep Power
    5

    Question Unable to read logger Stats

    Good day everyboday.
    First of all, please excuse my question, but I am very new in zimbra. I am busy testing the server in a test environmbet and for the purpose of the excersize I set it up on a SUSE11.2(64) box and am running the Zimbra free (6.n) release.

    Everything is running quite smoovely, but for:
    1. Documents (via the internally and via the internet).
    2. Mail attachments (also via internet and internally)
    3. Statistics (via the internet and internally)

    The problem seem to be related to SOAP (and possibly the SQL database the Zimbra suite is suppose to access for reporting)

    When trying to get the statistics using the Administration console I get:
    Server error encountered

    Message: system failure: Unable to read logger stats Error code:
    service.FAILURE Method: GetLoggerStatRequest Details:soap:Receiver


    I have installed MYSQL (and it is running), but when opening the databases, I see no database was created, but for the standard databases shipped with MYSQL.

    Something else is that I CAN get to the documents and attachments using ZIMBRA DESKTOP on the LAN.

    Cheers and I hope you guys can help me
    Aubrey Kloppers
    South Africa

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Welcome to the forums

    Zimbra ships with its own MySQL install and databases. With respect to statistics they are now stored in RRD files; and not in the MySQL database.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by cyber7 View Post
    First of all, please excuse my question, but I am very new in zimbra. I am busy testing the server in a test environmbet and for the purpose of the excersize I set it up on a SUSE11.2(64) box and am running the Zimbra free (6.n) release.
    I'm sure you realise this but only SLES is a supported platform not openSUSE (if that's what you're using.

    Quote Originally Posted by cyber7 View Post
    When trying to get the statistics using the Administration console I get:
    Server error encountered

    Message: system failure: Unable to read logger stats Error code:
    service.FAILURE Method: GetLoggerStatRequest Details:soap:Receiver
    Have you tried some of the fixes and debugging tips in the forums and Zimbra :: Wiki. ARe all the Zimbra services actually running? What's the output of the following command:

    Code:
    zmcontrol -v
    Quote Originally Posted by cyber7 View Post
    I have installed MYSQL (and it is running), but when opening the databases, I see no database was created, but for the standard databases shipped with MYSQL.
    I don't quite understand your point here, you don't need to install any additional MySQL - Zimbra is a complete package and all the required components are installed when you run the ./install.sh script.

    I'll also change the title of this thread as your current one doesn't actually reflect your post details.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    May 2010
    Location
    Cape Town; South Africa
    Posts
    102
    Rep Power
    5

    Default

    "zmcontrol -v" give me an output of:

    Release 6.0.5_GA_2213.SLES11_64_20100202233758 openSUSEUNKNOWN_64 FOSS edition.

    "zmlocalconfig -s | grep -i mysql | grep -i logger" gives me an output of:
    logger_mysql_bind_address = localhost
    logger_mysql_data_directory = ${zimbra_home}/logger/db/data
    logger_mysql_directory = ${zimbra_home}/logger/mysql
    logger_mysql_errlogfile = ${zimbra_home}/log/logger_mysql_error.log
    logger_mysql_mycnf = ${zimbra_home}/conf/my.logger.cnf
    logger_mysql_pidfile = ${zimbra_home}/logger/db/mysql.pid
    logger_mysql_port = 7307
    logger_mysql_socket = ${zimbra_home}/logger/db/mysql.sock
    zimbra_logger_mysql_password = zimbra


    "zmcontrol status" gives me an output of:
    antispam Running
    antivirus Running
    imapproxy Running
    ldap Running
    logger Running
    mailbox Running
    memcached Running
    mta Running
    snmp Running
    spell Running
    stats Running


    Regarding the support of "openSUSE", is this because of limitations on the server? What is the best platform to move to if so?

    If I may add: It is JUST the soap connection that seems to be the problem. I also have to add that doing a:
    "mysql --socket=/opt/zimbra/logger/db/mysql.sock -p" and logging in with the password, I get a:
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/logger/db/mysql.sock' (2)

    Thank you for the prompt reply
    Aubrey

Similar Threads

  1. bayes db..
    By osiris in forum Administrators
    Replies: 9
    Last Post: 06-15-2011, 11:14 AM
  2. [SOLVED] Unable to read logger status
    By Ready4Cool in forum Administrators
    Replies: 2
    Last Post: 01-28-2010, 10:38 PM
  3. Zimbra NE 6.0.4: Unable to read logger stats
    By Mark_vstep in forum Installation
    Replies: 2
    Last Post: 01-18-2010, 01:01 AM
  4. speed up the net
    By mcesari in forum Administrators
    Replies: 10
    Last Post: 04-25-2008, 11:24 AM
  5. Tomcat broken after upgrade to 4
    By dotslashroot in forum Migration
    Replies: 13
    Last Post: 01-31-2007, 05:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •