Results 1 to 3 of 3

Thread: Can't set zimbraMtaAuthURL

  1. #1
    Join Date
    Aug 2006
    Posts
    5
    Rep Power
    9

    Default Can't set zimbraMtaAuthURL

    I am having SMTP authentication issues in Thunderbird. I have TLS auth set in the Outgoing Mail Server on my client but still seem to have issues when sending from an external client. Sending via the web interface is working fine.

    Looking at the following command output:

    [zimbra@mail etc]$ zmprov gs mail.mydomain.com | grep Auth
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: mail.mydomain.com
    zimbraMtaAuthURL: http://mail.mydomain.com:80/service/soap/
    zimbraMtaTlsAuthOnly: TRUE

    I see that the zimbraMtaAuthURL is wrong (I think) since I have changed the default port for http auth requests to 8080 and not 80.

    I also have the mixed mode attribute set:

    [zimbra@mail etc]$ zmprov gs mail.mydomain.com | grep Mode
    zimbraMailMode: mixed

    The only place I have seen that references zimbraMtaAuthURL is in saslauthd.conf. But it seems to merely reference the attribute and not be setting the attribute.

    Is there a cli command to change this zimbraMtaAuthURL?

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    Common problem, caused by a bug. The URL is derived from the zimbraMtaAuthHost, and that host's zimbraMailPort - when you update the host, the url updates, but updating the port doesn't update the url.

    Go ahead and reset the host to it's current value
    zmprov ms `zmhostname` zimbraMtaAuthHost whatever
    and that should fix the URL
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Aug 2006
    Posts
    5
    Rep Power
    9

    Default

    By "whatever" I thought you meant the url + port so I did this:

    [zimbra@mail etc]$ zmprov ms mail.mydomain.com zimbraMtaAuthHost mail.mydomain.com:8080

    And got this.....

    ERROR: service.INVALID_REQUEST (invalid request: specified zimbraMtaAuthHost does not correspond to a valid service hostname: mail.mydomain.com:8080)

    So then I simply retyped what was already there without the port number:

    [zimbra@mail etc]$ zmprov ms mail.mydomain.com zimbraMtaAuthHost mail.mydomain.com

    And can now see the proper settings loaded

    [zimbra@mail etc]$ zmprov gs mail.mydomain.com | grep Auth
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: mail.mydomain.com
    zimbraMtaAuthURL: https://mail.mydomain.com:8443/service/soap/
    zimbraMtaTlsAuthOnly: TRUE

    Thanks for info on properly setting zimbraMtaAuthURL.

Similar Threads

  1. FQ Hostname Not Set
    By swu in forum Installation
    Replies: 30
    Last Post: 09-22-2011, 11:21 AM
  2. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 04:21 PM
  3. One domain set up in two different locations
    By sunshineknox in forum Administrators
    Replies: 1
    Last Post: 04-04-2007, 08:13 PM
  4. How to set From: header in web client?
    By ComputerX in forum Users
    Replies: 1
    Last Post: 01-30-2007, 02:14 PM
  5. Set user with Send and Receive rights on all accounts
    By CatiaL in forum Administrators
    Replies: 2
    Last Post: 12-04-2006, 09:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •