Results 1 to 2 of 2

Thread: patch - Wrong platform + version?

  1. #1
    Join Date
    Apr 2008
    Rep Power

    Exclamation patch - Wrong platform + version?

    Quick Background:
    I was on CentOS 5.4 + ZCS 6.0.6. FOSS version. I've applied the patch.

    Would applying the ZCS patch to ZCS 6.0.6 FOSS version (not Network version) on CentOS 5.x be ok? Any negative impact on my FOSS install?

    Before patching, my ZCS version was:
    "Version 6.0.6_GA_2324.RHEL5_64.FOSS Apr 6, 2010."

    After patching, it says:
    "Version 6.0.6_GA_2332.RHEL4.NETWORK May 6, 2010"

    It looks like I'm on:
    1. Redhat/CentOS 4 (It's 5)
    2. Redhat/CentOS 32-bit (It's 64-bit)
    3. Zimbra Network version (I'm on the FOSS version)

    Detailed Background:

    I downloaded the patch from the announcement link:
    I grabbed the patch from that link, which is the link below:

    I thought it would be ok to apply, because the file name, zcs-patch-6.0.6_GA_2332.tgz, didn't include the OS platform like the install tarballs do, the announcement didn't indicate the OS platform and said, "and was just built on an RHEL machine."

    So I applied the patch. I got one error, but the rest of the output showed that the patch applied successfully:
    could not find ParserDetails.ini in /usr/lib/perl5/vendor_perl/5.8.8/XML/SAX
    Current Version: 6.0.6_GA_2324
    Found Patch for 6.0.6_GA called 6.0.6_P1
    Deploying patch for 6.0.6_GA
    Updating files for package zimbra-store
    /opt/zimbra/jetty/webapps/service/WEB-INF/lib/zimbrastore.jar... copied.
    /opt/zimbra/jetty/webapps/zimbra/WEB-INF/lib/zimbrastore.jar... copied.
    /opt/zimbra/jetty/webapps/zimbraAdmin/WEB-INF/lib/zimbrastore.jar... copied.
    /opt/zimbra/lib/jars/zimbrastore.jar... copied.
    /opt/zimbra/jetty/common/lib/zimbracommon.jar... copied.
    /opt/zimbra/lib/jars/zimbracommon.jar... copied.
    /opt/zimbra/lib/ext/zimbrasync/zsynccommon.jar... copied.
    I ran the following command to get rid of the error per several links searched:
    perl -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::PurePerl))->save_parsers()"
    When I ran the patch again, I'd get:
    # ./ 
    Current Version: 6.0.6_GA_2332
     Current install 6.0.6_GA is the same or newer then patch version.
    Before patching, the version was (in the web admin->Help Desk->About Zimbra Version):
    Version 6.0.6_GA_2324.RHEL5_64.FOSS Apr 6, 2010.
    After patching, it says:
    Version 6.0.6_GA_2332.RHEL4.NETWORK May 6, 2010
    zmcontrol shows that I'm still on the old version.
    $ zmcontrol -v
    Release 6.0.6_GA_2324.RHEL5_64_20100406150533 CentOS5_64 FOSS edition.
    The fact that the GUI reports an incorrect OS version, 32/64 bit version and Zimbra version got me worried. Otherwise, a quick look from the webmail client, it looks ok so far.

    I just want confirm that:
    1. The incorrect version reported in the admin GUI doesn't affect current functionality or create licensing problems.
    2. The incorrect version reported in the admin GUi won't affect upgrading to 6.0.7 or higher FOSS in the future.

  2. #2
    Join Date
    Oct 2009
    Dublin, IRELAND
    Rep Power


    I read in another thread on here that the reason for the confused "branding" on the patch is that it was built on that platform. If I can find it in the next 10 mins or so - I will add a link. It's in the Announcements forum - MMorse -

    However, the actual content of the patch is all either java or javascript - thus has no dependency on the platform whatsoever.

    So - it was felt that it was unnecessary to build multiple different versions of the patch just to change the build version reported.

Similar Threads

  1. [SOLVED] Open Source version complains about license
    By tokbox-ben in forum Installation
    Replies: 2
    Last Post: 07-15-2008, 09:16 AM
    By in forum Installation
    Replies: 4
    Last Post: 06-11-2008, 09:52 AM
  3. Redhat file version wrong
    By matthijsberg in forum Installation
    Replies: 8
    Last Post: 04-25-2006, 12:00 AM
  4. Wrong icons in GA Zimbra web client
    By iain in forum Users
    Replies: 2
    Last Post: 02-13-2006, 02:13 AM
  5. Wrong Postfix Version - Post GA Upgrade
    By crichell in forum Installation
    Replies: 5
    Last Post: 02-08-2006, 09:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts