Results 1 to 7 of 7

Thread: Migrating from 6.0.6 to 6.0.7 ... but errors appear ..

  1. #1
    Join Date
    Nov 2007
    Location
    Brazil
    Posts
    42
    Rep Power
    8

    Thumbs down Migrating from 6.0.6 to 6.0.7 ... but errors appear ..

    Hello, i try to update my zimbra 6.0.6 to 6.0.7 version, but in the end of the migration its give me some errors :

    Code:
    This appears to be 6.0.6_GA
    Checking ldap status...not running.
    Running zmldapapplyldif...failed.
    Checking ldap status...already running.
    Stopping mysql...done.
    Updating from 6.0.7_GA
    Updating global config and COS's with attributes introduced after 6.0.6_GA...done.
    Stopping ldap...done.
    Upgrade complete.
    
    Running bdb db_recover...done.
    Running zmldapapplyldif...failed.
    Checking ldap status....already running.
    Setting defaults...done.
    Setting defaults from existing config...done.
    Checking for port conflicts
    Setting defaults from ldap...done.
    dualvar is only available with the XS version of Scalar::Util at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 38
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 38.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 1005.
    And now, all my messages are bounced :

    Code:
    Jun 16 14:16:05 marechal postfix/error[13643]: 6FAFA35AAA89: to=<dil@saude.al.gov.br>, relay=none, delay=12, delays=12/0/0/0.01, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending RCPT TO)
    I'm using Centos 5.5 64 bits and Zimbra 64 bits version too.

    If anyone can help me i will be gratefull. Thanks.

  2. #2
    Join Date
    Jun 2010
    Location
    India
    Posts
    82
    Rep Power
    5

    Unhappy Same error

    I get the very same error while trying to upgrade to zimbra 6.0.7 NE from 6.0.5 on a 32 bit centos machine. Any ideas guys? you've been a big help , hopefully on this too.

    strikermdd, did you figure something out on this issue? Please get back.

    Let me know if you guys need any further information, I would love to take part in a discussion.

  3. #3
    Join Date
    Jun 2010
    Location
    India
    Posts
    82
    Rep Power
    5

    Red face Sorry for the fuss

    Hi!

    The error i faced was almost like that but further checking the logs i could see a port conflict, the test server had sendmail running on port 25 which was the issue. Anyways thanks a lot and my suggestion to those going for fresh installation is to make sure required ports are occupied. If there are any, make sure you quit them before installing. Bye for now!

  4. #4
    Join Date
    Jun 2010
    Location
    India
    Posts
    82
    Rep Power
    5

    Unhappy Cleared port conflict error but

    Hi,

    I cleared the port conflict, but this time the same error without port conflict The very same error as my friend above. Can anyone lend a helping hand? Any idea what could have caused it?
    The line 1005 in /opt/zimbra/zimbramon/lib/Net/LDAP.pm says
    -----------------------
    sub start_tls {
    my $ldap = shift;
    my $arg = &_options;
    my $sock = $ldap->socket;

    require IO::Socket::SSL;
    require Net::LDAP::Extension;
    my $mesg = $ldap->message('Net::LDAP::Extension' => $arg);

    return _error($ldap, $mesg, LDAP_OPERATIONS_ERROR, "TLS already started")
    if $sock->isa('IO::Socket::SSL');

    return _error($ldap, $mesg, LDAP_PARAM_ERROR, "StartTLS requires LDAPv3")
    if $ldap->version < 3;

    $mesg->encode(
    extendedReq => {
    requestName => LDAP_EXTENSION_START_TLS,
    }
    );
    ----------------
    The /tmp/zmsetup.07132010-122106.log says installation was stopped at a check on LDAP. Please let us know if any more details are required. Any ideas?

  5. #5
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    Have you checked your certs? Still valid?

  6. #6
    Join Date
    Jun 2010
    Location
    India
    Posts
    82
    Rep Power
    5

    Smile Hi iway

    Hi,

    Thanks iway for getting back. My certs are still valid. Have almost an year left.

    I appreciate your concern, let me know if you need any more details.

  7. #7
    Join Date
    Jun 2010
    Location
    India
    Posts
    82
    Rep Power
    5

    Lightbulb hmm

    Hi,

    Thought I would work on this a bit.

    HTML Code:
    dualvar is only available with the XS version of Scalar::Util at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 38
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 38.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 1005.
    Scalar::Util holds a set of perl subroutines and dualvar is one of 'em. Now this dualvar is required to proceed with the installation and that too .. with the expected version of Scalar::Util by zimbra installation script. The version on the test server was conflicting.
    This is what I found on line 38 of /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm

    HTML Code:
    # non-XS Versions of Scalar::Util will fail
    BEGIN{
            eval { use Scalar::Util 'dualvar'; dualvar(0,'') };
    That says it ..

    I will have to start again after setting the right version and see how it goes. Will keep this post updated.

Similar Threads

  1. Replies: 6
    Last Post: 06-21-2010, 01:46 AM
  2. How can i upgrade from zimbra 6.0.6 to 6.0.7?
    By taxiarxos in forum Installation
    Replies: 6
    Last Post: 06-16-2010, 11:17 AM
  3. Errors migrating Groupwise accounts
    By misleb in forum Migration
    Replies: 1
    Last Post: 03-25-2008, 11:46 AM
  4. Errors Migrating from Exchange 5.5
    By Scotsman in forum Migration
    Replies: 2
    Last Post: 03-07-2007, 02:24 AM
  5. Replies: 5
    Last Post: 02-06-2007, 11:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •