Results 1 to 5 of 5

Thread: Process saslauthd consuming 100% of CPU.

  1. #1
    Join Date
    Oct 2005
    Posts
    38
    Rep Power
    10

    Unhappy Process saslauthd consuming 100% of CPU.

    Hi, I'm getting this behaviour from the MTA server using open source edition 3.1.4 and the users cannot send messages.

    Sometimes stopping/restarting with zmsaslauthdctl solves the problem but sometimes I need to reboot the server.

    The process appears like 3 or 4 times in the display from the 'top' command.

    The server is an HPBlade with dual opteron processors and 6GB or RAM.


  2. #2
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    next time this happens, can you please pstack the offending process ids? Would be interesting to see what these processes are so busy doing.

    Do the pstack a few times. That would give us an idea of what sequence of functions are being called.

    You could also use gdb and attach and do a "where" if you'd like.

    When you have the stack traces, please open a bug in bugzilla also.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Oct 2005
    Posts
    38
    Rep Power
    10

    Question

    sorry for my ignorance but what do you mean by pstack and gdb ?

    are those linux commands ?
    Could you please tell me how to use them ?

    thanks for your help.

  4. #4
    Join Date
    Dec 2005
    Posts
    18
    Rep Power
    10

    Default

    Here's a man page on pstack:

    http://www.linuxcommand.org/man_pages/pstack1.html

    Also, look here at a similar bug: http://bugzilla.zimbra.com/show_bug.cgi?id=11381 ... I'm not sure if that is the same problem that you are experiencing.

  5. #5
    Join Date
    Oct 2006
    Posts
    5
    Rep Power
    9

    Default

    I've been running saslauthd (and openssh and other apps that use encryption and random numbers) in different email project that wasnt using zimbra (just postfix installation that i've setup myself) and *if i remember correctly* saslauthd draining cpu was caused by its requirement to use /dev/random .. This device file generates its random data gathered from entropy happening in the machine (keypresses/mouse movements and such). In server machines that do not have mouse/keyboards even attached, reading of the /dev/random is sometimes blocking and using all available cpu as there is random data available..

    To fix this without recompling or reconfiguring saslauthd, remove or move /dev/random to a new name and use mknod to create new version with mknod that machines the same major/minor number pair as /dev/urandom ..

    *note*

    This ofcourse is a tradeoff in security and in same cases this is not an option. however, many cases using /dev/urandom instead of /dev/random is "secure enough" ..

Similar Threads

  1. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 08:18 PM
  2. Server Lock - saslauthd 100% CPU
    By claros in forum Administrators
    Replies: 2
    Last Post: 10-13-2006, 07:27 AM
  3. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •