Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: [SOLVED] Network password setting - Outlook

Hybrid View

  1. #1
    Join Date
    Oct 2009
    Location
    Malaysia
    Posts
    39
    Rep Power
    6

    Default [SOLVED] Network password setting - Outlook

    Hi there to all Zimbra Guru's,

    I have configured my zimbra server with public IP address, and the A record and DNS is configured well. I can send and receive emails from webmail without any problems or issue to all domains to and flow. But now when i want to configure the Outlook 2003/2007 to use Zimbra pop3 settings, im having some issue here. Everytime i setup the outlook for pop3 setting, when i click the Test message in the Outlook i got this error :

    log on into incoming mail server (pop3) : outlook could not connect to the incomin pop3 mail server because the server did not accept your username or password

    Could someone highlight me anything that im missing here or wrongly configured please ?

    Thank you

    Regards,
    Muthu

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by getridoff View Post
    log on into incoming mail server (pop3) : outlook could not connect to the incomin pop3 mail server because the server did not accept your username or password
    That error would seem to be self explanatory.

    Quote Originally Posted by getridoff View Post
    Could someone highlight me anything that im missing here or wrongly configured please ?
    You haven't actually told us what is configured on your server for access to POP3.

    BTW, you should not use pop3 to connect to a server on a public IP address you should use a secure connection with POP3S.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2009
    Location
    Malaysia
    Posts
    39
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    That error would seem to be self explanatory.

    You haven't actually told us what is configured on your server for access to POP3.

    BTW, you should not use pop3 to connect to a server on a public IP address you should use a secure connection with POP3S.

    Hi again,

    I have checked the username and the password. It is working via webmail and i can send and receive emails with that username and password. It's only appears error when i configured in Outlook, that's why im wondering why is that.

    BTW, sorry for my 1st posting not giving you much about my configuration. Below is my zimbra server configuration for your reference :

    Server settings
    =================

    MTA
    ========
    Webmail MTA hostname --> themindgarden.com
    Webmail MTA port --> 25
    Webmail MTA timeout --> 60
    Relay MTA for external delivery --> empty
    MTA trusted network --> 127.0.0.1/32 202.42.100.12 (i have changed the public IP due to security reason)
    enable dns lookup --> yes

    POP
    =====
    Enable pop3 service --> yes
    pop3 port number --> 110
    address --> empty
    Advertised name --> empty
    number of threads --> 100
    enable ssl for pop3 service --> no
    enable clear text login --> yes


    ------------------------------------------------------------------------------------------------------------------------



    Global settings
    =================

    MTA
    =====
    Enable authentication --> yes
    TLS authentication only --> no
    Webmail MTA hostname --> localhost
    Webmail MTA port --> 25
    Relay MTA for external delivery --> empty
    MTA trusted network --> empty
    enable dns lookup --> yes


    Protocol checks
    ==============
    hostname in greeting violates RFC (reject_invalid_hostname) --> unchecked
    client must greet with fully qualified hostname (reject_non_fqdn_hostname) --> unchecked
    sender address must be fully qualified (reject_non_fqdn_sender) --> unchecked



    PLease highlight me for any erros or mistakes that i have done with the configurations.

    Thank you very much.

    regards,
    Muthu

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by getridoff View Post
    MTA
    ========
    Webmail MTA hostname --> themindgarden.com
    Webmail MTA port --> 25
    Webmail MTA timeout --> 60
    Relay MTA for external delivery --> empty
    MTA trusted network --> 127.0.0.1/32 202.42.100.12 (i have changed the public IP due to security reason)
    enable dns lookup --> yes
    Let's start with the Webmail MTA hostname. Why do you have that entry in there? According to your DNS records it points to a different IP address than your MX records does, is there any reason for that and do you have multiple mail servers?

    Quote Originally Posted by getridoff View Post
    POP
    =====
    Enable pop3 service --> yes
    pop3 port number --> 110
    address --> empty
    Advertised name --> empty
    number of threads --> 100
    enable ssl for pop3 service --> no
    enable clear text login --> yes
    It's really not a good idea (i.e. it's a highly insecure setup) to be using POP3 and with Clear Text login enabled on a Public IP, you should set the clear text login to no and "Enable SSL for POP3 service".

    Quote Originally Posted by getridoff View Post
    Global settings
    =================

    MTA
    =====
    Enable authentication --> yes
    TLS authentication only --> no
    Webmail MTA hostname --> localhost
    Webmail MTA port --> 25
    Relay MTA for external delivery --> empty
    MTA trusted network --> empty
    enable dns lookup --> yes
    You shouldn't need the "Webmail MTA hostname" set at all in either the Global Settings or the Server settings, if they are enabled then the server setting will override the Global. You should also enable "TLS Authentication only" to ensure your external clients are secure.

    Make those changes and try connecting again using the correct ports for POP3 or IMAP.

    I would strongly recommend that you use IMAP instead of POP3 for client connections, they'll have a much better experience with that.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Oct 2009
    Location
    Malaysia
    Posts
    39
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Let's start with the Webmail MTA hostname. Why do you have that entry in there? According to your DNS records it points to a different IP address than your MX records does, is there any reason for that and do you have multiple mail servers?

    It's really not a good idea (i.e. it's a highly insecure setup) to be using POP3 and with Clear Text login enabled on a Public IP, you should set the clear text login to no and "Enable SSL for POP3 service".

    You shouldn't need the "Webmail MTA hostname" set at all in either the Global Settings or the Server settings, if they are enabled then the server setting will override the Global. You should also enable "TLS Authentication only" to ensure your external clients are secure.

    Make those changes and try connecting again using the correct ports for POP3 or IMAP.

    I would strongly recommend that you use IMAP instead of POP3 for client connections, they'll have a much better experience with that.



    Hi Phoenix,

    If im using Public IP for configuring Zimbra server, do i still need to do Split DNS, or creating db.mydomain.com as been explained in Split DNS setup ?

    By the way I will change the webmail MTA hostname and post it to you later.

    Thanks Phoenix..

  6. #6
    Join Date
    Oct 2009
    Location
    Malaysia
    Posts
    39
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Let's start with the Webmail MTA hostname. Why do you have that entry in there? According to your DNS records it points to a different IP address than your MX records does, is there any reason for that and do you have multiple mail servers?

    It's really not a good idea (i.e. it's a highly insecure setup) to be using POP3 and with Clear Text login enabled on a Public IP, you should set the clear text login to no and "Enable SSL for POP3 service".

    You shouldn't need the "Webmail MTA hostname" set at all in either the Global Settings or the Server settings, if they are enabled then the server setting will override the Global. You should also enable "TLS Authentication only" to ensure your external clients are secure.

    Make those changes and try connecting again using the correct ports for POP3 or IMAP.

    I would strongly recommend that you use IMAP instead of POP3 for client connections, they'll have a much better experience with that.


    Hi phoenix,

    I have changed the webmail mta hostname, and the re-confirm and opens the correct port as per your advice. And after a quick re-start Im able to use the pop3 receiving the emails as well.

    There is another function also i have discovered, why i cant receive emails using pop3. When creating new user, i accidently remove the feature of the user's pop3, which makes their accounts unable to receive emails and setup pop3 with Outlook. I got this idea after i checked thru the mail log, which expose the missing feature for that certain users. So what i do is, log back into admin account, edit that certain users account and ticked the Pop3 enable feature for that user, and got receive emails setup in Outlook.

    Im very sorry to say that this is purely my mistake as well, as i did not checked the mail logs earlier. If i did that, i wont be troubling you here ..hope you dont mad at me, as im still in learning phase of zimbra. Yesterday, with your guidance, i have successfully runs the zimbra mail server for the first time in our production line.

    But i have a question and doubt which still playing in my mind. I have successfully deployed Split DNS Zimbra server and used to its settings, and there's a lot of guidance about how to do it in this forum. But if i wanna use the Public IP as Zimbra server IP, do i still need to follow the Split DNS settings also, or i can ignore it? The Public IP Zimbra server sits outside of my firewall box. Perhaps you can input any of your opinion here on how to setup this.

    Thank you phoenix because your always here to help us out!

    Zimbra rocks!

    Regards,
    Muthu

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by getridoff View Post
    I have changed the webmail mta hostname, and the re-confirm and opens the correct port as per your advice. And after a quick re-start Im able to use the pop3 receiving the emails as well.
    Have you also changed it to use a secure connection?

    Quote Originally Posted by getridoff View Post
    But i have a question and doubt which still playing in my mind. I have successfully deployed Split DNS Zimbra server and used to its settings, and there's a lot of guidance about how to do it in this forum. But if i wanna use the Public IP as Zimbra server IP, do i still need to follow the Split DNS settings also, or i can ignore it? The Public IP Zimbra server sits outside of my firewall box. Perhaps you can input any of your opinion here on how to setup this.
    Is this server behind a NAT router or Firewall and is it on a private LAN IP?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    There should be no problems (other than the users must change their settings) if you change POP3 & IMAP to a secure connection. You should also get them to use Port 587 for the Submission port rather than Port 25, port 587 will also require them to authenticate before thy can send email.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Oct 2009
    Location
    Malaysia
    Posts
    39
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    There should be no problems (other than the users must change their settings) if you change POP3 & IMAP to a secure connection. You should also get them to use Port 587 for the Submission port rather than Port 25, port 587 will also require them to authenticate before thy can send email.
    Hi phoenix,

    Then it shouldnt be a problem for both sides as well (client and admin) to change the settings. By default, the zimbra server accepting port 25 without authentication, am i rite ? So i just need to change the port to secure which is 587, rite ? Is there any configuration for this port changing, or i simply can set it up on my zimbra server admin site ?

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by getridoff View Post
    Hi phoenix,

    Then it shouldnt be a problem for both sides as well (client and admin) to change the settings. By default, the zimbra server accepting port 25 without authentication, am i rite ? So i just need to change the port to secure which is 587, rite ? Is there any configuration for this port changing, or i simply can set it up on my zimbra server admin site ?
    You'll find that port 587 is already available to use and does require a user to authenticate, there's nothing you need to do in the Admin UI for that. Port 25 is always open and doesn't require authentication as that's how mail servers connect to each other.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. [SOLVED] Samba password sync
    By lpizzina in forum Administrators
    Replies: 6
    Last Post: 07-11-2010, 09:08 PM
  2. bypass the password history setting
    By tiger2000 in forum Administrators
    Replies: 1
    Last Post: 04-26-2010, 06:25 AM
  3. Zimbra Network Edition and Outlook folder sharing
    By ttaylor in forum Administrators
    Replies: 3
    Last Post: 04-06-2010, 05:05 PM
  4. Replies: 2
    Last Post: 08-06-2009, 11:26 AM
  5. Replies: 9
    Last Post: 12-21-2007, 01:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •