Results 1 to 5 of 5

Thread: FATAL system - out of memory.

Hybrid View

  1. #1
    Join Date
    Jul 2010
    Rep Power

    Default FATAL system - out of memory.

    I have a serious problem with one mailbox that affects our Zimbra system making it crash. We have been using the system in production enviroment for several months without any problem since now.

    At this moment we have the last estable version of ZCS Open Source Edition (6.0.7) over Ubuntu 8.04 64Bits. I have just updated from 6.0.6 last night but it has not solved the problem.

    The problem is that every time one new message arrives to the problematic mailbox, it doesn't gets delivered and in the /opt/zimbra/log/mailbox.log appends a register like this:
    2010-07-01 13:16:53,230 FATAL [LmtpServer-509] [;mid=118;ip=;] system - out of memory
    java.lang.OutOfMemoryError: Java heap space
    at java.util.Arrays.copyOf(
    at java.lang.AbstractStringBuilder.expandCapacity(Abs
    at java.lang.AbstractStringBuilder.append(AbstractStr
    at java.lang.StringBuilder.append( 119)
    at com.zimbra.cs.index.ZimbraAnalyzer$FieldTokenStrea m.addToken(
    at com.zimbra.cs.index.ZimbraAnalyzer$FieldTokenStrea m.bufferNextLine(
    at com.zimbra.cs.index.ZimbraAnalyzer$FieldTokenStrea
    at org.apache.lucene.index.DocInverterPerField.proces sFields(
    at org.apache.lucene.index.DocFieldConsumersPerField. processFields(
    at org.apache.lucene.index.DocFieldProcessorPerThread .processDocument( 34)
    at org.apache.lucene.index.DocumentsWriter.updateDocu ment(
    at org.apache.lucene.index.DocumentsWriter.addDocumen t(
    at org.apache.lucene.index.IndexWriter.addDocument(In
    at org.apache.lucene.index.IndexWriter.addDocument(In
    at com.zimbra.cs.index.LuceneIndex.addDocument(Lucene
    at com.zimbra.cs.index.MailboxIndex.indexMailItem(Mai
    at com.zimbra.cs.mailbox.IndexHelper.indexingPartOfEn dTransaction(
    at com.zimbra.cs.mailbox.Mailbox.endTransaction(Mailb
    at com.zimbra.cs.mailbox.IndexHelper.indexItemList(In
    at com.zimbra.cs.mailbox.IndexHelper.indexDeferredIte msInternal(
    at com.zimbra.cs.mailbox.IndexHelper.indexDeferredIte ms(
    at com.zimbra.cs.mailbox.IndexHelper.maybeIndexDeferr edItems(
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4310)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4303)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4251)
    at com.zimbra.cs.filter.IncomingMessageHandler.addMes sage(
    at com.zimbra.cs.filter.IncomingMessageHandler.implic itKeep(
    at com.zimbra.cs.filter.ZimbraMailAdapter.doDefaultFi ling(
    at com.zimbra.cs.filter.ZimbraMailAdapter.executeActi ons(
    at org.apache.jsieve.SieveFactory.evaluate(SieveFacto
    at com.zimbra.cs.filter.RuleManager.applyRulesToIncom ingMessage(

    After several deliver tries with the same error, the Zimbra system crashes and we have to restart it in order to have the service up again.

    I can access this problematic mailbox form any IMAP client even from the Zimbra webmail. I can even copy it to another mailbox using the imapsync tool, but the problem persists in the new mailbox.

    It is very surprising to me that a problem in one mailbox may originate the failure of all the Zimbra system.

    How can I solve this problem?
    Any help is welcome.

    Thank you very much for your help.
    Best regards.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    So, how much RAM is on this system?


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Nov 2006
    Rep Power


    As Phoenix has asked how much physical RAM plus the following
    su - zimbra
    zmlocalconfig | grep -i mailboxd_java

  4. #4
    Join Date
    Jul 2010
    Rep Power


    Our server has 8GB of RAM:
    # free
    total used free shared buffers cached
    Mem: 8190040 5965752 2224288 0 359652 2759216
    -/+ buffers/cache: 2846884 5343156
    Swap: 3903752 0 3903752

    $ zmlocalconfig | grep -i mailboxd_java
    mailboxd_java_heap_memory_percent = 40
    mailboxd_java_heap_new_size_percent = 25
    mailboxd_java_options = -server -Djava.awt.headless=true -XX:+UseConcMarkSweepGC -XX:NewRatio=2 -XX:PermSize=128m -XX:MaxPermSize=128m -XX:SoftRefLRUPolicyMSPerMB=1 -verbose:gc -XX:+PrintGCDetails -XX:+PrintGCTimeStamps -XX:+PrintGCApplicationStoppedTime

  5. #5
    Join Date
    Sep 2011
    Rep Power


    same here, i got:

    $ free
    total used free shared buffers cached
    Mem: 4058256 4029124 29132 0 30616 221140
    -/+ buffers/cache: 3777368 280888
    Swap: 3035128 111736 2923392

    $ zmlocalconfig | grep -i mailboxd_java
    mailboxd_java_heap_new_size_percent = 25
    mailboxd_java_heap_size = 998
    mailboxd_java_options = -server -Djava.awt.headless=true${networkaddress_cache_ttl} -XX:+UseConcMarkSweepGC -XX:PermSize=128m -XX:MaxPermSize=128m -XX:SoftRefLRUPolicyMSPerMB=1 -verbose:gc -XX:+PrintGCDetails -XX:+PrintGCTimeStamps -XX:+PrintGCApplicationStoppedTime -XX:-OmitStackTraceInFastThrow

    we think that is problem of spam but... still with downs of zimbra, if someone know about this, please help i run out of ideas..

    Thanks and happy new year

Similar Threads

  1. Replies: 43
    Last Post: 11-26-2011, 08:27 PM
  2. mysql not starting, sort of.
    By lhutton in forum Installation
    Replies: 6
    Last Post: 06-19-2009, 10:45 AM
  3. [SOLVED] Error running mailboxd after script backup
    By ttortosa in forum Administrators
    Replies: 5
    Last Post: 10-22-2008, 01:33 AM
  4. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  5. Replies: 2
    Last Post: 02-12-2008, 10:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts