Results 1 to 3 of 3

Thread: [SOLVED] virtual hosts and logging in

  1. #1
    Join Date
    Jun 2010
    Posts
    9
    Rep Power
    5

    Question [SOLVED] virtual hosts and logging in

    Hi all,

    I have just added a second domain to my ZCS installation. ZCS was originally installed with xyz.com as the sole domain. I have now added the abc.com domain without issue.

    I have two users;

    xyz_user belongs to the xyz.com domain and abc_user belongs to the abc.com domain.

    When I navigate to webmail.xyz.com is should and logon as xyz_user without having to enter the '@xyz.com'. I believe this is normal behaviour. However when I navigate to webmail.abc.com and try to logon as abc_user (without the @abc.com entered) I am unable to logon.

    As far as I understand zcs is supposed to pickup with url I have entered and then infer from that which is the default domain.

    Could someone please help me so that xyz_user doesn't have to specify @xyz.com when they have entered webmail.xyz.com as the URL and similarly for the abc_user when they have entered the abc.com URL.

    ZCS is running on a single machine with one IP address. Both webmail.xyz.com and webmail.abc.com resolve to this address.

    Cheers ws

  2. #2
    Join Date
    Dec 2009
    Location
    Michigan
    Posts
    454
    Rep Power
    5

    Default

    Quote Originally Posted by websavages View Post
    Hi all,

    As far as I understand zcs is supposed to pickup with url I have entered and then infer from that which is the default domain.

    Cheers ws
    Not if you didn't fill out the 'Virtual Hosts' tab for each domain.

    Doug
    Ben Franklin quote:

    "Those who would give up Essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety."

  3. #3
    Join Date
    Jun 2010
    Posts
    9
    Rep Power
    5

    Default

    Hi Doug,

    Thanks for the information regarding the Virtual Hosts tab. I filled in webmail.xyz.com as a virtual host for the xyz.com domain and webmail.abc.com as a virtual host for the abc.com domain. I gave ZCS a reboot (zmcontrol stop and start) and it works.

    Cheers ws

Similar Threads

  1. Replies: 11
    Last Post: 10-26-2010, 04:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •